Sign in with
Sign up | Sign in
Your question
Solved

Questions about slowdown

Tags:
Last response: in CPUs
Share
July 18, 2012 5:04:02 PM

Specs are in my sig, but here is my dilemma:

After installing my new build, I reinstalled Windows, all my programs and games. However, when I load some games (Dirt 3, BF3, Skyrim) it won't load all the way through and I will experience SEVERE slowdown to a point where I can do anything except hard-restart.

Fifa 12 will take multiple times of me going into Origin and clicking "play" in order for it work.

I have checked all my connections and ran an anti-virus program to no avail. I did change some of the startup settings in "MSconfig" but I don't think that would affect anything. It is ONLY games that are affected.

Possibly heat with the CPU. I have it OC'ed but have an aftermarket cooler.

Does anyone have any ideas? Or am I going to have to reinstall windows?
---
Intel i5-2500k @ 4.0 ghz | 8GB G.Skill DDR3 RAM | Sapphire Radeon 6970 | ASRock Z77 Pro | CM - Hyper 212 | OCZ 700W PSU | CM - Scout | 24'' LCD 1080p | 5.1 SS

More about : questions slowdown

a c 218 à CPUs
July 18, 2012 10:26:23 PM

Have you tried a bios update for the motherboard? The zz77 chipset was a new releaes chipset for the Ivy Bridge cpu and to use the 2500k in that MB you may need a bios update.
m
0
l
a c 307 à CPUs
July 19, 2012 2:48:36 AM

After a new install of Win7, all of the updates, and tons of new programs, I always clean the system of registry errors and other resource wasting crap with CCleaner. Do the Clean and Registry both. You may want to run it a couple times. That will at least determine if the problem is related to those issues.

And check your System Config to see what you can disable that may be conflicting with your gaming. I normally only have a half dozen or so items checked.
m
0
l
Related resources
Can't find your answer ? Ask !
July 19, 2012 1:42:56 PM

inzone said:
Have you tried a bios update for the motherboard? The zz77 chipset was a new releaes chipset for the Ivy Bridge cpu and to use the 2500k in that MB you may need a bios update.


I am looking around for the bios update for the z77 chipset but can't seem to find it on the site (I am confused by all of the downloads on there). Just download all of those? I installed drivers from the CD, but I think these are updated ones? No?

Edit:

http://www.asrock.com/mb/Intel/Z77%20Pro4/?cat=Download...

Anyone care to help?
m
0
l

Best solution

a b à CPUs
July 19, 2012 1:49:50 PM

You want BIOS version 1.30. Either use the instant flash (read your manual) or the Windows executable.
Share
a b à CPUs
July 19, 2012 1:55:53 PM

Which Z77 Pro do you have? There are several of them
m
0
l
July 19, 2012 2:04:11 PM

abekl said:
Which Z77 Pro do you have? There are several of them


I have to check when I get home, but I can use the Windows executable to download it, whether it is 1.30 or 1.40.

And just follow the instructions on the site?
m
0
l
a b à CPUs
July 19, 2012 5:01:08 PM

That's correct
m
0
l
July 19, 2012 5:03:15 PM

abekl said:
That's correct


Thanks. I will test all of my games and see what happens after the update. So far it is just BF3 and Dirt3, even though Battlefield worked at one point and stopped working.

All my other games, Arma2, ME3, New Vegas, Fifa 13 all work without a hitch. As well, everything else works with the OS.

So not sure if this does not solve it.
m
0
l
a c 218 à CPUs
July 19, 2012 5:26:12 PM

If all of those games are steam games then you can also try updating or reinstalling steam.
m
0
l
July 19, 2012 5:32:14 PM

Just Dirt 3, BF3 is Origin.

Not sure which version I have, since I am not home yet.
m
0
l
a c 218 à CPUs
July 19, 2012 5:35:18 PM

You can also reinstall Origin also since these games seem to use these clients to run thier games and it doesn't take much to corrupt a file.
m
0
l
July 19, 2012 6:05:00 PM

inzone said:
You can also reinstall Origin also since these games seem to use these clients to run thier games and it doesn't take much to corrupt a file.


Yea I reinstalled both Steam and Origin, to no avail.
m
0
l
July 20, 2012 12:47:14 AM

UPDATE
UPDATE
UPDATE
UPDATE
UPDATE

I was able to get into task manager while trying to load BF3 and apparently a program was causing the CPU and RAM usage to skyrocket to 100% in use. I had this "EKag20nt.exe" program running over 1,000 times.

THAT was the culprit, a reason for the slowdown and crashing. I located it on my computer, in some "lucidxtechnology" folder and uninstalled it. The program comes with the motherboard I believe, so it was corrupted the games somehow.

All games working fine right now. Thanks everyone for your help.
m
0
l
July 20, 2012 12:47:33 AM

Best answer selected by xunleashed.
m
0
l
!