Sign in with
Sign up | Sign in
Your question

Power button on Thermaltake Chaser MK-I case won't work. :(

Last response: in Systems
Share
April 7, 2012 5:05:36 AM

Hey all, I just recently built my new pc in Thermaltake Chaser MK-I case case and a ASUS P8Z68-V LE LGA 1155 Intel Z68 motherboard.

I swear to god, I feel like I've connected everything right... but the power button/reset/fan buttons will not work. The motherboard has power (The green light on it lights up when I switch the power supply on) but it seems I can't get the power to the starter panel?

Is this related to my power supply? It's a 750 watt. I'm running an ATI HD 5870, Intel i5 2500k, 8 Gbs of ram. I thought my PSU would be able to handle that...

Thank you for the time... I really can't figure this out. :( 
April 7, 2012 5:12:17 AM

Try flipping the positioning on the reset and power button connectors. Are your positive and negative LED connectors matching the positive and negative LED pins?
m
0
l
April 7, 2012 5:17:33 AM

See that's the thing, I tried flipping the positioning of the reset and power connectors multiple times. I also tried flipping the power and ground connections which are put together. Why this didn't work, I'm not sure. Thanks for replying btw, I appreciate it. I need all the help I can get. lol

m
0
l
Related resources
April 7, 2012 6:52:00 AM

Short/jumper the pins for pwr sw with a screwdriver or similar, does it fire up? issue is the button/wiring, contact manf for replacement :) 
few of these threads today, maybe a bad wire epidemic?
:p 
Moto
m
0
l
April 7, 2012 6:13:23 PM

Just tried it... and sadly it doesn't. I also tried jump starting it with wire too. :(  This is so weird, because power is going through the motherboard... it makes no sense why this isn't working.

I just recently called Asus support to see if they had any idea what was going on... after explaining everything, he came to the conclusion that it has something to do with my power supply. Though, with 750 watts, he said that was enough to start up the system.

It's so damn frustrating to know I was THIS close to starting it up, just to have some stupid panel not work.
m
0
l
April 7, 2012 6:14:31 PM

Does the computer work if you manually press the power button?
m
0
l
April 7, 2012 6:27:37 PM

He said in OP that power button doesn't work. :) 
m
0
l
April 7, 2012 6:32:14 PM

To the case buttons, but the manual power button should still work, right.
m
0
l
April 7, 2012 6:33:13 PM

Oh, the button on the motherboard. Silly me.
m
0
l
April 7, 2012 7:03:28 PM

I've been looking for a manual power button, but I can't seem to find one. The only button I see on this specific motherboard is the "MemOk" button. Hopefully I'm not blind lol.

BTW, I thought of something. If the hard drives were put into the motherboard incorrectly, could that cause a problem like this?


And yet again, thank you guys for responding. I really appreciate it. :) 
m
0
l
April 7, 2012 8:40:33 PM

Finally, I found something out!

I took the motherboard out of the case, put it on a cardboard box, plugged everything back in, and it worked! Pc went on, showed on the monitor, and the fans were rolling. I think the case isn't grounded? I need to search on how to do that. lol
m
0
l
April 7, 2012 8:42:04 PM

I think it was shorting somewhere. Try putting in the standoffs again.
m
0
l
April 7, 2012 9:01:40 PM

azeem40 said:
I think it was shorting somewhere. Try putting in the standoffs again.


Will do dude. Though I have to ask, is there any specific way I can avoid this from happening again? I really don't want to put everything back to get the same exact problem. :??:  Thanks again!
m
0
l
April 7, 2012 9:03:11 PM

Other than placing the standoffs, I don't know of any other way.
m
0
l
!