Sign in with
Sign up | Sign in
Your question

Kuhler 92- connection issue

Last response: in Components
Share
July 20, 2012 6:19:12 PM

Rig specs:

motherboard - sabertooth 990fx
CPU - amd bulldozer FX 8150 (cooled by kuhler 920)
PSU - corsair AX1200
Graphics - 1x HIS Radeon 6950 x 2GB turbo / 1x HIS Radeon 6950 x 2GB crossfired
Sound - Recon 3d Fatality
16GB corsair vengence Ram at 1666 (4x4GB)
2x 120gb corsair SSD
1x 60gb corsair SSD (OS)
1x 1TB WD HDD



ALL drivers have been checked and updated.
Bios is updated.


Problem:
'Cannot connect to Chill Control device'

- The pump is running on silent when plugged in and the light on the pump is on
- It was working previously, then i switched my hardware to a different case and now it won't work.
- Everything is plugged in to exactly the same spot.
- I've plugged the cable into both usb headers in every way possible.
- Doesn't show up in device manager
- Have reinstalled

I've searched loads of forums and tried for hours to fix it.

any help is appreciated. thanks.
July 30, 2012 4:44:39 PM

ebmurray21 said:
Rig specs:

motherboard - sabertooth 990fx
CPU - amd bulldozer FX 8150 (cooled by kuhler 920)
PSU - corsair AX1200
Graphics - 1x HIS Radeon 6950 x 2GB turbo / 1x HIS Radeon 6950 x 2GB crossfired
Sound - Recon 3d Fatality
16GB corsair vengence Ram at 1666 (4x4GB)
2x 120gb corsair SSD
1x 60gb corsair SSD (OS)
1x 1TB WD HDD



ALL drivers have been checked and updated.
Bios is updated.


Problem:
'Cannot connect to Chill Control device'

- The pump is running on silent when plugged in and the light on the pump is on
- It was working previously, then i switched my hardware to a different case and now it won't work.
- Everything is plugged in to exactly the same spot.
- I've plugged the cable into both usb headers in every way possible.
- Doesn't show up in device manager
- Have reinstalled

I've searched loads of forums and tried for hours to fix it.

any help is appreciated. thanks.



I'm aware of this issue especially with the software not recognizing the unit when connecting the USB. Please create a ticket for this issue that you're having with the Kuhler 920 by going to this website

http://www.antec.com/index.php?page=support_online

Once you have created the ticket, we can process a RMA for that defective unit.

Thanks
!