Display not working after core 2 quad q8200

I just acquired a core2quad Q8200 to replace my system's old E7500, but after installing it and booting up the system, the display doesn't work. The system starts up, but there's no sound, no video, nothing. It works fine with my E7500(I plugged it back in to check), but not with the quad core. I've tried moving the bios jumper, but that didn't work.

Specs:
Windows 7 Ultimate 32-bit
Asus eMachines motherboard(unknown model)
OCZ 750W PSU
Zotac GeForce 9600GT 1GB
Kingston 2GB DDR2 RAM(x2)
Seagate Barracuda 7200.12 500GB HDD(x2)


Any suggestions?
2 answers Last reply
More about display working core quad q8200
  1. Hi :)

    Its pretty obvious that your motherboard does not support that cpu, ... you DID check BEFORE you bought the quad of course ???

    You will have to use the old cpu.... or buy another motherboard that DOES support the quad...

    All the best Brett :)
  2. After some bios digging, it's actually NOT an Asus board, but an Intel D945GCL, and unfortunately I didn't check beforehand. However, upon looking up a list of compatible processors, the neither the Pentium 4 2.99GhZ, or the Core2Duo E7500 that I was running beforehand wasn't on the list of compatible CPUs, yet it ran fine with both. What worries me is that after upgrading the motherboard drivers(A few other results via Google said that it had worked), now NONE of my CPUs work, they all give the same issue, and with no beep codes.
Ask a new question

Read More

CPUs Displays