New Graphics card... Blank monitor?

I have recently purchased the ATI radeon HD 5570 and tried to install it onto my Compaq Pavilion sr1750nx (I have upgraded this computers RAM to 3 gigs and the power supply to 400 watts). My problem is that when I install it and attempt to turn the computer on, everything starts to run (Like I can here the fans) except I get no picture on my screen. Somethings to note is that I use an onboard graphics card and everything works perfectly when I use that so it is not a problem with other hardware not working. If you could help me that would be great! Here are some useful specs are...

Graphics card (The one I am trying to install): PowerColor AX5570 1GBD3-H Radeon HD 5570 1GB 128-bit DDR3 PCI Express 2.1 x16 HDCP Ready Video Card

Computer: Compaq Pavilion sr1750nx
7 answers Last reply
More about graphics card blank monitor
  1. Disable your onboard graphics in device manager or your system BIOS then put in the card and make sure it is properly seated in the PCIe slot. It will run in low-res mode for a bit then either Windows will find and install the drivers online (if you have 7 and set it to do that) or you can go to AMD's website and DL drivers.
  2. Vettedude said:
    Disable your onboard graphics in device manager or your system BIOS then put in the card and make sure it is properly seated in the PCIe slot. It will run in low-res mode for a bit then either Windows will find and install the drivers online (if you have 7 and set it to do that) or you can go to AMD's website and DL drivers.

    If I had already installed the drivers before putting it in should I just uninstall them? Or should I be fine?
  3. Did you disable the onboard graphics though?
  4. Vettedude said:
    Did you disable the onboard graphics though?

    Yeah I've done that.
  5. What is the brand of your PSU?
  6. Vettedude said:
    What is the brand of your PSU?

    Cooler Master
  7. Did you ever resolve the problem with your pci-e card in the Compaq SR1750?

    I am having the same problem.

    I will add this, with the PCIe card installed (ASUS HD 5450) the pc will not boot, it won't even make the initial kick of the fan speed.

    Thanks
Ask a new question

Read More

Graphics Cards Graphics