Sign in with
Sign up | Sign in
Your question

Restart instead of Shutdown - Randomly

Last response: in Systems
Share
April 10, 2012 11:12:47 AM

Hello,

My new system has been running for several weeks now and seems pretty stable. Every now and then when I shutdown the computer, it does a restart instead. There's no system errors and the restart on errors isn't set. Sometimes if I run a long job like a video render or backup, I set to shutdown when complete but it may do a restart instead. I've watched it do the restart so it's not that it just didn't shutdown.

Sometimes I walk away from the pc thinking it's going to shutdown and there it is running. Pretty annoying as I need to watch it shutdown if I need to leave the house to make sure it's off.

Is there a bios setting that may be causing this or something with Windows XP? It's strange it would happen randomly if something was set wrong.

ASROCK 880gm-le
AMD Athlon X3 455
Corsair Memory
Windows XP SP3

Thanks
April 10, 2012 10:42:20 PM

Could be a bad PSU. Problems with startup, shutdown, sleep, hibernate, and that sort of thing are often related to a bad PSU.

Also, just wondering, why do you need to make sure it is off when you leave the house?

What is preventing you from letting the computer go into sleep or hibernate mode instead of shutting it down?
m
0
l
April 11, 2012 11:03:43 AM

Raiddinn said:
Could be a bad PSU. Problems with startup, shutdown, sleep, hibernate, and that sort of thing are often related to a bad PSU.

Also, just wondering, why do you need to make sure it is off when you leave the house?

What is preventing you from letting the computer go into sleep or hibernate mode instead of shutting it down?

I've got a brand new Thermatake 600w power supply. Hate to think it's bad already. Any way to prove it's the problem without putting another psu in?

Wouldn't leave computer running when not home any more than leaving lights on. Saw Mythbusters episode where they proved leaving lights on did indeed use more electricity than turning them on uses, unlike what the electric companies have been telling us for years.

m
0
l
Related resources
April 11, 2012 2:14:33 PM

Even if you turn the computer off, there is still power running through it unless you take the cord out of the wall, just like with microwaves and stuff.

The power button needs to be powered at all times even if the computer is off so that you can turn it on when you want.

There is no difference between turning it off with the shutdown command and letting it lapse into sleep mode except that it starts up a whole lot faster from sleep mode than from a turned off state.

Both ways just use the minimal amount of power that is present in an off state just like the power button uses.

Also, I would love to be able to tell you that it doesn't sound like a PSU problem to me, but I really can't. Thermaltake doesn't have a good reputation and I am unwilling to trust their brand new PSUs to work as described based on their track history of quality.

There are really not very many ways you can completely test a PSU without switching it out.

You can tell if you are at or slightly above a PSUs break point by removing components. The graphics card is a big one if you have integrated graphics on your processor or motherboard.

If you can start the computer and use it regularly after removing a component that pulls a lot of juice from the PSU, then its probably not a good enough PSU.

That is the best test that can be done without switching out the PSU, but it comes nowhere near to providing equally trustworthy results.

The best thing to do is to try to borrow a good PSU from somewhere else and trying it.

If you are able to take the Thermaltake back to the store for a refund or store credit, Antec, Corsair, Seasonic, and XFX are much better brand names.
m
0
l
April 11, 2012 2:33:03 PM

Driver issues can cause this behavior. Make sure Wake On LAN is disabled in the BIOS and/or NIC settings in the OS.

You are shutting down via the start>shutdown button correct? You can change what is says by default. What kind of video card are you using? Check those drivers out make sure you have the latest. Nvidia drivers have caused this bahavior before. Check this link: http://forums.nvidia.com/index.php?showtopic=185107

m
0
l
April 11, 2012 5:47:35 PM

odwillia said:
Driver issues can cause this behavior. Make sure Wake On LAN is disabled in the BIOS and/or NIC settings in the OS.

You are shutting down via the start>shutdown button correct? You can change what is says by default. What kind of video card are you using? Check those drivers out make sure you have the latest. Nvidia drivers have caused this bahavior before. Check this link: http://forums.nvidia.com/index.php?showtopic=185107


Don't see a Wake On Lan in the cmos settings

NIC drivers:
- Wake on Lan Capabilities = Pattern Match & Magic Packet
- Shutdown Wake On Lan = Enabled
Realtek PCIe GBE on board network card

Yes, shutdown via start>turn off computer

MB has onboard video Radeon 4250 and have the latest drivers.
m
0
l
April 12, 2012 12:25:18 AM

Just wondering, did this problem exist before you changed the PSU?

Also, I really think you should go into the energy settings and try to use sleep mode and see if that gives you the results you want without you having to worry about any of this stuff at all.
m
0
l
April 12, 2012 11:19:51 AM

Raiddinn said:
Just wondering, did this problem exist before you changed the PSU?

Also, I really think you should go into the energy settings and try to use sleep mode and see if that gives you the results you want without you having to worry about any of this stuff at all.


Thanks again for the input.

I never replaced the psu. It's a new build with a new Thermaltake 600w psu.

I'll give the suspend/sleep a try but still want to solve this problem.
m
0
l
April 13, 2012 4:17:54 AM

Try to find someone you can borrow a different PSU from. Ask a relative or something.

I still think it is because of the PSU. I also just think you can maybe get by with the same PSU if you just avoid the problem entirely and get lucky in that this PSU works fine going back and forth out of sleep mode.

I have honestly no good reason to believe that sleep mode will work better with this PSU than restarting would, but its possible that it does.

Usually, I would just suggest getting a name brand PSU which doesn't come with a similar problem set, but I am hoping to save you the expense.
m
0
l
April 14, 2012 7:21:10 PM

Thanks.

An electrical engineer friend of mine suggest I reseat the psu motherboard plugs. I did that and we'll see. Easier than swapping them out. If that doesn't work I'll try with the other guy suggested, Wake On Lan and finally try to find a psu to swap out.
m
0
l
May 23, 2012 1:11:04 PM

Thought I had this handled by reseating the motherboard plugs but I hadn't rendered any videos lately.

System still restarts when I issue the shutdown command but happens more after I've rendered a video or done a system backup. Something that takes some time and uses the system hard.

Tried the wake on lan - disabled - still happens

Swapped out power supply last night. Ran system for 45min doing basic internet, word processing and it shutdown fine. Rendered a video that took 45 min and when shutting down, did a restart instead.

I hate to swap out motherboards but I've run out of ideas.

Any other thoughts of things to try?

Thanks
m
0
l
May 23, 2012 1:18:38 PM

I had this exact problem with an evga classified a while back, flashed the BIOS and no more problem, could be something to try.

Mine would also randomly turned on at night so could be a different problem though.
m
0
l
!