HD 7970 Drive Issues

Build is as follows; (Fresh Build)

PC Power and Cooling Silencer Mk II 950W High Performance
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600
ASUS P8Z68 DELUXE/GEN3 LGA 1155 Intel Z68 SATA 6Gb/s USB 3.0 ATX
Intel Core i5-2500K Sandy Bridge 3.3GHz
Crucial M4 CT128M4SSD2 2.5" 128GB SATA III
SAPPHIRE 21197-00-40G Radeon HD 7970 3GB
Win 7 Pro 64-bit

When I install the drivers given to me on the disc, all is well and I restart my PC after they've taken place. Upon boot up, I can see my bios screen and "Starting Windows" screens. After that, nothing, screen goes into hibernate. I can run in Safe mode and everything works per usual, no issues. I roll back the driver and restart in Normal Mode and everything is back to how it was before installing drivers. I believe the driver version that's giving me issues is 8.921xx or something like that. I also get a "Cannot Find/Load Device Driver". (Or something similar to that)
7 answers Last reply
More about 7970 drive issues
  1. What about the driver on the website? Safe Mode with Networking.
  2. Tried it, but just in case, can you link me to be sure?
  3. Hm. The AMD driver site doesn't seem to be working for the 7000 series.
  4. I just did a fresh build with a 7970 and it works fine with the drivers from the cd. (tried online first but AMD site didnt want to give me any) I have the same MB, CPU, and RAM as you on win 7 home 64-bit and it works fine. Did you install all the drivers that came with your MB?

    My driver is 8.921.0.0 btw.
  5. Seems AMD's site is having a little problem, but if you go around in a different route, you can still find the right drivers. Try these: http://support.amd.com/us/kbarticles/Pages/RC11Driver.aspx
  6. Yeah, i have the drivers that came for the mb cd. And that is the download i tried as far as the gpu goes. Still having no luck.
  7. Found this possible solution online if you want to give it a shot:

    - Plug And Play O/S (Advanced > PCI/PnP Settings): Changed from Yes to No.
    - Initiate Graphic Adapter (Advanced > Chipset Settings > North Bridge Chipset Configuration): Changed from PEG/PCI to PCI/PEG.
    Saved changes, reboot, installed drivers again, reboot, and... IT WORKED! So changing one (or both) of those settings above did the job. I don't feel like figuring out which of the those two settings was really responsible for the trouble right now (already spent way to much time on this), but i post this for people with the same problem googling for an answer.

    here is the link too : http://en.kioskea.net/forum/affich-6888-black-screen-after-windows-load
Ask a new question

Read More

Radeon Graphics