NO DISPLAY ON TEST BUILD-What is going on?

Specs:
Asrock Extreme4 x79
hyper 212 evo
3 gb EVGA GTX 580
3930k
32gb 4x8gb 1333 g skill ripjaws
psu-raidmax rx1000ae 1000w

NO DISPLAY!

I'm doing my test build..at first the gpu wasn't installed right (I had only one pcie power ad apter in instead of the two) but the motherboard came on with the cpu, the cpu fan, and the memory. I installed the GPU correctly using one of the pcie cables the psu came with by filling the other hole (or w.e) but still no display (the gpu fan runs.) And idk if I'm supposed to hear a beep from the mobo or if I hear it from a speaker (which I do not have.)
7 answers Last reply
More about display test build what
  1. Its on now. Still nothing on the screen :(
  2. Your motherboard might be fried. Try switching out parts one by one, or look up some symptoms of a fried motherboard.
  3. Anyone else?
  4. Try a different PCIe slot. Or, if you can get your hands on one, try a different graphics card.
  5. I tried a different PCIe slot. No avail. I'm doing this with no RAM in now. Still doesn't work. Apparently the 8gb ripjaws sticks aren't on the compatibility list here http://www.asrock.com/mb/memory.us.asp?Model=X79%20Extreme4 I just realized, but someone on this forum said it wouldn't matter.
  6. Tomorrow I'll check the boards and resume. I'm going to look at the CPU to see if there are any bent pins..but that basically could be it. This is so frustrating.
  7. It IS possible to correct bent pins, but it's risky (although if they're bent, you don't have anything to lose). Just look it up... you use a mechanical pencil.
Ask a new question

Read More

Build Systems Displays