Sign in with
Sign up | Sign in
Your question

How can I change the file type?

Last response: in Windows XP
Share
November 3, 2004 11:43:02 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

In internet explorer when I choose file>Save as...> a window appears titled
Save Web Page.

Within that window "Web Page,complete" appears in the Save as type
dropdown menu.
Is it possible to change "Web Page,complete" to "Web Page,HTML only" as the
first option that appears?
Any suggestions? Thank You.

More about : change file type

Anonymous
November 3, 2004 3:19:11 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

dusty wrote:
> In internet explorer when I choose file>Save as...> a window appears
> titled Save Web Page.
>
> Within that window "Web Page,complete" appears in the Save as type
> dropdown menu.
> Is it possible to change "Web Page,complete" to "Web Page,HTML
> only" as the first option that appears?
> Any suggestions? Thank You.

No. We have been looking for a way to do this since IE4 first came out.
Nothing yet. :) 

--
Ronnie Vernon
Microsoft MVP
Windows Shell/User
November 3, 2004 8:48:03 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"Ronnie Vernon MVP" wrote:

> dusty wrote:
> > In internet explorer when I choose file>Save as...> a window appears
> > titled Save Web Page.
> >
> > Within that window "Web Page,complete" appears in the Save as type
> > dropdown menu.
> > Is it possible to change "Web Page,complete" to "Web Page,HTML
> > only" as the first option that appears?
> > Any suggestions? Thank You.
>
> No. We have been looking for a way to do this since IE4 first came out.
> Nothing yet. :) 
>
> --
> Ronnie Vernon
> Microsoft MVP
> Windows Shell/User
>
> Thank You for taking the time to reply Ronnie
>
Related resources
Anonymous
November 3, 2004 9:14:27 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

dusty wrote:
>> Thank You for taking the time to reply Ronnie

Your very welcoms. Have fun. :) 

--

Ronnie Vernon
Microsoft MVP
Windows Shell/User
November 4, 2004 5:51:41 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi Dusty,

Go to Windows Explorer/Tools/Folder Options/View and check your options
under Managing pairs of Web pages and folders. This can also be handled via
gpedit and/or the registry.

--
All the Best,
Kelly

Microsoft-MVP Windows® XP-Shell/User
2004 Windows MVP "Winny" Award

Troubleshooting Windows XP
http://www.kellys-korner-xp.com

Taskbar Repair Tool Plus!
http://www.kellys-korner-xp.com/taskbarplus!.htm


"dusty" <dusty@discussions.microsoft.com> wrote in message
news:C5112625-43E9-45B4-AAF9-C8675C88B7D2@microsoft.com...
>
> In internet explorer when I choose file>Save as...> a window appears
> titled
> Save Web Page.
>
> Within that window "Web Page,complete" appears in the Save as type
> dropdown menu.
> Is it possible to change "Web Page,complete" to "Web Page,HTML only" as
> the
> first option that appears?
> Any suggestions? Thank You.
Anonymous
November 5, 2004 1:11:58 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"Kelly" <kelly@mvps.org> wrote
| Hi Dusty,
|
| Go to Windows Explorer/Tools/Folder Options/View and check your options
| under Managing pairs of Web pages and folders. This can also be handled via
| gpedit and/or the registry.
|
| --
| All the Best,
| Kelly
|
| Microsoft-MVP Windows® XP-Shell/User
|
| "dusty" <dusty@discussions.microsoft.com> wrote in message
| news:C5112625-43E9-45B4-AAF9-C8675C88B7D2@microsoft.com...
| >
| > In internet explorer when I choose file>Save as...> a window appears
| > titled
| > Save Web Page.
| >
| > Within that window "Web Page,complete" appears in the Save as type
| > dropdown menu.
| > Is it possible to change "Web Page,complete" to "Web Page,HTML only" as
| > the first option that appears?
| > Any suggestions? Thank You.

In SP1, Windows Explorer/Tools/Folder Options/View does not have options
under Managing pairs of Web pages and folders. Nor in
Internet Explorer/Tools/Internet Options/Advanced.

In gpedit.msc, there used to be a setting "Manage Connected Items as a Unit",
but if you enabled that setting, then if you delete the html file, it would
automatically delete the html_files folder as well.

There is a setting to _remove_ "Save As Web Page Complete".
This might make "Save As HTML" the default in the "Save as" dialog.

In XP Pro,
Start
Run
gpedit.msc
Enter

User Configuration
Administrative Templates
Windows Components
Internet Explorer
Browser Menus
File menu: Disable Save As Web Page Complete
Anonymous
November 5, 2004 1:11:59 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

a nonymous wrote:
> "Kelly" <kelly@mvps.org> wrote
>> Hi Dusty,
>>
>> Go to Windows Explorer/Tools/Folder Options/View and check your
>> options under Managing pairs of Web pages and folders. This can
>> also be handled via gpedit and/or the registry.
>>
>> --
>> All the Best,
>> Kelly
>>
>> Microsoft-MVP Windows® XP-Shell/User
>>
>> "dusty" <dusty@discussions.microsoft.com> wrote in message
>> news:C5112625-43E9-45B4-AAF9-C8675C88B7D2@microsoft.com...
>>>
>>> In internet explorer when I choose file>Save as...> a window appears
>>> titled
>>> Save Web Page.
>>>
>>> Within that window "Web Page,complete" appears in the Save as type
>>> dropdown menu.
>>> Is it possible to change "Web Page,complete" to "Web Page,HTML
>>> only" as the first option that appears?
>>> Any suggestions? Thank You.
>
> In SP1, Windows Explorer/Tools/Folder Options/View does not have
> options under Managing pairs of Web pages and folders. Nor in
> Internet Explorer/Tools/Internet Options/Advanced.
>
> In gpedit.msc, there used to be a setting "Manage Connected Items as
> a Unit", but if you enabled that setting, then if you delete the html
> file, it would automatically delete the html_files folder as well.
>
> There is a setting to _remove_ "Save As Web Page Complete".
> This might make "Save As HTML" the default in the "Save as" dialog.
>
> In XP Pro,
> Start
> Run
> gpedit.msc
> Enter
>
> User Configuration
> Administrative Templates
> Windows Components
> Internet Explorer
> Browser Menus
> File menu: Disable Save As Web Page Complete

I tested this and that setting does remove the Web Page, Complete (*.htm
*.html) and it also removes the Web Archive, single file (*.mht). It leaves
the default selection as Web Page, HTML only (*.htm;*.html) which is exactly
what the OP was looiking for. Thanks.

--

Ronnie Vernon
Microsoft MVP
Windows Shell/User
November 5, 2004 1:12:00 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"Ronnie Vernon MVP" wrote:

> a nonymous wrote:
> > "Kelly" <kelly@mvps.org> wrote
> >> Hi Dusty,
> >>
> >> Go to Windows Explorer/Tools/Folder Options/View and check your
> >> options under Managing pairs of Web pages and folders. This can
> >> also be handled via gpedit and/or the registry.
> >>
> >> --
> >> All the Best,
> >> Kelly
> >>
> >> Microsoft-MVP Windows® XP-Shell/User
> >>
> >> "dusty" <dusty@discussions.microsoft.com> wrote in message
> >> news:C5112625-43E9-45B4-AAF9-C8675C88B7D2@microsoft.com...
> >>>
> >>> In internet explorer when I choose file>Save as...> a window appears
> >>> titled
> >>> Save Web Page.
> >>>
> >>> Within that window "Web Page,complete" appears in the Save as type
> >>> dropdown menu.
> >>> Is it possible to change "Web Page,complete" to "Web Page,HTML
> >>> only" as the first option that appears?
> >>> Any suggestions? Thank You.
> >
> > In SP1, Windows Explorer/Tools/Folder Options/View does not have
> > options under Managing pairs of Web pages and folders. Nor in
> > Internet Explorer/Tools/Internet Options/Advanced.
> >
> > In gpedit.msc, there used to be a setting "Manage Connected Items as
> > a Unit", but if you enabled that setting, then if you delete the html
> > file, it would automatically delete the html_files folder as well.
> >
> > There is a setting to _remove_ "Save As Web Page Complete".
> > This might make "Save As HTML" the default in the "Save as" dialog.
> >
> > In XP Pro,
> > Start
> > Run
> > gpedit.msc
> > Enter
> >
> > User Configuration
> > Administrative Templates
> > Windows Components
> > Internet Explorer
> > Browser Menus
> > File menu: Disable Save As Web Page Complete
>
> I tested this and that setting does remove the Web Page, Complete (*.htm
> *.html) and it also removes the Web Archive, single file (*.mht). It leaves
> the default selection as Web Page, HTML only (*.htm;*.html) which is exactly
> what the OP was looiking for. Thanks.
>
> --
>
> Ronnie Vernon
> Microsoft MVP
> Windows Shell/User
>


I thank all of you for your interest and your help.

unfortunately I have the home edition and when i tried

start...run...gpedit.msc...Enter

I get a message "windows cannot find gpedit.msc"

nonetheless your knowledge and help is appreciated.

Thank you again,
Dusty
Anonymous
November 7, 2004 9:49:06 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

| > >> "dusty" <dusty@discussions.microsoft.com> wrote
| > >>> In internet explorer when I choose file>Save as...> a window appears
| > >>> titled Save Web Page.
| > >>> Within that window "Web Page,complete" appears in the Save as type
| > >>> dropdown menu.
| > >>> Is it possible to change "Web Page,complete" to "Web Page,HTML
| > >>> only" as the first option that appears?
| > >>> Any suggestions? Thank You.
|
| > > "Kelly" <kelly@mvps.org> wrote
| > >> Hi Dusty,
| > >> Go to Windows Explorer/Tools/Folder Options/View and check your
| > >> options under Managing pairs of Web pages and folders. This can
| > >> also be handled via gpedit and/or the registry.
| > >> --
| > >> All the Best,
| > >> Kelly
| > >> Microsoft-MVP Windows® XP-Shell/User
|
| > a nonymous wrote:
| > > In SP1, Windows Explorer/Tools/Folder Options/View does not have
| > > options under Managing pairs of Web pages and folders. Nor in
| > > Internet Explorer/Tools/Internet Options/Advanced.
| > >
| > > In gpedit.msc, there used to be a setting "Manage Connected Items as
| > > a Unit", but if you enabled that setting, then if you delete the html
| > > file, it would automatically delete the html_files folder as well.
| > >
| > > There is a setting to _remove_ "Save As Web Page Complete".
| > > This might make "Save As HTML" the default in the "Save as" dialog.
| > >
| > > In XP Pro,
| > > Start
| > > Run
| > > gpedit.msc
| > > Enter
| > >
| > > User Configuration
| > > Administrative Templates
| > > Windows Components
| > > Internet Explorer
| > > Browser Menus
| > > File menu: Disable Save As Web Page Complete
|
| "Ronnie Vernon MVP" wrote:
| > I tested this and that setting does remove the Web Page, Complete (*.htm
| > *.html) and it also removes the Web Archive, single file (*.mht). It leaves
| > the default selection as Web Page, HTML only (*.htm;*.html) which is exactly
| > what the OP was looiking for. Thanks.
| > --
| > Ronnie Vernon
| > Microsoft MVP
| > Windows Shell/User
|
|"dusty" <dusty@discussions.microsoft.com> wrote
| I thank all of you for your interest and your help.
| unfortunately I have the home edition and when i tried
| start...run...gpedit.msc...Enter
| I get a message "windows cannot find gpedit.msc"
| nonetheless your knowledge and help is appreciated.
| Thank you again,
| Dusty


In XP Home, create this registry entry...
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer
\Infodelivery\Restrictions

New DWORD Value named NoBrowserSaveWebComplete
Value Data = 1 (one)
November 7, 2004 9:49:07 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"a nonymous" wrote:

> | > >> "dusty" <dusty@discussions.microsoft.com> wrote
> | > >>> In internet explorer when I choose file>Save as...> a window appears
> | > >>> titled Save Web Page.
> | > >>> Within that window "Web Page,complete" appears in the Save as type
> | > >>> dropdown menu.
> | > >>> Is it possible to change "Web Page,complete" to "Web Page,HTML
> | > >>> only" as the first option that appears?
> | > >>> Any suggestions? Thank You.
> |
> | > > "Kelly" <kelly@mvps.org> wrote
> | > >> Hi Dusty,
> | > >> Go to Windows Explorer/Tools/Folder Options/View and check your
> | > >> options under Managing pairs of Web pages and folders. This can
> | > >> also be handled via gpedit and/or the registry.
> | > >> --
> | > >> All the Best,
> | > >> Kelly
> | > >> Microsoft-MVP Windows® XP-Shell/User
> |
> | > a nonymous wrote:
> | > > In SP1, Windows Explorer/Tools/Folder Options/View does not have
> | > > options under Managing pairs of Web pages and folders. Nor in
> | > > Internet Explorer/Tools/Internet Options/Advanced.
> | > >
> | > > In gpedit.msc, there used to be a setting "Manage Connected Items as
> | > > a Unit", but if you enabled that setting, then if you delete the html
> | > > file, it would automatically delete the html_files folder as well.
> | > >
> | > > There is a setting to _remove_ "Save As Web Page Complete".
> | > > This might make "Save As HTML" the default in the "Save as" dialog.
> | > >
> | > > In XP Pro,
> | > > Start
> | > > Run
> | > > gpedit.msc
> | > > Enter
> | > >
> | > > User Configuration
> | > > Administrative Templates
> | > > Windows Components
> | > > Internet Explorer
> | > > Browser Menus
> | > > File menu: Disable Save As Web Page Complete
> |
> | "Ronnie Vernon MVP" wrote:
> | > I tested this and that setting does remove the Web Page, Complete (*.htm
> | > *.html) and it also removes the Web Archive, single file (*.mht). It leaves
> | > the default selection as Web Page, HTML only (*.htm;*.html) which is exactly
> | > what the OP was looiking for. Thanks.
> | > --
> | > Ronnie Vernon
> | > Microsoft MVP
> | > Windows Shell/User
> |
> |"dusty" <dusty@discussions.microsoft.com> wrote
> | I thank all of you for your interest and your help.
> | unfortunately I have the home edition and when i tried
> | start...run...gpedit.msc...Enter
> | I get a message "windows cannot find gpedit.msc"
> | nonetheless your knowledge and help is appreciated.
> | Thank you again,
> | Dusty
>
>
> In XP Home, create this registry entry...
> HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer
> \Infodelivery\Restrictions
>
> New DWORD Value named NoBrowserSaveWebComplete
> Value Data = 1 (one)
>
> I'm unfamiliar with modifying my registry
> I have gotten as far as the folder microsoft
>Within that folder there is not one named Internet Explorer
>I've created a new folder named Internet Explorer by choosing new>key
>within that> Infodelivery
>and within that one >Restrictions

>I then created a new DWORD Value named>
> NoBrowserSaveWebComplete
>I modified that in the value data area with >1 (one)

>After doing so the folder Restrictions now reads>
>name type data
>(ab)default REG_SZ (value not set)
> NoBrowserSaveWebComplete REG_ DWORD 0xff84b7d2 (4286887890)

>I expected to see 1 (one) in the data area of REG_ DWORD
>instead it created 0xff84b7d2 (4286887890)
> I'm not absolutely sure if
>I've done this correctly or if I can do any irrepairable damage
>by continuing and restarting the computer.
> Thank you for the help a nonymous,
>
Dusty
>)
Anonymous
November 8, 2004 10:57:44 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

| > "a nonymous" wrote:
| > In XP Home, create this registry entry...
| > HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer
| > \Infodelivery\Restrictions
| >
| > New DWORD Value named NoBrowserSaveWebComplete
| > Value Data = 1 (one)
|
| "dusty" <dusty@discussions.microsoft.com> wrote
| I'm unfamiliar with modifying my registry
| I have gotten as far as the folder microsoft
| Within that folder there is not one named Internet Explorer
| I've created a new folder named Internet Explorer by choosing new>key
| within that Infodelivery and within that one Restrictions
|
| I then created a new DWORD Value named NoBrowserSaveWebComplete
| I modified that in the value data area with 1 (one)
|
| After doing so the folder Restrictions now reads
|
| name type data
| (ab)default REG_SZ (value not set)
| NoBrowserSaveWebComplete REG_DWORD 0xff84b7d2 (4286887890)
|
| I expected to see 1 (one) in the data area of REG_DWORD
| instead it created 0xff84b7d2 (4286887890)
| I'm not absolutely sure if
| I've done this correctly or if I can do any irrepairable damage
| by continuing and restarting the computer.
| Thank you for the help a nonymous


Hello Dusty,

Excellent work on your part. According to what you wrote, everything
you did was 100% correct. (My cryptic instructions would be meaningful
only to experienced users of Regedit, or to people more intelligent
than me.)

I am puzzled about that strange numeric data value. It should be 1.

When you created the New DWORD Value named NoBrowserSaveWebComplete,
it should have displayed with a data value of 0.

When you modified that Value data to 1, it should have displayed
with a value of 1.

Please do the following...

1. In regedit, modify that value to 1.

2. Export the Restrictions key via File-menu > Export
Ensure that you see the following in the "Export range" area at the
bottom of "Export Registry File" dialog box...

(*) Selected branch
HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions

3. Open that exported file in a text editor such as Notepad.

4. Copy the contents of that file and paste into your reply.


For reference, the following is what you should see in that
exported file...

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions]
"NoBrowserSaveWebComplete"=dword:00000001


Note: If you are still unable to change the data to 1, delete the
"Internet Explorer" key which you created under
HKEY_CURRENT_USER\Software\Policies\Microsoft
before continuing and restarting the computer.

By the way, are you the same "Dusty" who asked about deleting folders/files
using a Startup/Logon script, about twelve months ago?
November 8, 2004 10:57:45 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"a nonymous" wrote:

> | > "a nonymous" wrote:
> | > In XP Home, create this registry entry...
> | > HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer
> | > \Infodelivery\Restrictions
> | >
> | > New DWORD Value named NoBrowserSaveWebComplete
> | > Value Data = 1 (one)
> |
> | "dusty" <dusty@discussions.microsoft.com> wrote
> | I'm unfamiliar with modifying my registry
> | I have gotten as far as the folder microsoft
> | Within that folder there is not one named Internet Explorer
> | I've created a new folder named Internet Explorer by choosing new>key
> | within that Infodelivery and within that one Restrictions
> |
> | I then created a new DWORD Value named NoBrowserSaveWebComplete
> | I modified that in the value data area with 1 (one)
> |
> | After doing so the folder Restrictions now reads
> |
> | name type data
> | (ab)default REG_SZ (value not set)
> | NoBrowserSaveWebComplete REG_DWORD 0xff84b7d2 (4286887890)
> |
> | I expected to see 1 (one) in the data area of REG_DWORD
> | instead it created 0xff84b7d2 (4286887890)
> | I'm not absolutely sure if
> | I've done this correctly or if I can do any irrepairable damage
> | by continuing and restarting the computer.
> | Thank you for the help a nonymous
>
>
> Hello Dusty,
>
> Excellent work on your part. According to what you wrote, everything
> you did was 100% correct. (My cryptic instructions would be meaningful
> only to experienced users of Regedit, or to people more intelligent
> than me.)
>
> I am puzzled about that strange numeric data value. It should be 1.
>
> When you created the New DWORD Value named NoBrowserSaveWebComplete,
> it should have displayed with a data value of 0.
>
> When you modified that Value data to 1, it should have displayed
> with a value of 1.
>
> Please do the following...
>
> 1. In regedit, modify that value to 1.
>
> 2. Export the Restrictions key via File-menu > Export
> Ensure that you see the following in the "Export range" area at the
> bottom of "Export Registry File" dialog box...
>
> (*) Selected branch
> HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions
>
> 3. Open that exported file in a text editor such as Notepad.
>
> 4. Copy the contents of that file and paste into your reply.
>
>
> For reference, the following is what you should see in that
> exported file...
>
> Windows Registry Editor Version 5.00
>
> [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions]
> "NoBrowserSaveWebComplete"=dword:00000001
>
>
> Note: If you are still unable to change the data to 1, delete the
> "Internet Explorer" key which you created under
> HKEY_CURRENT_USER\Software\Policies\Microsoft
> before continuing and restarting the computer.
>
> By the way, are you the same "Dusty" who asked about deleting folders/files
> using a Startup/Logon script, about twelve months ago?
>
> Hi a nonymous,
> no not the same Dusty
>I just saw your post and will have to
>follow your instructions in the morning

>by the way,when i created the value I copied and pasted 1 (one)
>into the value data area
>not only the number but the word as well
>that probably accounts for the error
>I will keep you updated
>Thank you for staying with me on this one
>Have a nice evening
Dusty
November 8, 2004 10:57:46 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"dusty" wrote:

>
>
> "a nonymous" wrote:
>
> > | > "a nonymous" wrote:
> > | > In XP Home, create this registry entry...
> > | > HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer
> > | > \Infodelivery\Restrictions
> > | >
> > | > New DWORD Value named NoBrowserSaveWebComplete
> > | > Value Data = 1 (one)
> > |
> > | "dusty" <dusty@discussions.microsoft.com> wrote
> > | I'm unfamiliar with modifying my registry
> > | I have gotten as far as the folder microsoft
> > | Within that folder there is not one named Internet Explorer
> > | I've created a new folder named Internet Explorer by choosing new>key
> > | within that Infodelivery and within that one Restrictions
> > |
> > | I then created a new DWORD Value named NoBrowserSaveWebComplete
> > | I modified that in the value data area with 1 (one)
> > |
> > | After doing so the folder Restrictions now reads
> > |
> > | name type data
> > | (ab)default REG_SZ (value not set)
> > | NoBrowserSaveWebComplete REG_DWORD 0xff84b7d2 (4286887890)
> > |
> > | I expected to see 1 (one) in the data area of REG_DWORD
> > | instead it created 0xff84b7d2 (4286887890)
> > | I'm not absolutely sure if
> > | I've done this correctly or if I can do any irrepairable damage
> > | by continuing and restarting the computer.
> > | Thank you for the help a nonymous
> >
> >
> > Hello Dusty,
> >
> > Excellent work on your part. According to what you wrote, everything
> > you did was 100% correct. (My cryptic instructions would be meaningful
> > only to experienced users of Regedit, or to people more intelligent
> > than me.)
> >
> > I am puzzled about that strange numeric data value. It should be 1.
> >
> > When you created the New DWORD Value named NoBrowserSaveWebComplete,
> > it should have displayed with a data value of 0.
> >
> > When you modified that Value data to 1, it should have displayed
> > with a value of 1.
> >
> > Please do the following...
> >
> > 1. In regedit, modify that value to 1.
> >
> > 2. Export the Restrictions key via File-menu > Export
> > Ensure that you see the following in the "Export range" area at the
> > bottom of "Export Registry File" dialog box...
> >
> > (*) Selected branch
> > HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions
> >
> > 3. Open that exported file in a text editor such as Notepad.
> >
> > 4. Copy the contents of that file and paste into your reply.
> >
> >
> > For reference, the following is what you should see in that
> > exported file...
> >
> > Windows Registry Editor Version 5.00
> >
> > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodelivery\Restrictions]
> > "NoBrowserSaveWebComplete"=dword:00000001
> >
> >
> > Note: If you are still unable to change the data to 1, delete the
> > "Internet Explorer" key which you created under
> > HKEY_CURRENT_USER\Software\Policies\Microsoft
> > before continuing and restarting the computer.
> >
> > By the way, are you the same "Dusty" who asked about deleting folders/files
> > using a Startup/Logon script, about twelve months ago?
> >
> > Hi a nonymous,
> > no not the same Dusty
> >I just saw your post and will have to
> >follow your instructions in the morning
>
> >by the way,when i created the value I copied and pasted 1 (one)
> >into the value data area
> >not only the number but the word as well
> >that probably accounts for the error
> >I will keep you updated
> >Thank you for staying with me on this one
> >Have a nice evening
> Dusty
>
>Success !!
>At least in creating the registry value and restarting the computer
>although it has not resolved the goal of changing the
>"save as type" issue
>the first option stll appears save> "web page,complete"
>Any further suggestions are welcome
>Thanks again, a nonymous
> Dusty
>
>
>
Anonymous
November 9, 2004 10:13:02 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"dusty" <dusty@discussions.microsoft.com> wrote
|> > Hi a nonymous,
|> > no not the same Dusty

Hi Dusty,

I asked because the other "Dusty" responded with the same
professional attention to detail as you do, and also in the same way.


| > >by the way,when i created the value I copied and pasted 1 (one)
| > >into the value data area
| > >not only the number but the word as well
| > >that probably accounts for the error
| > >I will keep you updated
| > >Thank you for staying with me on this one
| > >Have a nice evening Dusty

That would explain that strange number. This is an interesting bug
(or feature to allow multibyte character strings) in the
"Edit DWORD Value" dialog box. When you type into the "Value Data" box,
only numeric "0" to "9" are allowed in "Decimal" mode (also alphabetic
"A" to "F" when in "Hexadecimal" mode.)


| >Success !!
| >At least in creating the registry value and restarting the computer
| >although it has not resolved the goal of changing the
| >"save as type" issue
| >the first option stll appears save> "web page,complete"
| >Any further suggestions are welcome
| >Thanks again, a nonymous Dusty

Please do the following...

1. Check that "NoBrowserSaveWebComplete" is still 1.
If it is 0, or (more likely) that
\Internet Explorer\Infodelivery\Restrictions
no longer exists, recreate those keys and that value and then
create/modify the following...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion
\Policies\Explorer

(New) DWORD Value named NoSaveSettings
Value Data = 0

From now on, when you exit a Logon session, Windows should
remember all settings that had been changed during that session.
However, do not logoff/restart just yet.


2. Now close all instances of Internet Explorer.
With "NoBrowserSaveWebComplete" set to 1, reopen Internet
Explorer. Now, both "Web Page, Complete (*.htm *.html)" and
"Web Archive, single file (*.mht)" should be missing from the
"File Save As" dialog. You should now also see that
"Web Page, HTML only (*.htm;*.html)" is the default selection.
You should see this every time you (re)start Windows as well.
November 9, 2004 10:13:03 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"a nonymous" wrote:

>
> "dusty" <dusty@discussions.microsoft.com> wrote
> |> > Hi a nonymous,
> |> > no not the same Dusty
>
> Hi Dusty,
>
> I asked because the other "Dusty" responded with the same
> professional attention to detail as you do, and also in the same way.
>
>
> | > >by the way,when i created the value I copied and pasted 1 (one)
> | > >into the value data area
> | > >not only the number but the word as well
> | > >that probably accounts for the error
> | > >I will keep you updated
> | > >Thank you for staying with me on this one
> | > >Have a nice evening Dusty
>
> That would explain that strange number. This is an interesting bug
> (or feature to allow multibyte character strings) in the
> "Edit DWORD Value" dialog box. When you type into the "Value Data" box,
> only numeric "0" to "9" are allowed in "Decimal" mode (also alphabetic
> "A" to "F" when in "Hexadecimal" mode.)
>
>
> | >Success !!
> | >At least in creating the registry value and restarting the computer
> | >although it has not resolved the goal of changing the
> | >"save as type" issue
> | >the first option stll appears save> "web page,complete"
> | >Any further suggestions are welcome
> | >Thanks again, a nonymous Dusty
>
> Please do the following...
>
> 1. Check that "NoBrowserSaveWebComplete" is still 1.
> If it is 0, or (more likely) that
> \Internet Explorer\Infodelivery\Restrictions
> no longer exists, recreate those keys and that value and then
> create/modify the following...
>
> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion
> \Policies\Explorer
>
> (New) DWORD Value named NoSaveSettings
> Value Data = 0
>
> From now on, when you exit a Logon session, Windows should
> remember all settings that had been changed during that session.
> However, do not logoff/restart just yet.
>
>
> 2. Now close all instances of Internet Explorer.
> With "NoBrowserSaveWebComplete" set to 1, reopen Internet
> Explorer. Now, both "Web Page, Complete (*.htm *.html)" and
> "Web Archive, single file (*.mht)" should be missing from the
> "File Save As" dialog. You should now also see that
> "Web Page, HTML only (*.htm;*.html)" is the default selection.
> You should see this every time you (re)start Windows as well.
>
> Hi a nonymous,

> Fascinating!! Am I impressed!!
>Thank you so much for your help.
>I am looking forward to future posts from you and others
>who help us learn more about customizing
>and solving problems.

>Hope to correspond with you in the near future
sincerely,

Dusty



>
Anonymous
November 10, 2004 8:36:37 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"dusty" <dusty@discussions.microsoft.com> wrote
| Hi a nonymous,
|
| Fascinating!! Am I impressed!!
| Thank you so much for your help.
| I am looking forward to future posts from you and others
| who help us learn more about customizing
| and solving problems.
|
| Hope to correspond with you in the near future
| sincerely, Dusty

Hi Dusty,

Thank you! Am I correct in assuming that this issue is
now actually resolved?
November 10, 2004 8:36:38 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"a nonymous" wrote:

>
> "dusty" <dusty@discussions.microsoft.com> wrote
> | Hi a nonymous,
> |
> | Fascinating!! Am I impressed!!
> | Thank you so much for your help.
> | I am looking forward to future posts from you and others
> | who help us learn more about customizing
> | and solving problems.
> |
> | Hope to correspond with you in the near future
> | sincerely, Dusty
>
> Hi Dusty,
>
> Thank you! Am I correct in assuming that this issue is
> now actually resolved?
>
>
> Hi a nonymous,
>
>Yes! It is resolved!
>I was so thrilled to see the change I forgot to say "it works" lol

>I was curious >How did you know "NoBrowserSaveWebComplete"
>should be the DWORD value and the location to place it within
>the registry tree?
>(also the "NoSaveSettings" DWORD value )
>Is this something only a computer programmer could know?

> Thanks again a nonymous,
> Dusty.

>
>
Anonymous
November 11, 2004 10:11:45 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

| "a nonymous" wrote:
| > Hi Dusty,
| > Thank you! Am I correct in assuming that this issue is
| > now actually resolved?
|
| "dusty" <dusty@discussions.microsoft.com> wrote
| Hi a nonymous,
|
| Yes! It is resolved!
| I was so thrilled to see the change I forgot to say "it works" lol
|
| I was curious How did you know "NoBrowserSaveWebComplete"
| should be the DWORD value and the location to place it within
| the registry tree?
| (also the "NoSaveSettings" DWORD value )
| Is this something only a computer programmer could know?
|
| Thanks again a nonymous, Dusty.

For "NoBrowserSaveWebComplete":
- used a static tool to take a snaphot of the registry
- used GPEdit to set the policy
File menu: Disable Save As Web Page Complete
- took another snaphot of the registry
- compared those two snapshots
- found the relevant key/name
- tested and confirmed in Internet Explorer

For "NoSaveSettings":
- This has been known for a long time and has been posted many times
in these newsgroups, but is usually referred to as a .REG file which
is available from MS-MVP Kelly Theriot's website at
http://www.kellys-korner-xp.com/xp_tweaks.htm
Line 54,(Save Settings on Exit)

Save the .REG File to a hard disk.
Double click the .REG File; answer yes to the "Registry Editor" prompt.
(Open the .REG file in Notepad to view its contents.)
Then logoff, logon.

That website contains hundreds of tweaks for Windows XP, but they are
meant to be used to resolve specific issues under certain conditions.


Only people who do a lot of reading about Windows XP would know about
this technical XP stuff.


An excellent tutorial:
http://www.theeldergeek.com/windows_xp_registry.htm
Backing Up and Restoring the XP Registry
How The Windows XP Registry is Structured
Types of Registry Backups

Also:
http://winguides.com/article.php?id=1&guide=registry
Tutorial
http://winguides.com/registry/
http://insideoe.tomsterdam.com/tips/regedit.htm

More Technical:
http://msdn.microsoft.com/library/en-us/dnexnt01/html/e...
NT_Regedit
http://support.microsoft.com/kb/256986
How to back up, restore, and edit the registry:
(Description of the MS Windows Registry)


Also, should you ever want to restore the "Web Page Complete" option:

Export the HKEY_CURRENT_USER\Software\Policies\Microsoft
\Internet Explorer\Infodelivery\Restrictions key as a registration file
named WebPageHTMLonly.REG to a convenient location.

Open WebPageHTMLonly.REG in Notepad.
Change the "1" to a "0".
File > Save As with a name "WebPageComplete.REG" (including the quote
marks, to ensure that the file is not saved with a TXT extension)

Now you can easily switch between "HTMLonly" and "Complete" save modes
by first closing all Internet Explorer windows, then double-clicking
the relevant .REG file .
November 11, 2004 10:11:46 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"a nonymous" wrote:

>
> | "a nonymous" wrote:
> | > Hi Dusty,
> | > Thank you! Am I correct in assuming that this issue is
> | > now actually resolved?
> |
> | "dusty" <dusty@discussions.microsoft.com> wrote
> | Hi a nonymous,
> |
> | Yes! It is resolved!
> | I was so thrilled to see the change I forgot to say "it works" lol
> |
> | I was curious How did you know "NoBrowserSaveWebComplete"
> | should be the DWORD value and the location to place it within
> | the registry tree?
> | (also the "NoSaveSettings" DWORD value )
> | Is this something only a computer programmer could know?
> |
> | Thanks again a nonymous, Dusty.
>
> For "NoBrowserSaveWebComplete":
> - used a static tool to take a snaphot of the registry
> - used GPEdit to set the policy
> File menu: Disable Save As Web Page Complete
> - took another snaphot of the registry
> - compared those two snapshots
> - found the relevant key/name
> - tested and confirmed in Internet Explorer
>
> For "NoSaveSettings":
> - This has been known for a long time and has been posted many times
> in these newsgroups, but is usually referred to as a .REG file which
> is available from MS-MVP Kelly Theriot's website at
> http://www.kellys-korner-xp.com/xp_tweaks.htm
> Line 54,(Save Settings on Exit)
>
> Save the .REG File to a hard disk.
> Double click the .REG File; answer yes to the "Registry Editor" prompt.
> (Open the .REG file in Notepad to view its contents.)
> Then logoff, logon.
>
> That website contains hundreds of tweaks for Windows XP, but they are
> meant to be used to resolve specific issues under certain conditions.
>
>
> Only people who do a lot of reading about Windows XP would know about
> this technical XP stuff.
>
>
> An excellent tutorial:
> http://www.theeldergeek.com/windows_xp_registry.htm
> Backing Up and Restoring the XP Registry
> How The Windows XP Registry is Structured
> Types of Registry Backups
>
> Also:
> http://winguides.com/article.php?id=1&guide=registry
> Tutorial
> http://winguides.com/registry/
> http://insideoe.tomsterdam.com/tips/regedit.htm
>
> More Technical:
> http://msdn.microsoft.com/library/en-us/dnexnt01/html/e...
> NT_Regedit
> http://support.microsoft.com/kb/256986
> How to back up, restore, and edit the registry:
> (Description of the MS Windows Registry)
>
>
> Also, should you ever want to restore the "Web Page Complete" option:
>
> Export the HKEY_CURRENT_USER\Software\Policies\Microsoft
> \Internet Explorer\Infodelivery\Restrictions key as a registration file
> named WebPageHTMLonly.REG to a convenient location.
>
> Open WebPageHTMLonly.REG in Notepad.
> Change the "1" to a "0".
> File > Save As with a name "WebPageComplete.REG" (including the quote
> marks, to ensure that the file is not saved with a TXT extension)
>
> Now you can easily switch between "HTMLonly" and "Complete" save modes
> by first closing all Internet Explorer windows, then double-clicking
> the relevant .REG file .
>
> Boy did I open a can of worms LOL
> I have enough information here to keep me occupied for months
> Thanks again for your help and extra effort
>
Anonymous
November 12, 2004 8:10:24 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

"dusty" <dusty@discussions.microsoft.com> wrote
|
| Boy did I open a can of worms LOL
| I have enough information here to keep me occupied for months
| Thanks again for your help and extra effort

Thank you!
November 18, 2004 5:02:35 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

In part.....

MS-MVP Kelly Theriot's website at
http://www.kellys-korner-xp.com/xp_tweaks.htm

That website contains hundreds of tweaks for Windows XP, but they are
meant to be used to resolve specific issues under certain conditions.

Thank you!

--
All the Best,
Kelly (MS-MVP)

Troubleshooting Windows XP
http://www.kellys-korner-xp.com

"a nonymous" <anonymous@discussions.microsoft.com> wrote in message
news:uHJMon2xEHA.3372@TK2MSFTNGP10.phx.gbl...
>
> | "a nonymous" wrote:
> | > Hi Dusty,
> | > Thank you! Am I correct in assuming that this issue is
> | > now actually resolved?
> |
> | "dusty" <dusty@discussions.microsoft.com> wrote
> | Hi a nonymous,
> |
> | Yes! It is resolved!
> | I was so thrilled to see the change I forgot to say "it works" lol
> |
> | I was curious How did you know "NoBrowserSaveWebComplete"
> | should be the DWORD value and the location to place it within
> | the registry tree?
> | (also the "NoSaveSettings" DWORD value )
> | Is this something only a computer programmer could know?
> |
> | Thanks again a nonymous, Dusty.
>
> For "NoBrowserSaveWebComplete":
> - used a static tool to take a snaphot of the registry
> - used GPEdit to set the policy
> File menu: Disable Save As Web Page Complete
> - took another snaphot of the registry
> - compared those two snapshots
> - found the relevant key/name
> - tested and confirmed in Internet Explorer
>
> For "NoSaveSettings":
> - This has been known for a long time and has been posted many times
> in these newsgroups, but is usually referred to as a .REG file which
> is available from MS-MVP Kelly Theriot's website at
> http://www.kellys-korner-xp.com/xp_tweaks.htm
> Line 54,(Save Settings on Exit)
>
> Save the .REG File to a hard disk.
> Double click the .REG File; answer yes to the "Registry Editor" prompt.
> (Open the .REG file in Notepad to view its contents.)
> Then logoff, logon.
>
> That website contains hundreds of tweaks for Windows XP, but they are
> meant to be used to resolve specific issues under certain conditions.
>
>
> Only people who do a lot of reading about Windows XP would know about
> this technical XP stuff.
>
>
> An excellent tutorial:
> http://www.theeldergeek.com/windows_xp_registry.htm
> Backing Up and Restoring the XP Registry
> How The Windows XP Registry is Structured
> Types of Registry Backups
>
> Also:
> http://winguides.com/article.php?id=1&guide=registry
> Tutorial
> http://winguides.com/registry/
> http://insideoe.tomsterdam.com/tips/regedit.htm
>
> More Technical:
> http://msdn.microsoft.com/library/en-us/dnexnt01/html/e...
> NT_Regedit
> http://support.microsoft.com/kb/256986
> How to back up, restore, and edit the registry:
> (Description of the MS Windows Registry)
>
>
> Also, should you ever want to restore the "Web Page Complete" option:
>
> Export the HKEY_CURRENT_USER\Software\Policies\Microsoft
> \Internet Explorer\Infodelivery\Restrictions key as a registration file
> named WebPageHTMLonly.REG to a convenient location.
>
> Open WebPageHTMLonly.REG in Notepad.
> Change the "1" to a "0".
> File > Save As with a name "WebPageComplete.REG" (including the quote
> marks, to ensure that the file is not saved with a TXT extension)
>
> Now you can easily switch between "HTMLonly" and "Complete" save modes
> by first closing all Internet Explorer windows, then double-clicking
> the relevant .REG file .
>
>
>
>
!