Sign in with
Sign up | Sign in
Your question

XFX 5870 w/ eyefinity X6 2GB having driver install failures!

Last response: in Graphics & Displays
Share
February 3, 2012 3:29:10 AM

Hello all,

I am in desperate need of help, or i won't be sleeping again any time soon, and already lost so much i am sick literally.

First, My build....

Asus p6X58D Premium
Intel i7 X980 Gulftown 3.35GHz @ Stock (runs slightly faster than rated no turbo engaged)
24 GB ram Patriot Viper II Extreme series (if I am remembering right LOL!)
XFX HD 5870 W eyefinity 2 GB gddr5
Samsung 24" 1920X1200 X 3
1TB WD Black 7200 RPM 6 Gbs X 2
1TB WD Black 7200 rpm 3Gbs X 3
1000 Watt Bronze 80 Rosewill PSU
Windows 7 Ultimate 64 bit RTM/oem

After running this build for about a year, with little issue beyond those generated by a root kit infection of the boot sector of my system drive, from which i have recovered successfully, more or less, as it required a format and re installation of the OS, and all the programs.
After this harrowing ordeal, I have been running without issue except for mt mouse pointer freezing/skipping, which was resolved in another thread here.

After running prime95 torture test for 7 hours and another GPU stress test for five, all was well and nothing rose above 107°F. then a few nights later I noticed SpeedFan was indicating my GPU and two of the 6 cores rising in to the 120°f ranges, still within reason however since the machine was all but idle (i was working on my other build at the time) and was continuing to rise upwards of 128°f and although i know this is still within acceptable ranges, not DOING anything at the time, warranted further investigation, so i shut it down, unplugged it, and partially disassembled the build enough to give it all a good vacuuming, and as suspected, between the GPU and the secondary Antec GPU fan, there was a clump of dust acting like an insulator. and put everything back after it was all clean, ensuring everything ws making proper contact where it should, including the 6 and 6+6 PCIe plugs into the gpu card.

At the same time my quad core machine advised me of a new ATI driver for my HD5860 in it, and proceeded to allow the update, with no errors.

However when i got the now clean machine booted after some posting issues of unknown cause, i swapped out the video card with an old radeon 4600 series to find it did in fact post and boot, returning the HD5870 for another try again, it posted again and proceeded to boot normally, or so it seemed, because after boot up i got a notification "there is no ATI driver installed or the existing one is corrupt or not working properly I proceeded to XFX and then AMD site itself since every attempt from both sites resulted in either CCC and everything loaded fine but the driver failed, or the install package failed and the driver could not be loaded.

BTW there often were times over the past two years that new updated driver installs would error, so i just stayed with the current one and let it go until it had advanced to the next revision knowing there can be issues with these drivers and windows 7, so i tried going back to the last known working driver for this card, that being just prior to turning the 10.xxx revisions, and initially it seemed to work but there were warnings, i am so dizzy at the moment i cannot recall what it was, so i proceeded to advance through each of the revisions installing the entire suite after each failure, or if everything installed okay except the driver, I would then try getting and installing only the driver, and no matter which stage of this i was at, one of those issues resulted, i have been at this now for 20 solid hours barely eating and having no more than 4 hours of sleep (more so from being miserable from my head cold) and am at the end of my rope and was all but in tears this morning when i HAD to go lie down.

I don't know what else to do... i really do not wish to have to reinstall Windows again, as i just DID that a month ago and finally finished installing around 77 programs and although the installations aren't THAT great a deal all together, configuring those programs for how they are to be used is a monumental task that i haven't even finished from the last recovery (the root kit virus... yes it is clean now ran Kaperski's TDSS killer)

one other thing.... when running SpeedFan again i noticed it no longer reports a GPU and states the 'power' fan is 0 RPMs which occurred JUST before i shut it down for those temps. It STILL say power fan is 0 RPM and shows battery ???? all 12 cores are running between 77 and 87 degrees, all HDD'S high 70's aside from power fan, all physical fans can be visually confirmed as running/spinning, and cpu is slightly higher 3354MHz curiously no memory references at all.... not sure if they were even there previously, but usually such a utility would have such representation. I am going to go download another type of utility at CPUID site!!! I'll report those results

What should i check, what else can i try, where do i go for the best versions of these drivers, at one point it claimed i have no ATI drivers installed, then when switching to another revision it will report there are no AMD graphics driver installed? and the ONE instance everything, including driver had installed without error or warning... Windows said it was an unsigned driver and requires ONLY digitally signed drivers... i realize i could have rebooted from the alternate boot menu and choose ignore driver signing errors but that isn't a fix in my book.

I am a grown man and do not want to cry tonight out of sheer frustration, like i almost did this morning until i finally ATE something to help me reduce the stress levels.

Thanks, you guys more often than not always help resolve my computer problems, any input would be greatly appreciated.

TSG!
February 3, 2012 3:46:45 AM

Great wall of text.

cut out 90% text next time bud

i have had a skim through and im still not clear on what your problem actually is.

are you having problems installing and getting the driver / CCC software running?
m
0
l
February 3, 2012 4:04:35 AM

Tried to avoid having to go back and forth all night answering everyone's "did you try...

But yes I download the drivers but they fail to install for any number of reasons given!!

Thanks!
TSG!
m
0
l
Related resources
February 3, 2012 4:22:33 AM

Have you tried something like CCleaner to remove all traces of the old drivers.

also i see u mentioned a quad core PC. have you tried ur video card in that machine to confirm the card is fine and not faulty?
m
0
l
February 3, 2012 4:24:31 AM

i did have a problem in the last 6 months where when i would try to install my video driver it would go to a black screen (normally flickers on and off during installing drivers) but just stay there. i would have to restart my PC resulting in the driver not installing correctly. Then one time it would not reboot to windows at all so i reinstalled

has not happened since i reinstalled however (2-3 driver updates)
m
0
l
February 3, 2012 4:33:30 AM

HugoStiglitz said:
i did have a problem in the last 6 months where when i would try to install my video driver it would go to a black screen (normally flickers on and off during installing drivers) but just stay there. i would have to restart my PC resulting in the driver not installing correctly. Then one time it would not reboot to windows at all so i reinstalled

has not happened since i reinstalled however (2-3 driver updates)



This too ALSO happened to me a couple months ago, and had to do the same to recover, and until my mouse pointer began skipping around and freezing i have had no problems. Bought new mouse, did the same thing, posted here got a solution, it seems to be holding with nly an occasional hiccup!

No.. did not attempt to put it in my Quad, need to know at least ONE of these remains operational, but if it helps, loading the 4600 series driver also failed.
m
0
l
February 3, 2012 4:41:26 AM

While attempting to try this from Safe mode, I am now getting an error 'Failed to load detection driver' however when i try to run the driver detection program it tells me the windows installer is not available in safe mode!?!? Kind of one defeats the other scenario.... is it safe mode actually causing the initial error? Not that it won't anyway just with a different reason for the error. I just finished installing some 77 programs and configured about half of them, would need another two or so weeks to finish them and be productive again, if I reinstall the OS I will then be out of commission for over a month! Although i can do some work on the Quad, the graphics editing REALLY sucks having to wait for the edits to update and i have 149 images to edit for a website!! Ughh!
m
0
l
!