Sign in with
Sign up | Sign in
Your question

I7 3770K with Sabertooth Z77 issues

Last response: in CPUs
Share
July 24, 2012 11:22:02 PM

I will try to keep it simple and explain the problem .,
First used i7 3770k with a complete new build except for the mobo o( UD3 )
installed windows and than since the chipset/mobo drivers are outdated in the CD ,
installed ethernet drivers first and connected to the internet .
when i connected to the internet , windows updates automatically downloaded ALL ivy bridge processor technology drivers !!
highlight : i particularly saw the HD 4000 intel graphics drivers installing

now ,

after getting enough money i bought a sabertooth z77 mobo and than shifted the whole setup to the new mobo .

1. I have a gtx 560 TI but i have not installed it on the PC yet .

2. I went ahead and installed windows and the the drivers cd and clicked to install ALL drivers

after few restarts,
i noticed my pc did not detect the Intel HD 4000 graphics , It simply said Standard VGA graphics

like wise i saw no ivy bridge related drivers on " device manager " .

i did few other checks ...
a. MOBO Driver CD , utilities i tried to install the Intel smart response technology and some other intel utility for the advanced technology in the CPU,

in both cases the installer returned with an error saying " no compatible hardware found "

than i tried the "Lucid Virtu " technnology , it also did not detect cpu graphics and returned saying no cpu graphics found ( or something similar)

finally i went into " dxdiag" window
and under the immediate tab that appears i found :


System Manufacturer : System manufacturer
System Model : System Product Name

where usually MOBO info appears . (( updated mobo bios and checked too ) )
i took the PC to the reseller whom i bought the part from said them it ws a faulty MOBO and he opened another sabertooth z77 and did the whole thing on that new MOBO ...

THE SYSTEM DID NOT DETECT any of the intel technologies from the CPU !!

iam at my wits end now , not few weeks ago i bent pins on a brand new P8Z77 mobo and destroyed it .,
and adding into the frustration this happens ,

Iam going to take my old mobo to the reseller and check back if it detects the Intel technologies (including HD 4000) graphics and to clarify that the problem is not with the processor)
and the whole setup ( mainly mobo ) to the main ASUS to check the mobo .

the reseller is an idiot and says me that maybe the motherboard does not support those technologies from CPU .

i need help very badly as it seems i cant get any bright minded people in my place ( dubai ) to understand the issue / find the real fault e.t.c

i need advice on how to strongly advocate my claim to the reseller to make them do something about the product if / when we find no solution to the problem.

thank you .

PS. i dont mean to be rude or offend any one , but iam looking for expert advice so people who are looking for posting comments and dont have proper knowledge about these issues dont bother *

build :

Intel i7 3770K
Intel SSD 120 GB 330 Series
750 W Force PSU [ Brand new and confirmed working perfectly ]

ASUS SABERTOOTH Z77 MOBO

NVIDIA GTX 560 TI [ never attached it to the PC during the tests ]


THANK YOU !!
Anonymous
July 25, 2012 12:15:28 AM

Hardware incompatibilities to easy your pain let me tell you my story! I buyed the first quad that got out with vista x64 ultimate!

I hade 8 Gbytes ram on board and When i install them the system was unstable everyting was trebling blue screens a mesh finaly i got into the report logs and i find the raid driver systor was hitting errors! I google it and i found someone with the same problem in site and the answere was try to intsall it with 2 Gbytes! So i did but can you imagine? I MEAN VISTA x64 ULTIMATE didn't work with 8 Gbytes ram! Evry time i wanted to use the dvd for reinstalling i had to open the case and remove 3 dimms!? Finaly microsfot released WAIK and i leard how to slipsream sp1, the hot fix for the bug ram and some others in order to fix a dvd without needed to remove the dims! That was NOT the only problem the microphone didn't recored nothing i hade to remove again 3 dims!? needed to make it sp2 to fix and this bug. After sp2 i found that microsoft camera vx-2000 didn't worked in vista 64 if i didn't remove also 3 dimms...

The lesson? never buy something that is coming out fast search aroound the net google it and you may save your self a lot of trubble.

*** happens to anyone.
m
0
l
July 25, 2012 12:18:44 AM

i did a fair amount of research on both the products , tho not as a couple ......and they have been rated as one of the best ....and while trying to find solution to my problem ,

i found lots of people enthusiasist gamers going with the couple without any problems . at this point i have come to the conclusion .


1. Faulty processor
2. Faulty Mobo
3. Have to make changes in BIOS that would let the mobo be detectable by system/Let the mobo detect the intel technologies from CPU


@recon-uk

well he did bump the post i guess :) 
m
0
l
Related resources
July 25, 2012 12:24:50 AM

i refresh every mins hoping for a proper help and get dissapointed bad :(  :p 
m
0
l
Anonymous
July 25, 2012 12:30:50 AM

When a hardware incompatibility occurs you do nothing else except to communicate with the manufacturer for a possible solution i mean when and how fast they fix a bios upgrade, driver upgrade and other stuff.

You have no choice to return them back..
m
0
l
July 25, 2012 12:42:52 AM

guys it was hard understanding giatrakis, but lets not be too harsh and please if you have any ideas / solutions to my problem post ., giatrakis at least contributed some info on his last post . :p 


thank you
m
0
l
Anonymous
July 25, 2012 12:50:54 AM

I messed a bit ok I change it 10nx but I said almost the same with recon-uk new drivers, bios upgrade, whatever you can find in the end I did returned the camera back or 3 dims back to have it and wait for them to update their drivers?

I took my money back at list.
m
0
l
a c 148 à CPUs
a b \ Driver
July 25, 2012 1:14:46 AM

Sabertooth is a nice board and the only times I have run into strange problems was due to memory.

Try usinig just 1 stick of 1.5v ddr3 1333 in the A2 slot.
m
0
l
!