Sign in with
Sign up | Sign in
Your question

Help, please! Problem with 3.0 usb

Last response: in Components
Share
July 25, 2012 8:07:15 AM

I have the antec 900 case if you own one you will be familiar with what I'm talking about (hopefully) The front 3.0 usb connector does not match the slots on my motherboard...I have no idea what to do with it, where to connect it. Here's my motherboard http://www.newegg.com/Product/Product.aspx?item=N82E168...

I am new to building pcs. This is my first, I got real far into my build when I ran into this problem. I simply do not know what to do :(  It's stressful. From what I've read and seen the case has 3.0 usb and the motherboard supports 3.0 :s Ugh :fou: 

More about : problem usb

a b ) Power supply
a b V Motherboard
July 25, 2012 8:20:00 AM

The USB ports could be 2.0 or 3.0.
What colour are the USB ports (black or blue)?
m
0
l
July 25, 2012 8:20:58 AM

Blue. I already know it's a 3.0. It's a 20 pin connector but doesn't go anywhere on the motherboard wtf
m
0
l
Related resources
a b ) Power supply
a b V Motherboard
July 25, 2012 8:25:51 AM

the motherboard doesnt have a usb 3.0 port. it is supposed to fit in port similar to the one seen here
m
0
l
July 25, 2012 8:28:36 AM

najirion said:
your board is a GIGABYTE GA-Z68A-D3H-B3 right?

http://www.gigabyte.us/products/product-page.aspx?pid=3...

unfortunately, there are no usb 3.0 HEADERS in the board. There are usb 3.0 PORTS at the back of the board but no HEADERS for usb 3.0 connectors from cases. The header should look like this:

http://www.cpusolutions.com/store/pc/catalog/p67saberto...


So are there any adapters I could buy to make it work. I'm sort of at a loss here now not knowing how to connect these ports.
m
0
l
!