Open each folder in the same window

Archived from groups: microsoft.public.windowsxp.customize (More info?)

I was trying to change the file folder's icon by going to the file types Tab
in the folder option ,after I chose another icon, every time I click over a
folder, search menu popped out so I got back to the folder option and set
every thing as its defaults, now I got another problem and can't fix it
,each folder doesn't open in the same window ,even by choosing the "open
each folder ...." from the folder option ,can anyone help me to fix this.
Thanks

Afshin
12 answers Last reply
More about open folder window
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Start | Run | Type: control folders | OK |
    General tab | ? Open each folder in the same window |
    Apply | OK

    [[Specifies that the contents of each folder open in the same window. To
    switch back to the previous folder, click the Back button on the toolbar, or
    press BACKSPACE.]]

    I that doesn't do it...

    Start | Run | Type: control folders | OK |
    File Types tab | Scroll down to and Select: (NONE) Folder |
    Advanced button | Highlight: explore | Set Default button |
    OK | Apply | OK

    Explore opens folders with Folders pane on the left.
    Open opens folders with common tasks showing on the left.

    Thanks to Goldfinger for this tip.


    --
    Hope this helps. Let us know.
    Wes

    In news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl,
    A-Design <afshinstock@hotmail.com> hunted and pecked:
    > I was trying to change the file folder's icon by going to the file
    > types Tab in the folder option ,after I chose another icon, every
    > time I click over a folder, search menu popped out so I got back to
    > the folder option and set every thing as its defaults, now I got
    > another problem and can't fix it ,each folder doesn't open in the
    > same window ,even by choosing the "open each folder ...." from the
    > folder option ,can anyone help me to fix this. Thanks
    >
    > Afshin
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Afshin,

    Type REGSVR32 /i SHELL32 in Start/Run dialog.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org
    --------------------------------------------
    Using ToolbarCop to remove the unwanted Toolband, Toolbar Icons and BHO:
    http://windowsxp.mvps.org/toolbarcop.htm
    --------------------------------------------
    The Parasite Fight - Quick Fix Protocol:
    http://aumha.org/a/quickfix.php
    --------------------------------------------
    "A-Design" <afshinstock@hotmail.com> wrote in message news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl...
    I was trying to change the file folder's icon by going to the file types Tab
    in the folder option ,after I chose another icon, every time I click over a
    folder, search menu popped out so I got back to the folder option and set
    every thing as its defaults, now I got another problem and can't fix it
    ,each folder doesn't open in the same window ,even by choosing the "open
    each folder ...." from the folder option ,can anyone help me to fix this.
    Thanks

    Afshin
  3. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thank you so much Ramesh that fixed the problem.
    Afshin,

    "Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
    news:OBDO9BwwEHA.3844@TK2MSFTNGP09.phx.gbl...
    Afshin,

    Type REGSVR32 /i SHELL32 in Start/Run dialog.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org
    --------------------------------------------
    Using ToolbarCop to remove the unwanted Toolband, Toolbar Icons and BHO:
    http://windowsxp.mvps.org/toolbarcop.htm
    --------------------------------------------
    The Parasite Fight - Quick Fix Protocol:
    http://aumha.org/a/quickfix.php
    --------------------------------------------
    "A-Design" <afshinstock@hotmail.com> wrote in message
    news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl...
    I was trying to change the file folder's icon by going to the file types Tab
    in the folder option ,after I chose another icon, every time I click over a
    folder, search menu popped out so I got back to the folder option and set
    every thing as its defaults, now I got another problem and can't fix it
    ,each folder doesn't open in the same window ,even by choosing the "open
    each folder ...." from the folder option ,can anyone help me to fix this.
    Thanks

    Afshin
  4. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    This did not correct the issue. I've tried every fix I could find on the web
    to no avail. It appears that many people have this problem and there are at
    leat as many fixes! Why hasn't MS addressed this issue?

    Thanks for any suggestions you may have.

    "Ramesh [MVP]" wrote:

    > Afshin,
    >
    > Type REGSVR32 /i SHELL32 in Start/Run dialog.
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    > --------------------------------------------
    > Using ToolbarCop to remove the unwanted Toolband, Toolbar Icons and BHO:
    > http://windowsxp.mvps.org/toolbarcop.htm
    > --------------------------------------------
    > The Parasite Fight - Quick Fix Protocol:
    > http://aumha.org/a/quickfix.php
    > --------------------------------------------
    > "A-Design" <afshinstock@hotmail.com> wrote in message news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl...
    > I was trying to change the file folder's icon by going to the file types Tab
    > in the folder option ,after I chose another icon, every time I click over a
    > folder, search menu popped out so I got back to the folder option and set
    > every thing as its defaults, now I got another problem and can't fix it
    > ,each folder doesn't open in the same window ,even by choosing the "open
    > each folder ...." from the folder option ,can anyone help me to fix this.
    > Thanks
    >
    > Afshin
    >
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    | Thanks for any suggestions you may have.
    | > "A-Design" <afshinstock@hotmail.com> wrote
    | > I was trying to change the file folder's icon by going to the file types Tab
    | > in the folder option ,after I chose another icon, every time I click over a
    | > folder, search menu popped out so I got back to the folder option and set
    | > every thing as its defaults, now I got another problem and can't fix it
    | > ,each folder doesn't open in the same window ,even by choosing the "open
    | > each folder ...." from the folder option ,can anyone help me to fix this.
    | > Thanks
    | >
    | > Afshin

    | "Ramesh [MVP]" wrote:
    | > Afshin,
    | > Type REGSVR32 /i SHELL32 in Start/Run dialog.
    | > --
    | > Ramesh, Microsoft MVP

    "bfenster" <bfenster@discussions.microsoft.com> wrote
    | This did not correct the issue. I've tried every fix I could find on the web
    | to no avail. It appears that many people have this problem and there are at
    | leat as many fixes!

    It does correct the issue *after* you fiddle around in File Types > Folder

    What are all those "fix(es you) could find on the web" ?

    | Why hasn't MS addressed this issue?

    You will never find the answer to that question in these newsgroups.
  6. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    This is getting confusing. So, for anyone interested and willing to help Let
    me try to clarify my problem. My WIN XP Pro will not open folders in the same
    window.
    1. It is configured to do so per folder options.
    2. I have run "REGSVR32 /i SHELL32" and rebooted before and after step 3
    below.
    3. I went to File types/folder/advanced and set "explore" to "default". Hate
    that option!
    4. I noticed on a different system that there is no default set for "open"
    or "explore". However, there is no way to turn both defaults off, I.E., it is
    either "explore" or "open".
    5. There is another thread in this forum named "Folder Options Problems!"
    where I submitted further information (export of Registry settings) that was
    requested by "Ramesh [MVP] that you can check out.

    Thanks, Bruce
  7. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    That fixed the search issue. You need to undo your fix of the search issue then type that command again. You haven't said what you did to fix exactly. I suspect you added something to the registry (via file types dialog), specifically an Open verb on File Folder which will override the correct settings.

    Every time you use the File Types dialog to edit folders you must type that command. The File Types dialog writes registry entries for older windows versions which only matters on folders (as the rules in choosing the default command is slightly different in XP). Hence Open is no longer the default and it will take the first verb it can find, which is search on a non edited registry. This is because it has exausted it's list of options and is on it's last fallback strategy of anything it can find. This is a well known minor bug.

    Directories (File Folders) inherit their open command from Folders. The file types dialog writes a win 95 entry but XP expects a XP entry so the inheritance link of the default action is lost but not the inheritance itself.

    Adding an Open to Directory will override Folders' Open. The Open command is not a simple one and most people wouldn't know how to add correctly.

    --
    ----------------------------------------------------------
    http://www.uscricket.com
    "bfenster" <bfenster@discussions.microsoft.com> wrote in message news:D72A887C-D81E-46A0-ABFA-BE923DF4A486@microsoft.com...
    > This did not correct the issue. I've tried every fix I could find on the web
    > to no avail. It appears that many people have this problem and there are at
    > leat as many fixes! Why hasn't MS addressed this issue?
    >
    > Thanks for any suggestions you may have.
    >
    > "Ramesh [MVP]" wrote:
    >
    >> Afshin,
    >>
    >> Type REGSVR32 /i SHELL32 in Start/Run dialog.
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >> --------------------------------------------
    >> Using ToolbarCop to remove the unwanted Toolband, Toolbar Icons and BHO:
    >> http://windowsxp.mvps.org/toolbarcop.htm
    >> --------------------------------------------
    >> The Parasite Fight - Quick Fix Protocol:
    >> http://aumha.org/a/quickfix.php
    >> --------------------------------------------
    >> "A-Design" <afshinstock@hotmail.com> wrote in message news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl...
    >> I was trying to change the file folder's icon by going to the file types Tab
    >> in the folder option ,after I chose another icon, every time I click over a
    >> folder, search menu popped out so I got back to the folder option and set
    >> every thing as its defaults, now I got another problem and can't fix it
    >> ,each folder doesn't open in the same window ,even by choosing the "open
    >> each folder ...." from the folder option ,can anyone help me to fix this.
    >> Thanks
    >>
    >> Afshin
    >>
    >>
    >>
    >>
  8. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    "bfenster" <bfenster@discussions.microsoft.com> wrote
    | This is getting confusing. So, for anyone interested and willing to help Let
    | me try to clarify my problem. My WIN XP Pro will not open folders in the same
    | window.
    | 1. It is configured to do so per folder options.
    | 2. I have run "REGSVR32 /i SHELL32" and rebooted before and after step 3
    | below.
    | 3. I went to File types/folder/advanced and set "explore" to "default". Hate
    | that option!
    | 4. I noticed on a different system that there is no default set for "open"
    | or "explore". However, there is no way to turn both defaults off, I.E., it is
    | either "explore" or "open".
    | 5. There is another thread in this forum named "Folder Options Problems!"
    | where I submitted further information (export of Registry settings) that was
    | requested by "Ramesh [MVP] that you can check out.
    |
    | Thanks, Bruce


    0. and 5. Confusing, yes. Threads must be crossed.

    Maybe (long shot) - in Internet Options
    Advanced tab
    [?] Reuse windows for launching shortcuts
  9. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thanks but "Reuse windows for launching shortcuts" already set.

    "a nonymous" wrote:

    >
    > "bfenster" <bfenster@discussions.microsoft.com> wrote
    > | This is getting confusing. So, for anyone interested and willing to help Let
    > | me try to clarify my problem. My WIN XP Pro will not open folders in the same
    > | window.
    > | 1. It is configured to do so per folder options.
    > | 2. I have run "REGSVR32 /i SHELL32" and rebooted before and after step 3
    > | below.
    > | 3. I went to File types/folder/advanced and set "explore" to "default". Hate
    > | that option!
    > | 4. I noticed on a different system that there is no default set for "open"
    > | or "explore". However, there is no way to turn both defaults off, I.E., it is
    > | either "explore" or "open".
    > | 5. There is another thread in this forum named "Folder Options Problems!"
    > | where I submitted further information (export of Registry settings) that was
    > | requested by "Ramesh [MVP] that you can check out.
    > |
    > | Thanks, Bruce
    >
    >
    > 0. and 5. Confusing, yes. Threads must be crossed.
    >
    > Maybe (long shot) - in Internet Options
    > Advanced tab
    > [?] Reuse windows for launching shortcuts
    >
    >
    >
  10. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    | > "bfenster" <bfenster@discussions.microsoft.com> wrote
    | > | This is getting confusing. So, for anyone interested and willing to help Let
    | > | me try to clarify my problem. My WIN XP Pro will not open folders in the same
    | > | window.
    | > | 1. It is configured to do so per folder options.
    | > | 2. I have run "REGSVR32 /i SHELL32" and rebooted before and after step 3
    | > | below.
    | > | 3. I went to File types/folder/advanced and set "explore" to "default". Hate
    | > | that option!
    | > | 4. I noticed on a different system that there is no default set for "open"
    | > | or "explore". However, there is no way to turn both defaults off, I.E., it is
    | > | either "explore" or "open".
    | > | 5. There is another thread in this forum named "Folder Options Problems!"
    | > | where I submitted further information (export of Registry settings) that was
    | > | requested by "Ramesh [MVP] that you can check out.
    | > | Thanks, Bruce

    | "a nonymous" wrote:
    | > 0. and 5. Confusing, yes. Threads must be crossed.
    | >
    | > Maybe (long shot) - in Internet Options
    | > Advanced tab
    | > [?] Reuse windows for launching shortcuts

    "bfenster" <bfenster@discussions.microsoft.com> wrote
    | Thanks but "Reuse windows for launching shortcuts" already set.


    Assuming that nothing is actually wrong with your XP installation, the only other
    setting might be:
    Windows Explorer
    Tools
    Folder Options
    View
    Advanced settings:
    [_] Launch folder windows in a separate process
    - -

    Regarding item 5 above, I see no trace of that thread in my reader,
    (especially no recent activity)
    - -

    Regarding item 4 above...

    For actual directories on a disk drive:
    Windows Explorer
    Tools
    Folder Options
    File Types
    File Folder
    Actions:
    search (but it is *not* selected as default)

    HKEY_CLASSES_ROOT\Directory\shell
    (Default) REG_SZ none

    (Deleting the data in the (Default) value will ensure that there
    will not be any default action for that file type.)


    For virtual folders (such as My Computer):
    Windows Explorer
    Tools
    Folder Options
    File Types
    Folder
    Actions:
    explore -and- open (but *neither* is selected as default)

    HKEY_CLASSES_ROOT\Folder\shell
    (Default) REG_SZ none
    - -

    Regarding item 3 above, what do you mean by "Hate that option!" ?
  11. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    1. My XP pro has been installed for years. I'm a reasonably sophisticated
    user with a programming & support backgound that works for IBM. I've kept my
    system neat & tidy. I'm clean of viruses per (AVG) and Spyware per (Add-Aware
    & Spybot S&D). This issue began out of nowhere when I booted a few days ago.
    The first symtom was that folder option "Show common tasks in folders" was
    active when I booted up. I never use that option!
    2. Already tried "Launch folder windows in a separate process".
    3. The thread you don't see is "Folders Options Problems!" in "Expert Zone
    newsgroups" dated 8/14. Did you select Show: "All threads"?
    4. "Hate that option" means I'd rather go to the dentist than use it. I'll
    deal with multiple windows first which I also hate just slightly less!
    5. I don't give up easily but I'm getting close!

    Bruce

    "a nonymous" wrote:

    >
    > | > "bfenster" <bfenster@discussions.microsoft.com> wrote
    > | > | This is getting confusing. So, for anyone interested and willing to help Let
    > | > | me try to clarify my problem. My WIN XP Pro will not open folders in the same
    > | > | window.
    > | > | 1. It is configured to do so per folder options.
    > | > | 2. I have run "REGSVR32 /i SHELL32" and rebooted before and after step 3
    > | > | below.
    > | > | 3. I went to File types/folder/advanced and set "explore" to "default". Hate
    > | > | that option!
    > | > | 4. I noticed on a different system that there is no default set for "open"
    > | > | or "explore". However, there is no way to turn both defaults off, I.E., it is
    > | > | either "explore" or "open".
    > | > | 5. There is another thread in this forum named "Folder Options Problems!"
    > | > | where I submitted further information (export of Registry settings) that was
    > | > | requested by "Ramesh [MVP] that you can check out.
    > | > | Thanks, Bruce
    >
    > | "a nonymous" wrote:
    > | > 0. and 5. Confusing, yes. Threads must be crossed.
    > | >
    > | > Maybe (long shot) - in Internet Options
    > | > Advanced tab
    > | > [?] Reuse windows for launching shortcuts
    >
    > "bfenster" <bfenster@discussions.microsoft.com> wrote
    > | Thanks but "Reuse windows for launching shortcuts" already set.
    >
    >
    >
    > Assuming that nothing is actually wrong with your XP installation, the only other
    > setting might be:
    > Windows Explorer
    > Tools
    > Folder Options
    > View
    > Advanced settings:
    > [_] Launch folder windows in a separate process
    > - -
    >
    > Regarding item 5 above, I see no trace of that thread in my reader,
    > (especially no recent activity)
    > - -
    >
    > Regarding item 4 above...
    >
    > For actual directories on a disk drive:
    > Windows Explorer
    > Tools
    > Folder Options
    > File Types
    > File Folder
    > Actions:
    > search (but it is *not* selected as default)
    >
    > HKEY_CLASSES_ROOT\Directory\shell
    > (Default) REG_SZ none
    >
    > (Deleting the data in the (Default) value will ensure that there
    > will not be any default action for that file type.)
    >
    >
    > For virtual folders (such as My Computer):
    > Windows Explorer
    > Tools
    > Folder Options
    > File Types
    > Folder
    > Actions:
    > explore -and- open (but *neither* is selected as default)
    >
    > HKEY_CLASSES_ROOT\Folder\shell
    > (Default) REG_SZ none
    > - -
    >
    > Regarding item 3 above, what do you mean by "Hate that option!" ?
    >
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Sorry for the late response,
    I just did what Ramesh told for me,and that fixed the problem.
    Thanks,


    "David Candy" <.> wrote in message
    news:ufcSKhBzEHA.2804@TK2MSFTNGP15.phx.gbl...
    That fixed the search issue. You need to undo your fix of the search issue
    then type that command again. You haven't said what you did to fix exactly.
    I suspect you added something to the registry (via file types dialog),
    specifically an Open verb on File Folder which will override the correct
    settings.

    Every time you use the File Types dialog to edit folders you must type that
    command. The File Types dialog writes registry entries for older windows
    versions which only matters on folders (as the rules in choosing the default
    command is slightly different in XP). Hence Open is no longer the default
    and it will take the first verb it can find, which is search on a non edited
    registry. This is because it has exausted it's list of options and is on
    it's last fallback strategy of anything it can find. This is a well known
    minor bug.

    Directories (File Folders) inherit their open command from Folders. The file
    types dialog writes a win 95 entry but XP expects a XP entry so the
    inheritance link of the default action is lost but not the inheritance
    itself.

    Adding an Open to Directory will override Folders' Open. The Open command is
    not a simple one and most people wouldn't know how to add correctly.

    --
    ----------------------------------------------------------
    http://www.uscricket.com
    "bfenster" <bfenster@discussions.microsoft.com> wrote in message
    news:D72A887C-D81E-46A0-ABFA-BE923DF4A486@microsoft.com...
    > This did not correct the issue. I've tried every fix I could find on the
    > web
    > to no avail. It appears that many people have this problem and there are
    > at
    > leat as many fixes! Why hasn't MS addressed this issue?
    >
    > Thanks for any suggestions you may have.
    >
    > "Ramesh [MVP]" wrote:
    >
    >> Afshin,
    >>
    >> Type REGSVR32 /i SHELL32 in Start/Run dialog.
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >> --------------------------------------------
    >> Using ToolbarCop to remove the unwanted Toolband, Toolbar Icons and BHO:
    >> http://windowsxp.mvps.org/toolbarcop.htm
    >> --------------------------------------------
    >> The Parasite Fight - Quick Fix Protocol:
    >> http://aumha.org/a/quickfix.php
    >> --------------------------------------------
    >> "A-Design" <afshinstock@hotmail.com> wrote in message
    >> news:OEV3hvrwEHA.1988@TK2MSFTNGP12.phx.gbl...
    >> I was trying to change the file folder's icon by going to the file types
    >> Tab
    >> in the folder option ,after I chose another icon, every time I click over
    >> a
    >> folder, search menu popped out so I got back to the folder option and set
    >> every thing as its defaults, now I got another problem and can't fix it
    >> ,each folder doesn't open in the same window ,even by choosing the "open
    >> each folder ...." from the folder option ,can anyone help me to fix
    >> this.
    >> Thanks
    >>
    >> Afshin
    >>
    >>
    >>
    >>
Ask a new question

Read More

Configuration Microsoft Customization Windows XP