I need to reinstall Catalyst on each reboot

Hello, everyone. I hope you can help me with a problem I've been having lately with my display drivers for my Radeon card.

The problem: Since a while ago, it seems that the Catalyst drivers revert every time I restart my computer. I notice because when I start pretty much anything that makes somewhat decent use of the graphics card, such as pretty much any game, I get a lot of stuttering that renders the application basically unusable.

The first time it happened, I tried reinstalling graphics drivers, and it worked! Until I rebooted. Then it starts stuttering again, which is again stopped if I just reinstall the Catalyst drivers. It's as if it reverts every time I reboot. But opening the Catalyst manager and checking version tells me the latest version is installed correctly even before I do the reinstall.

I honestly have no idea what may be causing this. I've been at this for a month, and while to be honest reinstalling Catalyst every restart is just three minutes, it's still a nuisance and it worries me a bit, whether the Catalyst uninstaller is leaving something there that is causing problems, or if it's symptomatic of some other problem.

If anyone has any suggestions, I'd be infinitely thankful, and if you need further spec data or similar, don't hesitate to ask (I'm just not sure what would be applicable here).

Thank you for your time.
2 answers Last reply
More about reinstall catalyst reboot
  1. Uninstall CCC install manager in add/remove programs
    Download http://phyxion.net/item/driver-sweeper.html
    Run it in safemode 1st time
    Check off Amd display
    Analyze and clean
    Reboot normal mode
    Download and install latest CCC
    Install as Admin
    If you still have issues you have a hardware problem = card or psu
  2. Tried it. Is it normal that uninstalling everything from the catalyst uninstaller has the screen basically losing all contrast and me seeing everything black with vague blue outlines?

    In any case, since I knew the windows and could navigate them despite barely seeing the buttons, I did as you explained. It doesn't seem to have worked, so I'm presuming a hardware problem.

    Why do you think it could be the PSU? I mean, I would completely believe it, because last time I took the computer for repairs they had to change my PSU and this trouble started soon after, so it seems a likely culprit. But it seems counterintuitive that a PSU failure would only affect this particular thing.

    In any case, many thanks for your help!
Ask a new question

Read More

Radeon Drivers Catalyst Graphics