Sign in with
Sign up | Sign in
Your question

Somewhat unique 5770 crossfire problem

Last response: in Graphics & Displays
Share
February 5, 2012 5:21:58 PM

Hello. I've got a crossfire problem that I've seen solved here and elsewhere but my mobo prevents me from fixing the problem like most people would. I've got 2 xfx 5770's that used to work just fine in crossfire mode. Each card works independently of the other while plugged in and I've tested both as the primary card so that I can be sure they are working. The second card, whichever one is in the lower slot, is always stuck in pcie- 2x mode and shows up as a disabled adaptor in CCC.

I've seen other places where people were told to set it to 4x mode and poof, problem solved, but my mobo is an asus m4a785td-v-evo. I can't control that from the bios.

My system is a phenom 955 in the aforementioned asus board with 12 gigs of ram. I know its an aging build and I plan on building a new pc later this year but I'd like to get every last bit of oomph out of it that I can until then.
February 5, 2012 6:54:16 PM

did you use the blue and the gray slot that are the pci-e 16 slots also did you download the driver for crossfire
m
0
l
February 5, 2012 7:03:07 PM

Yeah. I've been having this problem since the driver version was 10. something and now we're up to 12.1 so I've just been dragging feet, puttering with it occasionally and today in SWTOR it started lagging and I decided to seek some help.

The cards are also most definitely plugged into the right slots. Don't think the xfire bridge would reach if they weren't, but thankyou.
m
0
l
Related resources
February 5, 2012 7:10:56 PM

you got the 12.1 ccc did you put also put the 12.1 cap for crossfire
m
0
l
February 5, 2012 7:22:41 PM

I've got an older profiles for crossfire, but I'm not to that point yet. I can't get ccc to even acknowledge crossfire to begin with. The second card shows up as a disabled adaptor in hardware.


Really all I'm looking for is a way to get it out of 2x mode that doesn't involve the bios.
m
0
l
February 5, 2012 7:26:27 PM

remove the old crossfire and put the new one with the 12.1 and see what are the results
m
0
l
February 5, 2012 7:28:59 PM

Just my two cents - but I have flashed both of my cards (XFX) over to 6770 roms, and both run terrifically. As a side note, this also saved some much needed option rom space as the 6770 bios is 1/2 the size. I never had mine drop to 2x mode though, and don't honestly know if it will fix that problem.
m
0
l
February 5, 2012 7:34:58 PM

Nada.

This is a problem that has persisted through several catalyst versions and as many cap profiles in addition to several fresh installs of windows. Installed the 12.1 and it didn't seem to take any notice of it.
m
0
l
February 5, 2012 7:47:01 PM

Jim could you show me some material on that operation? Reflashing a video card has always seemed like one of those last ditch effort things, like the next step after that is just hitting it with a hammer until it works or your hammer breaks.
m
0
l
February 5, 2012 7:47:47 PM

did you try to interchange the card from the one in first slot move to second slot and second move to first and see results
m
0
l
February 5, 2012 7:50:02 PM

Yes. No problems. Even with how it is right now I can plug a monitor into the second card and sure enough it will display. Its like its working, but stuck in 2x mode and unable to get into crossfire.
m
0
l
February 5, 2012 8:00:56 PM

Other than the two graphics cards, do you have any other expansion cards plugged in?

On a side note: I'm not sure sw:tor has official crossfire support yet. If you get your Crossfire working and they haven't yet added support for XFire, try googling for some workarounds.
m
0
l
February 5, 2012 8:05:35 PM

Neither am I, but I haven't bothered to look up what has crossfire support and what doesn't in forever because it hasn't worked in forever. I have no other cards in the pc. I've seen this problem before and people have resolved it by setting the second card to pcie 4x mode in bios but my bios just doesn't have that option. Thats what I really need a workaround for.
m
0
l
February 5, 2012 8:12:16 PM

Based on your motherboard's support page, the motherboard should default to x16 on the blue slot and x4 on the grey slot. It is indeed odd that it is defaulting the grey slot to x2 in absence of any other pci cards.

I don't know how savvy you are to bios settings, but I would clear the cmos (reset the BIOS to defaults). Your board should do what it says by default and it says it should do x16 and x4 and it even has official XFire support.
m
0
l
February 5, 2012 8:12:37 PM

After running the render test in gpuz the second card now shows up as an enabled adapter in ccc where it said disabled before, but is still stuck in 2x mode
m
0
l
February 5, 2012 8:14:36 PM

Thanks lark, but already gave that a go. Was even extra thorough and removed the battery for a bit. Going to try it again though since its now considered an enabled adapter in ccc.
m
0
l
February 5, 2012 8:18:35 PM

Check the socket itself for debris or damage. If the card still shows up as 2x with no other slots occupied, then the connector itself is damaged. Don't think of it as a disaster, consider it "an opportunity for an upgrade."
m
0
l
February 5, 2012 8:19:32 PM

Sounds like a motherboard issue then. Have you tried a BIOS update?

Since its enabled though, try benching it and see if you're close to similar systems.
m
0
l
February 5, 2012 8:50:49 PM

da-focker said:
Jim could you show me some material on that operation? Reflashing a video card has always seemed like one of those last ditch effort things, like the next step after that is just hitting it with a hammer until it works or your hammer breaks.

The process is fairly straight forward.
First, create a DOS bootable USB drive.
Then download this ROM, and the ATI Flash utility
Once you have those files, decompress them, and copy all the files to your flash drive.
Reboot using your flash drive.
Run atiflash -s 0 oldbios.bin to back up your current BIOS. The S 0 is your card number (zero for the first, then one for the second). You should rename the backup accordingly oldbios1.bin and oldbios2.bin - just to be sure you have good copies of both.
Then run atiflash -p 0 newbios.bin (replace newbios.bin with the actual bios name) to program the first card. DO NOT reprogram both cards at once. First restart the PC to ensure it will accept the new flash. Everything should be good, and both cards will actually work in X-Fire together (believe it or not).
Once verified that your cards will work normally with the new bios, then reboot back to your flash drive, and run atiflash -p 1 newbios.bin to program the second card.

Restart, and life should be grand.

EDIT: Sorry, slight error - you need to run the command as atiflash -f -p 0 newbios.bin, the -f is needed to force the flash.
m
0
l
February 5, 2012 11:16:14 PM

Think I'm gonna wind up just hitting it with a hammer. The adapter is back to being listed as disabled and running gpu-z's render function doesn't change anything anymore.
m
0
l
February 6, 2012 7:04:17 AM

da-focker said:
Think I'm gonna wind up just hitting it with a hammer. The adapter is back to being listed as disabled and running gpu-z's render function doesn't change anything anymore.


Asus shows 18 Bios versions,which one are you using?

there is now a 12.2 preview version of ccc,12.1 had horrible reviews,I bypassed it.

what PSU are you using?


also try this"
1-uninstall CCC and profiles from add/remove programs,shut down
2-remove second card,restart,install latest ccc 12.2 previews and profiles,shut down
3-reinstall second card(bridge and power connectors)
4-restart and retry.

your 955 is good enough to play BF3,after everything else,O/C it a little.

also,monitors are to be plugged into the primary card only.and disable the onboard video in the bios.
m
0
l
!