Sign in with
Sign up | Sign in
Your question

[1st build] New AMD build won't post

Last response: in Systems
Share
April 14, 2012 12:23:58 AM

My new PC's fans turn on (except the GPU) and the Keyboard lights flash but it doesn't post or show video on the screen.

CPU: AMD Phenom II x4 955 Black edition
MoBo: Biostar A780l3g
RAM: Kingston KHX 1600C9AD3K2
PSU: Corsair CX500 Builders series
GPU: Nvidia 9500gt

I don't think it's the RAM because the ram is proven to work with the Motherboard and I think the PSU is fine because the Fans spin. I know it's not the GPU because it works fine in my old PC. I tried re-seating the Ram and I know that the cpu power is plugged in so I think it's the CPU or the motherboard.
April 14, 2012 12:38:24 AM

step 1. check to make sure all the mb, cpu and cpu cooling wires are connected
step 2. check to see if the video card is seated properly first take out and re-insert if that does not work take out the screw securing the the video card at the back and with your hand move the card to see if there is a loose connection in the psi connector box.
m
0
l
Related resources
April 14, 2012 1:31:16 AM

I'm sure all the wires are plugged in and I've tried integrated graphics with the same result however when I tried to start up with only one stick of ram in the slot furthest from the cpu the fan's start up then shut off within a few seconds even the case fan. Also i just remembered that I changed the ram from an Adata xpg series because it was giving no memory beeps and iv'e gone through most of the stuff on the list except breadboarding because i don't know what a good insulated surface would be.
m
0
l
April 14, 2012 1:39:47 AM

beginning to sound like the mb has had the dick
m
0
l
June 25, 2012 7:28:45 PM

Sorry for being away for so long but I recently got the motherboard back from Biostar and the problem is still there.

When i turn on my computer there is a small amount of heat near the heatsink but i'm not sure if it's from the cpu or something else.

Edit: I get beeps when I try to boot without any ram. Does this mean that the cpu is working.
m
0
l
!