Sign in with
Sign up | Sign in
Your question

Computer laggg with a alright RIG

Last response: in Graphics & Displays
Share
February 8, 2012 6:22:16 AM

Hello,

Ok so my rig gigabyte mobo not sure model number
6870 saphire card
phenom II 955 BE 3.2 Quad core
1tb western digital HD
6GB DDR2
770w OCZ PSU

I lag all the time...Im using windows 7 64bit and I thought my rig was ok not the greatest bit ok please try and help me out I play MW2 mainly but also amnesia,dead island,ut3,gw and I lag on them all my internet Is only 1 MB upload speed which sucks but even games that dont req internet lag Im lost and dont know where to look I did the windows 7 thing where it scores your computer the max is 7.9 my GPU is 7.7 my cpu and ram are 7.1 but my hard drive is 5.9 i dont think that would matter but Im just giving you all the info I can when I play MW2 if I use frapps its a little worse not much but even when I turn the graphics real low I till get lag I dont know if its my HD, or RAM maybe even my cpu the video card is 2 weeks old the hard drive is about 6 months old and the cpu and ram were bought about 1yr and a half ago any tips at all would be greatful thanks in advance
February 8, 2012 6:28:39 AM

How are you running ddr2???
m
0
l
February 8, 2012 6:48:06 AM

Did you previously have an nvidia card?
m
0
l
Related resources
February 8, 2012 7:27:03 AM

no to the nvidia card and I am running 3 sticks of ddr2
m
0
l
February 9, 2012 4:24:30 AM

myro said:
no to the nvidia card and I am running 3 sticks of ddr2

How do you place them in the RAM slots? Ideally it should be even like 2 or 4 sticks. Try removing 1 stick that is not in the same color as the other two slots.
m
0
l
!