Sign in with
Sign up | Sign in
Your question

Com lags on certain games

Last response: in Systems
Share
April 16, 2012 4:09:42 AM

Hi,
I've just built a new desktop computer, here are the specs

Windows 7 Ultimate
i5-2500
Asus P8H67-M Pro
2x2GB RAM Kingston 1333
1.5 TB 5400 RPM
500 GB 5400RPM
GTX 560Ti

Thing is, this setup plays Mass Effect 3 and Battlefield 3 fine with no framerate issues whatsoever.
However, it keeps lagging and stuttering on Company of Heroes, which is odd considering its an older game...I've updated to the latest Nvidia drivers for the 560Ti so i'm really at a loss as to whats the problem

I'm thinking either insufficient RAM or slow hdd speeds (ive defragmented the HDDs), but that doesnt seem to explain it being able to play the later games with ease

I'd really appreciate the help! Thanks in advance

More about : lags games

a b B Homebuilt system
April 16, 2012 11:10:18 AM

try enabling or disabling the vertical sync in CoH.

look at the Anti Aliasing and Anisotropic Filtering filtering settings in CoH as well they might be cranked to max.
m
0
l
April 16, 2012 11:35:24 AM

Hey, thanks for the reply! AA and AF are both turned off, theres no vertical sync option. I suspect the framerate issues are due to a poorly made mod that (for some reason) uses a lot more memory than the vanilla CoH. Still, I cant imagine how a 2006 game manages to perform so badly on my setup.

If I could upgrade anything at a budget of around $200, what should I get? I'm already getting an upgrade for the RAM to 8gb. Looking at either a 2nd 500GB HDD for raid 0 with the one I already have, or a mobo upgrade to the Z68 mobos (with the integrated SSD cache), or just get a separate SSD for the games.

Also note that my PSU is 550W, which is technically (i think) fine but im not sure if its pushing the power limits..
m
0
l
Related resources
a b B Homebuilt system
April 16, 2012 12:56:16 PM

make sure the game patch up there a lot of patches.
also i would try from there guild to try this
C:\Program Files\THQ\Company of Heroes\RelicCOH.exe” -novsync
let nvidia game card set up the vsync using that will turn off the 60 fps cap.
there also one on there cuild for tripple buffer i would use that one next if turning off vsync does not help.
also check that you have the directx installed.
http://www.microsoft.com/download/en/details.aspx?id=35
the game is an older 9x game that been ported..there may be a bug with how dix10 trys to run the game.
m
0
l
April 16, 2012 1:50:27 PM

Well, its patched up to the latest. Ive tried the novsync, not sure if anything happened though (a quick google search points to a cap on fps to the monitor refresh rate). Well, I've just decided not to play the mod in question (EuropeanTheater 1944) and try others as a change.

Just FYI, the framerate issues DONT go dont very much even when i switch to the lowest settings so I dont think its the hardware? I have DX10 installed, and the installer you linked to doesnt allow me to overwrite a more recent installation.

Seriously though, thanks man I really appreciate the help. Its just really annoying when things dont make sense (older game performs worse!?). Odd.
m
0
l
!