Sign in with
Sign up | Sign in
Your question

Asus Xonar Essence STX Not Detected. Please Help!!!!!!

Last response: in Components
Share
July 29, 2012 5:46:39 PM

I just Built my computer everything is working fine and dandy. So i do my final step in the build and thats installing the asus xonar essence stx. Windows is not detecting this card, i know about the 4 pin power cord issues this card has and it is in there nice and snug i think. I hope the card or pcie x1 slot is not bad, but i actually think they are fine. Guys please help me get this card working i an really getting frustrated here. I did updates , installed drivers. And this thing will not be detected by windows 7. Please Help!!!!!!

Thank Will


Oh my motherboard by the way is a Asus sabertooth 990 fx Amd.
July 29, 2012 5:50:41 PM

Try this, see if its detected in device manager (search it in the start menu), go to sound, video and game controllers (i think thats what its called), see if its there.

Also in the BIOS (press esc when you see the ASUS logo), see if you can disable onboard audio.
m
0
l
July 29, 2012 6:06:28 PM

jay_nar2012 said:
Try this, see if its detected in device manager (search it in the start menu), go to sound, video and game controllers (i think thats what its called), see if its there.

Also in the BIOS (press esc when you see the ASUS logo), see if you can disable onboard audio.

Hey i found it in the device manager. It has the yellow caution looking triangle next to it???????
m
0
l
Related resources
July 29, 2012 6:12:12 PM

Try uninstalling the device (click on the card once in device manager and click del/delete on your keyboard, a prompt will come up, click yes) and then restart and when you log on to windows, it should find and install the drivers.
m
0
l
July 30, 2012 2:05:02 AM

still having problems installing card please help.
m
0
l
a b Ĉ ASUS
July 30, 2012 2:56:37 AM

Try the Xonar Unified Drivers and see if that helps.

The way my Xense worked, if I tried to install the drivers without the power connector plugged in, the driver install software would warn me. Can't imagine the STX would be any different...

Worst case, reconnect the 4-pin connector. I never had any problems with it, but a LOT of people have complained about it being flimsy.
m
0
l
July 30, 2012 4:11:25 AM

Hey gamerk316 where is the best site to download these unified drivers. I am running out of options here it seems. I hope they work.
m
0
l
July 30, 2012 4:32:32 AM

i mean this sound card isnt even popping up on device manager on win7 home preimium. Wtf!!!!!!
m
0
l
July 30, 2012 2:55:46 PM

But shouldnt this card be detected before any drivers are evn installed. Or do the drivers need to be added for the card to be detected. Could the pci ex1 slot be turned off on motherboard and if so how would i be able to activated this pci e x1 slot on asus sabertooth 990 fx. I am starting to believe i got a bad card.
m
0
l
a b Ĉ ASUS
July 30, 2012 3:05:13 PM

Its possible. I believe the soundcard will come up as a "Generic C-Media Audio Device" in the control panel before drivers are installed. So either its not getting power from the power connector, the PCI-E slot has problems, or the card is bad.

Just for kicks, try a different PCI-E slot. At the very least, reconnect the 4-pin connector again.
m
0
l
July 30, 2012 3:16:38 PM

yeah dude i just put it in the top and bottom pci e express slots the longer slots for vids cards and still nothing so i am sure my pci e x1 slot is fine. How long does it take for newegg to do an exchange i dont have the paper invoice they sent me anymore will that be a problem or can i just use my newegg account for rma?????
m
0
l
July 30, 2012 3:19:07 PM

this is a shame this was what i couldnt wait for to use with my new corsair 2500 2.1 speaker setup i bought and my new shure headphones. i am very dissapointed and frustrated from this dam card.
m
0
l
July 30, 2012 4:07:36 PM

Doesn't your comp already have audio ports, they will be alright until you sort out your SPU..
m
0
l
July 30, 2012 4:07:55 PM

well i just found out i cant RMA this card back to newegg its been 36 days and they wont let me. guess i am buying a new one.
m
0
l
July 30, 2012 6:47:58 PM

YES!YES!YES! I GOT IT WORKING! I downloaded those drivers from brainbits site and bam. This sound card with this corsair sp 2500 speaker setup are amazing. They sound almost as good as my onkyo setup for real no lie just with less power. Maybe even cleaner. Thank alot guys for all your help.
m
0
l
July 30, 2012 6:57:38 PM

Congrats on the working sound card, and your welcome.
m
0
l
August 18, 2012 7:11:58 PM

Man i had the very same problem with my card it was like no power was going to the card but what it was just a setting for the pciex1 slot it wouldnt even load the drivers because my motherboard Asus Sabertooth Z77 didnt recognized the card but i had a guy figure it out for me it was a setting in the bios it was like the pci-e x1 slot i choose to use was disabled..if im not mistaken when you plug the card in you have to go into the bios and asign that slot to your card...soon as it was done the drivers took off and loaded...Tell you that card can be a real bitch to install..
m
0
l
August 18, 2012 7:48:55 PM

what it was i remember now is in the Cmos...has to be PCI- express 1x not 4x
m
0
l
!