Cannot get gpu to work

Hello,

recently installed a msi twin frozer ii 6970 2gb hd card in a new build, and i can't seem to get catalyst to associate itself with it. i have tried uninstalling and reinstalling the drivers, uninstalling and letting windows 7 try to find drivers, and uninstalling and getting drivers from the ati site's driver utility suite thing. nothing seems to be working and i'm going insane here... =/
8 answers Last reply
More about cannot work
  1. Are you sure you picked the right drivers and have you tried from MSI's website? Are you sure you plug the monitor cable to the card not the motherboard and BIOS setting's graphics to 'PCI-E' instead of onboard/integrated/whatever?
  2. uninstalled whatever i had prior and then used msi's drivers found from here: http://www.msi.com/product/vga/R6970-Lightning.html#/?div=Driver&os=Win7%2032

    then went to touchbios and changed boot to start from pci-e 16x. put hdmi cable into the gpu's hdmi port. on restart no indication or blip on monitor so i changed it back to the onboard. when i got back into the bios, it had changed back to have onboard graphics load first. device manager has detected it but shows code 43 "windows has stopped this device because it reported problems"

    is it possible i have a DOA board?
  3. Possibly you do :). But don't RMA just yet. Give us your specs and also make sure you plug it properly though. Because when you put it correct, set the bios to PCI-E and plug the cable to your card it should be working.
  4. refillable said:
    Possibly you do :). But don't RMA just yet. Give us your specs and also make sure you plug it properly though. Because when you put it correct, set the bios to PCI-E and plug the cable to your card it should be working.


    mobo: gigabyte z68x ud3h b3
    cpu: intel i5 2500k @ 3.30 ghz
    memory: 8gb (2x4gb) g.skill ripjaws
    gpu: msi lightning 6970 2gb hd
    os: windows 7 home premium
    psu: corsair gs800
    hdd: samsung 1tb
    optical: samsung 12x s-ata lightscribe.
    monitor: 27" acer via hdmi cable

    led's on gpu all light up, fans spin, noticeable heat emanating from top of card


    i was also thinking maybe it can't do hdmi out but maybe the dvi out. i'm using touchbios to change it to pci-e, is there any other way?
  5. You use another cable or port?
  6. my monitor doesn't have a dvi port (weird) so i'm going to go find a dvi to dsub converter first
  7. OK OK good luck :).
  8. alright, tried using both hdmi out of card and using the dvi/dsub connection, nothing happens. now i can't even access bios.
Ask a new question

Read More

Radeon GPUs Drivers Graphics