Sign in with
Sign up | Sign in
Your question

First time build, no BIOS screen

Last response: in Systems
Share
April 25, 2012 1:47:45 PM

Hey guys, this is my first time building my own computer and I am having troubles. The build is located on this page http://www.techspot.com/guides/229-desktop-buying-guide... and I followed an installation guide almost to perfection. However, whenever I boot up nothing shows on screen. All of the fans and lights are going but nothing shows up. I have tried many different monitors so I know that isn't the problem. Looking back, the only problem I was having was putting the clamp(socket) down over the CPU. I found that there was a lot of pressure needed to get it down and I fear I may have damaged the mobo's pins. Is there anyway I can confirm this or test it? Please help guys.

More about : time build bios screen

a b B Homebuilt system
April 25, 2012 2:36:30 PM

hello
firstly i would check if the power cables are connected to the video card
since its a 2500k with integrated graphics I would connect the display to the motherboard's back plate dvi and see if you get any signal.
if still nothing take out the card and try to get signal with the integrated graphic. if that works go to bios and check the primary video adapted from integrated to pcie, save and turn off. put the card in, plug the monitor to the card
April 25, 2012 2:44:45 PM

Thank you for answering. I can't seem to find any dvi on the motherboard? Maybe mine doesn't have one? Also, I bought a small speaker to connect, and instead of the one "beep" there is continuous "beeps"
Also, the power is connected to the gpu. I only see one, is there more?
Related resources
a b B Homebuilt system
April 25, 2012 2:54:13 PM

Our standard troubleshooting checklist was created to diagnose this exact type of problem. Perform all the steps in the checklist and let us know how it goes. There's a link to the checklist in my signature.
a b B Homebuilt system
April 25, 2012 2:54:46 PM

Check the motherboard manual, as it should have the beep codes in it. 3 short beeps usually is a memory issue, but not all the time.
April 25, 2012 3:19:02 PM

Here's my update.

I read the sticky, and found out the RAM wasn't in all the way. However, now when I turn it on, there are no beeps . The monitor recognizes that it is connected but nothing comes up on the screen.
a b B Homebuilt system
April 25, 2012 3:41:59 PM

There is no video connection coming from the motherboard even though the cpu has graphics capabilities. The 67's came out with overclocking ability or video ability. Yours, (P-version) is the overclocking not the H-version that has the video connections. Make sure you have both power connectors plugged into the motherboard (24 pin & 8 pin) and I would take the video card out and re-seat it and make sure it is all the way in and "locked down", also don't forget the 6 pin power connector on the video card. OH, and make sure you have the card in the 1st long blue pci-e slot, not any of the white or the 2nd or 3rd blue connectors.
April 25, 2012 4:57:57 PM

all of the pci-e slots are back. the mobo manual says its the one closest to the processor. I'm still not getting any video AND there aren't any beeps. Any other idea on how to fix my problem?

coming back to my initial concern, do you think that it could be the cpu is messed up in any way?
April 25, 2012 5:12:53 PM

The Dr. Debug LED light shows an A3 if that will help you guys help me.
April 25, 2012 5:51:10 PM

dumb qu3stion, maybe. did you connect the video to your onboard or vga card?
April 25, 2012 5:53:59 PM

i found the same problem on another site, did u connect both 6 pin power to the video card? did u install the os to the 64 bit ssd if so did you set the bios > storage config >sata controller to achii mode?
April 25, 2012 7:39:33 PM

bump, still can't find out what's up
a b B Homebuilt system
April 25, 2012 7:51:33 PM

Did you check to see what your motherboard owners manual says about an A3 error code? The error code descriptions start on page 40...

These links might also be of interest to you. Google is a beautiful thing... I found all these links by doing a simple Google search for "ASRock P67 Extreme4 A3 error code".

http://www.tomshardware.com/forum/296707-30-error-code-...

http://www.overclockers.com/forums/showthread.php?t=677...

http://forums.techarena.in/motherboard-processor-ram/14...

http://www.reddit.com/r/buildapc/comments/qdrht/trouble...
!