Sign in with
Sign up | Sign in
Your question

Belkin router URL redirects.

Last response: in Wireless Networking
Share
July 8, 2011 4:44:09 PM

Hello,

I am experiencing a great inconvenience with my relatively new Belkin Surf+ N300 wireless ADSL router.
I am confident that the router has been doing this since I got it, however I have not noticed until now. Whenever I try to access a URL with the word "router" anywhere in it (e.g www.routerwebsite.com) it will take me to my router's settings page (usually comes up when the router's LAN IP is entered)

Yes this is very handy if you don't know the LAN IP, or are less skilled in router management, however if, like in my case, you like to access websites with "router" in their URL, you have a serious problem. I have tried factory resets, and have scoured through the settings of the router but have been so far unsuccessful. I have "googled" my problem however only one thread was found with the same problem as me, and a fix was not found.

Many thanks in advance for your help! :) 
July 11, 2011 5:51:52 PM

Apologies for the double post - but it seems this thread is being buried under solved ones. Can anyone shed any light on this situation? It's a massive problem for me at the moment!

Thanks again! :) 
July 13, 2011 1:56:22 PM

I have the same issue. And found your post while looking for a solution. Trying to go to Sprouter.com and the damn thing keeps going to my router set up page.
Related resources
July 13, 2011 4:56:02 PM

Confirmation that it's on at least all of the Surf+ N300 models. Either a strange bug or a huge mistake on Belkin's part. I may try contacting them eventually if nobody else here is able to contribute any guidance or a solution, as it seems nobody is familiar with the problem.

I did hear somewhere that it was something the router did before you had set it up properly - almost like a "newbie" mode, so that you don't need to know the LAN IP of the router to access the settings.

I can't remember if it happened before I updated my firmware, so it might be fixed in a new version, who knows :( 
July 14, 2011 2:33:45 AM

I have a different router and my router cannot be accessed by typing "router" by default. But I can edit the host file so that if "router" is entered on the web browser, it goes to the router's page and I don't have a problem with redirecting. May be you can try editing the host file by adding an entry to see if your entry overwrites the default redirection.
!