Sign in with
Sign up | Sign in
Your question

AMD Graphics Driver Weird Frame Drop and Update Issue

Last response: in Graphics & Displays
Share
February 17, 2012 9:44:18 PM

First of all, brace yourselves, this is going to be a long post. I posted a somewhat similar question on SuperUser from StackExchange and I received no actual good answer. I am hoping you guys can help...

I have last year bought an HP dv7 Pavillion notebook but due to personal problems I was not able to get my hands on it up until last year's December. It's an i5, has a ATI Radeon HD Mobility 5650 graphics card and 6GB RAM. It's running Windows 7 x64.

Now, the problem started when I was downloading the essential updates and stuff for my "new" PC. At first I tried playing Skyrim and Battlefield 3. Both of them asked me to update my driver, since my driver was quite deprecated. I then proceeded to the AMD driver update page. From there I downloaded the Mobility Catalyst Software Suite. When trying to run it, it outputted the following message:

AMD Catalyst Mobility cannot be downloaded due to incompatible hardware/software on your computer.

I then tried downloading the Catalyst Control Center. I am not sure what I actually did. I installed and uninstalled a bunch of versions. After a couple of tries it worked. I was able to play games.

Now, the main problem starts here. Yesterday I downloaded Mass Effect 3 Demo. When I tried playing it, something weird happened. The game looked like something taken from a PS1 game. The textures were blurred and everything was either too bright or too dark. But the main problem, FPS was extremely low.

I couldn't figure out why that was happening. I Google'd everywhere. Found nothing. I asked myself whether it was just a driver update issue. I downloaded the latest version (v12.1) of Catalyst and restarted my PC. I then tried restarting Mass Effect 3. At first the FPS had increased significantly (it was marking up to 60 fps). The graphics were still weird. But after a couple of minutes (hadn't even gotten to the tutorial yet), the FPS started dropping a lot.

I then tried playing Battlefield 3. I figured it was just the game's fault. I was wrong. The same thing happened to Battlefield 3. It was unplayable. I think the issue has something to do with my AMD card.

I started Googling everywhere. Again, found nothing. I then tried updating the Catalyst Software Suite. But as before, it outputted the same annoying incompatibility error. So I started googling ways to actually figure that error. I found a bunch of answers. Most of them told people to get the outdated HP graphical update driver, since AMD apparently prevented HP and Toshiba PCs to get the latest updates.

I didn't touch the PC Monday or Tuesday. Sunday it was working just fine. Wednesday I noticed games were running really slow. I thought it was just that day. Now I realized, after a bunch of restarts and driver updates, this is not a one time only issue.

I am getting desperate now. I don't know what the problem is. Saturday I was playing Battlefield 3 as usual (everything going smoothly). And now it won't even run Mass Effect 3 right. That problem came out of nowhere! Should I just get the HP update or what?

I beg your help. I don't know what to do!

Thank you in advance,

Renato
February 18, 2012 9:36:51 AM

Alright, a quick heads up. I ran 3d Mark Vantage and my score for the Graphics card was around 300, while most people would get 3000. I am pretty certain its something to do with my video card. Also, apparently when I play a video on Youtube, the frame increases drastically. I don't know why... Maybe because the video enables the Video Card whilst the game itself won't?
m
0
l
!