Keyboard shortcuts for foreign language characters

Archived from groups: microsoft.public.windowsxp.customize (More info?)

I do a lot of writing in French (and a few other foreign languages) and
sometimes mix French words into otherwise English text (and vice versa). I
all previous versions of Windows prior to XP I have been able to insert the
accented letters needed to write in French (and other special characters) by
using an ALT+(number on numberpad) code. For example, to enter an "a" with
an accent grave I would simply hold down ALT and enter the number 133 on the
key pad. This was a very convenient way to insert the letters needed to
write French words and I used them so much that I could almost (but not
quite) do it while touch typing. When I started using XP (about a year ago)
I found that most of the ALT codes which I used did other strange things
instead. I have had to resort to using the character map to enter accented
letters which is very slow.

I read an article in Maximum PC sometime ago which I believe addressed this
problem, but I did not act at the time and have since lost the article. I
believe it said that there was a way to disable some (or all) of the keyboard
shortcuts that XP installs automatically, thus allowing the old ALT codes for
foreign characters to work again.

A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
most, however, do not.

Can anyone help me? I would DEEPLY appreciate being able to fix this problem.

Thanks a lot (merci beaucoup)
--
Charles
9 answers Last reply
More about keyboard shortcuts foreign language characters
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    It is not exactly what you are looking for but check out
    http://allchars.zwolnet.com/index.html
    and look for AllChar.
    A minor part of the webpage text is in dutch but the tool is great.
    It emulates *nix Compose key in windows.
    It's freeware.
    I have it in my startup routine and it sits right under the (left) Ctrl key
    waiting for you.
    The notification area has a little icon to access all it's functions.
    To type any 'compposite' character just hit Ctrl first and then two
    consecutive normal keys making up the 'composite.
    eg.
    To type
    Copyright you would hit Ctrl - o - c ©
    Registered Ctrl - o - r ®
    something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    Check it out, you'll love it, it is dead-easy to get used to.
    Thank the guy (not me) for producing it.

    hth

    george


    "Charles" <Charles@discussions.microsoft.com> wrote in message
    news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    >I do a lot of writing in French (and a few other foreign languages) and
    > sometimes mix French words into otherwise English text (and vice versa).
    > I
    > all previous versions of Windows prior to XP I have been able to insert
    > the
    > accented letters needed to write in French (and other special characters)
    > by
    > using an ALT+(number on numberpad) code. For example, to enter an "a"
    > with
    > an accent grave I would simply hold down ALT and enter the number 133 on
    > the
    > key pad. This was a very convenient way to insert the letters needed to
    > write French words and I used them so much that I could almost (but not
    > quite) do it while touch typing. When I started using XP (about a year
    > ago)
    > I found that most of the ALT codes which I used did other strange things
    > instead. I have had to resort to using the character map to enter
    > accented
    > letters which is very slow.
    >
    > I read an article in Maximum PC sometime ago which I believe addressed
    > this
    > problem, but I did not act at the time and have since lost the article. I
    > believe it said that there was a way to disable some (or all) of the
    > keyboard
    > shortcuts that XP installs automatically, thus allowing the old ALT codes
    > for
    > foreign characters to work again.
    >
    > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    > most, however, do not.
    >
    > Can anyone help me? I would DEEPLY appreciate being able to fix this
    > problem.
    >
    > Thanks a lot (merci beaucoup)
    > --
    > Charles
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thank you very much George. I will get the software you recommd (fortunately
    I speak a little Dutch ... een klein beetje.) I am still trying to get the
    answer to my orginial question, though. Some of the Microsoft built0in short
    cuts are useful, of course, and have been present since the first versions of
    Windows. But some of the new ones in XP are, to me at least, useless and
    often just a confusing hindrance.

    I hope there is a way to deactivate at least some of the built-in short
    cuts. I suspect there is but that it is just "cleverly" hidden away in some
    arcane ini file or some such thing.

    Thanks again,

    Charles

    "george" wrote:

    > It is not exactly what you are looking for but check out
    > http://allchars.zwolnet.com/index.html
    > and look for AllChar.
    > A minor part of the webpage text is in dutch but the tool is great.
    > It emulates *nix Compose key in windows.
    > It's freeware.
    > I have it in my startup routine and it sits right under the (left) Ctrl key
    > waiting for you.
    > The notification area has a little icon to access all it's functions.
    > To type any 'compposite' character just hit Ctrl first and then two
    > consecutive normal keys making up the 'composite.
    > eg.
    > To type
    > Copyright you would hit Ctrl - o - c ©
    > Registered Ctrl - o - r ®
    > something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    > Check it out, you'll love it, it is dead-easy to get used to.
    > Thank the guy (not me) for producing it.
    >
    > hth
    >
    > george
    >
    >
    > "Charles" <Charles@discussions.microsoft.com> wrote in message
    > news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    > >I do a lot of writing in French (and a few other foreign languages) and
    > > sometimes mix French words into otherwise English text (and vice versa).
    > > I
    > > all previous versions of Windows prior to XP I have been able to insert
    > > the
    > > accented letters needed to write in French (and other special characters)
    > > by
    > > using an ALT+(number on numberpad) code. For example, to enter an "a"
    > > with
    > > an accent grave I would simply hold down ALT and enter the number 133 on
    > > the
    > > key pad. This was a very convenient way to insert the letters needed to
    > > write French words and I used them so much that I could almost (but not
    > > quite) do it while touch typing. When I started using XP (about a year
    > > ago)
    > > I found that most of the ALT codes which I used did other strange things
    > > instead. I have had to resort to using the character map to enter
    > > accented
    > > letters which is very slow.
    > >
    > > I read an article in Maximum PC sometime ago which I believe addressed
    > > this
    > > problem, but I did not act at the time and have since lost the article. I
    > > believe it said that there was a way to disable some (or all) of the
    > > keyboard
    > > shortcuts that XP installs automatically, thus allowing the old ALT codes
    > > for
    > > foreign characters to work again.
    > >
    > > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    > > most, however, do not.
    > >
    > > Can anyone help me? I would DEEPLY appreciate being able to fix this
    > > problem.
    > >
    > > Thanks a lot (merci beaucoup)
    > > --
    > > Charles
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    But there are two Alt + Num
    Alt + 133 gives à (a accented) or so does Alt + 0224 (à)
    Alt + 0133 gives … (epilisis)

    Character map tells you what to enter in the long format.

    The difference isn't the number of digits but the leading 0. Numbers under 99 are the same in both schemes (065 and 0065 are both A).
    --
    ----------------------------------------------------------
    http://www.uscricket.com
    "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    > Thank you very much George. I will get the software you recommd (fortunately
    > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    > answer to my orginial question, though. Some of the Microsoft built0in short
    > cuts are useful, of course, and have been present since the first versions of
    > Windows. But some of the new ones in XP are, to me at least, useless and
    > often just a confusing hindrance.
    >
    > I hope there is a way to deactivate at least some of the built-in short
    > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    > arcane ini file or some such thing.
    >
    > Thanks again,
    >
    > Charles
    >
    > "george" wrote:
    >
    >> It is not exactly what you are looking for but check out
    >> http://allchars.zwolnet.com/index.html
    >> and look for AllChar.
    >> A minor part of the webpage text is in dutch but the tool is great.
    >> It emulates *nix Compose key in windows.
    >> It's freeware.
    >> I have it in my startup routine and it sits right under the (left) Ctrl key
    >> waiting for you.
    >> The notification area has a little icon to access all it's functions.
    >> To type any 'compposite' character just hit Ctrl first and then two
    >> consecutive normal keys making up the 'composite.
    >> eg.
    >> To type
    >> Copyright you would hit Ctrl - o - c ©
    >> Registered Ctrl - o - r ®
    >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    >> Check it out, you'll love it, it is dead-easy to get used to.
    >> Thank the guy (not me) for producing it.
    >>
    >> hth
    >>
    >> george
    >>
    >>
    >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    >> >I do a lot of writing in French (and a few other foreign languages) and
    >> > sometimes mix French words into otherwise English text (and vice versa).
    >> > I
    >> > all previous versions of Windows prior to XP I have been able to insert
    >> > the
    >> > accented letters needed to write in French (and other special characters)
    >> > by
    >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    >> > with
    >> > an accent grave I would simply hold down ALT and enter the number 133 on
    >> > the
    >> > key pad. This was a very convenient way to insert the letters needed to
    >> > write French words and I used them so much that I could almost (but not
    >> > quite) do it while touch typing. When I started using XP (about a year
    >> > ago)
    >> > I found that most of the ALT codes which I used did other strange things
    >> > instead. I have had to resort to using the character map to enter
    >> > accented
    >> > letters which is very slow.
    >> >
    >> > I read an article in Maximum PC sometime ago which I believe addressed
    >> > this
    >> > problem, but I did not act at the time and have since lost the article. I
    >> > believe it said that there was a way to disable some (or all) of the
    >> > keyboard
    >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    >> > for
    >> > foreign characters to work again.
    >> >
    >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    >> > most, however, do not.
    >> >
    >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    >> > problem.
    >> >
    >> > Thanks a lot (merci beaucoup)
    >> > --
    >> > Charles
    >>
    >>
    >>
  4. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192

    --
    ----------------------------------------------------------
    http://www.uscricket.com
    "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    > Thank you very much George. I will get the software you recommd (fortunately
    > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    > answer to my orginial question, though. Some of the Microsoft built0in short
    > cuts are useful, of course, and have been present since the first versions of
    > Windows. But some of the new ones in XP are, to me at least, useless and
    > often just a confusing hindrance.
    >
    > I hope there is a way to deactivate at least some of the built-in short
    > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    > arcane ini file or some such thing.
    >
    > Thanks again,
    >
    > Charles
    >
    > "george" wrote:
    >
    >> It is not exactly what you are looking for but check out
    >> http://allchars.zwolnet.com/index.html
    >> and look for AllChar.
    >> A minor part of the webpage text is in dutch but the tool is great.
    >> It emulates *nix Compose key in windows.
    >> It's freeware.
    >> I have it in my startup routine and it sits right under the (left) Ctrl key
    >> waiting for you.
    >> The notification area has a little icon to access all it's functions.
    >> To type any 'compposite' character just hit Ctrl first and then two
    >> consecutive normal keys making up the 'composite.
    >> eg.
    >> To type
    >> Copyright you would hit Ctrl - o - c ©
    >> Registered Ctrl - o - r ®
    >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    >> Check it out, you'll love it, it is dead-easy to get used to.
    >> Thank the guy (not me) for producing it.
    >>
    >> hth
    >>
    >> george
    >>
    >>
    >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    >> >I do a lot of writing in French (and a few other foreign languages) and
    >> > sometimes mix French words into otherwise English text (and vice versa).
    >> > I
    >> > all previous versions of Windows prior to XP I have been able to insert
    >> > the
    >> > accented letters needed to write in French (and other special characters)
    >> > by
    >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    >> > with
    >> > an accent grave I would simply hold down ALT and enter the number 133 on
    >> > the
    >> > key pad. This was a very convenient way to insert the letters needed to
    >> > write French words and I used them so much that I could almost (but not
    >> > quite) do it while touch typing. When I started using XP (about a year
    >> > ago)
    >> > I found that most of the ALT codes which I used did other strange things
    >> > instead. I have had to resort to using the character map to enter
    >> > accented
    >> > letters which is very slow.
    >> >
    >> > I read an article in Maximum PC sometime ago which I believe addressed
    >> > this
    >> > problem, but I did not act at the time and have since lost the article. I
    >> > believe it said that there was a way to disable some (or all) of the
    >> > keyboard
    >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    >> > for
    >> > foreign characters to work again.
    >> >
    >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    >> > most, however, do not.
    >> >
    >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    >> > problem.
    >> >
    >> > Thanks a lot (merci beaucoup)
    >> > --
    >> > Charles
    >>
    >>
    >>
  5. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    The problem I am having is that, instead of simply producing a character in
    whatever body of text I happen to be writing (be it in a word processor, an
    e-mail program, or whtever) something completely unrelated happens -- like
    jumping to the last e-mail I read, or skipping to another mailbox, or jumping
    to the bottom of the text. I have not catalogued all the precise problems
    but they happen for most of the ALT codes that worked fine in all previous
    versions of Windows but do not work in Windows XP. The codes I used to use
    were both 3 and 4 digit codes, ranging from ALT+0193 which produced a capital
    A-accent-grave to ALT+159 which produced the old German form of an "s" which
    looks like an itallic "f"

    I gather that some of these codes are unicode, but that is not the problem.
    The problem is that the very same codes that used to work in ALL versions of
    Windows before XP (and I think I have used or tried them all over the years)
    do other things in XP. My conclusion is that Windows XP expropriates some of
    these codes to do all the wonderful things that it does with keyboard
    short-cuts. All I really want to do is to disable some of the Windows XP
    defaults and be able to use the character codes that have been standard for
    years.

    Thanks for the insights, but I'm still searching for an answer.

    Charles



    "David Candy" wrote:

    > But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192
    >
    > --
    > ----------------------------------------------------------
    > http://www.uscricket.com
    > "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    > > Thank you very much George. I will get the software you recommd (fortunately
    > > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    > > answer to my orginial question, though. Some of the Microsoft built0in short
    > > cuts are useful, of course, and have been present since the first versions of
    > > Windows. But some of the new ones in XP are, to me at least, useless and
    > > often just a confusing hindrance.
    > >
    > > I hope there is a way to deactivate at least some of the built-in short
    > > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    > > arcane ini file or some such thing.
    > >
    > > Thanks again,
    > >
    > > Charles
    > >
    > > "george" wrote:
    > >
    > >> It is not exactly what you are looking for but check out
    > >> http://allchars.zwolnet.com/index.html
    > >> and look for AllChar.
    > >> A minor part of the webpage text is in dutch but the tool is great.
    > >> It emulates *nix Compose key in windows.
    > >> It's freeware.
    > >> I have it in my startup routine and it sits right under the (left) Ctrl key
    > >> waiting for you.
    > >> The notification area has a little icon to access all it's functions.
    > >> To type any 'compposite' character just hit Ctrl first and then two
    > >> consecutive normal keys making up the 'composite.
    > >> eg.
    > >> To type
    > >> Copyright you would hit Ctrl - o - c ©
    > >> Registered Ctrl - o - r ®
    > >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    > >> Check it out, you'll love it, it is dead-easy to get used to.
    > >> Thank the guy (not me) for producing it.
    > >>
    > >> hth
    > >>
    > >> george
    > >>
    > >>
    > >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    > >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    > >> >I do a lot of writing in French (and a few other foreign languages) and
    > >> > sometimes mix French words into otherwise English text (and vice versa).
    > >> > I
    > >> > all previous versions of Windows prior to XP I have been able to insert
    > >> > the
    > >> > accented letters needed to write in French (and other special characters)
    > >> > by
    > >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    > >> > with
    > >> > an accent grave I would simply hold down ALT and enter the number 133 on
    > >> > the
    > >> > key pad. This was a very convenient way to insert the letters needed to
    > >> > write French words and I used them so much that I could almost (but not
    > >> > quite) do it while touch typing. When I started using XP (about a year
    > >> > ago)
    > >> > I found that most of the ALT codes which I used did other strange things
    > >> > instead. I have had to resort to using the character map to enter
    > >> > accented
    > >> > letters which is very slow.
    > >> >
    > >> > I read an article in Maximum PC sometime ago which I believe addressed
    > >> > this
    > >> > problem, but I did not act at the time and have since lost the article. I
    > >> > believe it said that there was a way to disable some (or all) of the
    > >> > keyboard
    > >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    > >> > for
    > >> > foreign characters to work again.
    > >> >
    > >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    > >> > most, however, do not.
    > >> >
    > >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    > >> > problem.
    > >> >
    > >> > Thanks a lot (merci beaucoup)
    > >> > --
    > >> > Charles
    > >>
    > >>
    > >>
    >
  6. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    In that case press the numlock key first. You are sending Alt + Home etc.


    --
    ----------------------------------------------------------
    http://www.uscricket.com
    "Charles" <Charles@discussions.microsoft.com> wrote in message news:E04599DF-1A3C-49A8-81BB-4F810370A7F5@microsoft.com...
    > The problem I am having is that, instead of simply producing a character in
    > whatever body of text I happen to be writing (be it in a word processor, an
    > e-mail program, or whtever) something completely unrelated happens -- like
    > jumping to the last e-mail I read, or skipping to another mailbox, or jumping
    > to the bottom of the text. I have not catalogued all the precise problems
    > but they happen for most of the ALT codes that worked fine in all previous
    > versions of Windows but do not work in Windows XP. The codes I used to use
    > were both 3 and 4 digit codes, ranging from ALT+0193 which produced a capital
    > A-accent-grave to ALT+159 which produced the old German form of an "s" which
    > looks like an itallic "f"
    >
    > I gather that some of these codes are unicode, but that is not the problem.
    > The problem is that the very same codes that used to work in ALL versions of
    > Windows before XP (and I think I have used or tried them all over the years)
    > do other things in XP. My conclusion is that Windows XP expropriates some of
    > these codes to do all the wonderful things that it does with keyboard
    > short-cuts. All I really want to do is to disable some of the Windows XP
    > defaults and be able to use the character codes that have been standard for
    > years.
    >
    > Thanks for the insights, but I'm still searching for an answer.
    >
    > Charles
    >
    >
    >
    > "David Candy" wrote:
    >
    >> But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192
    >>
    >> --
    >> ----------------------------------------------------------
    >> http://www.uscricket.com
    >> "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    >> > Thank you very much George. I will get the software you recommd (fortunately
    >> > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    >> > answer to my orginial question, though. Some of the Microsoft built0in short
    >> > cuts are useful, of course, and have been present since the first versions of
    >> > Windows. But some of the new ones in XP are, to me at least, useless and
    >> > often just a confusing hindrance.
    >> >
    >> > I hope there is a way to deactivate at least some of the built-in short
    >> > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    >> > arcane ini file or some such thing.
    >> >
    >> > Thanks again,
    >> >
    >> > Charles
    >> >
    >> > "george" wrote:
    >> >
    >> >> It is not exactly what you are looking for but check out
    >> >> http://allchars.zwolnet.com/index.html
    >> >> and look for AllChar.
    >> >> A minor part of the webpage text is in dutch but the tool is great.
    >> >> It emulates *nix Compose key in windows.
    >> >> It's freeware.
    >> >> I have it in my startup routine and it sits right under the (left) Ctrl key
    >> >> waiting for you.
    >> >> The notification area has a little icon to access all it's functions.
    >> >> To type any 'compposite' character just hit Ctrl first and then two
    >> >> consecutive normal keys making up the 'composite.
    >> >> eg.
    >> >> To type
    >> >> Copyright you would hit Ctrl - o - c ©
    >> >> Registered Ctrl - o - r ®
    >> >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    >> >> Check it out, you'll love it, it is dead-easy to get used to.
    >> >> Thank the guy (not me) for producing it.
    >> >>
    >> >> hth
    >> >>
    >> >> george
    >> >>
    >> >>
    >> >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    >> >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    >> >> >I do a lot of writing in French (and a few other foreign languages) and
    >> >> > sometimes mix French words into otherwise English text (and vice versa).
    >> >> > I
    >> >> > all previous versions of Windows prior to XP I have been able to insert
    >> >> > the
    >> >> > accented letters needed to write in French (and other special characters)
    >> >> > by
    >> >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    >> >> > with
    >> >> > an accent grave I would simply hold down ALT and enter the number 133 on
    >> >> > the
    >> >> > key pad. This was a very convenient way to insert the letters needed to
    >> >> > write French words and I used them so much that I could almost (but not
    >> >> > quite) do it while touch typing. When I started using XP (about a year
    >> >> > ago)
    >> >> > I found that most of the ALT codes which I used did other strange things
    >> >> > instead. I have had to resort to using the character map to enter
    >> >> > accented
    >> >> > letters which is very slow.
    >> >> >
    >> >> > I read an article in Maximum PC sometime ago which I believe addressed
    >> >> > this
    >> >> > problem, but I did not act at the time and have since lost the article. I
    >> >> > believe it said that there was a way to disable some (or all) of the
    >> >> > keyboard
    >> >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    >> >> > for
    >> >> > foreign characters to work again.
    >> >> >
    >> >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    >> >> > most, however, do not.
    >> >> >
    >> >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    >> >> > problem.
    >> >> >
    >> >> > Thanks a lot (merci beaucoup)
    >> >> > --
    >> >> > Charles
    >> >>
    >> >>
    >> >>
    >>
  7. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    If you set the keyboard to US International then

    `A will give you à (except for accent grave but the others work). Acctually there doesn't seem to be accent grave A at all in the international keyboard.


    Contact Us

    © 2004 Microsoft Corporation. All rights reserved. Terms of use Privacy Accessibility


    --
    How To Use the United States-International Keyboard Layout in Windows XP
    Applies To
    This article was previously published under Q306560

    IN THIS TASK
    SUMMARY
    How to Use the United States-International Keyboard
    Adding the United States-International Keyboard Layout
    Creating Extended Characters
    Creating International Characters
    How to Use StickyKeys

    SUMMARY
    This step-by-step guide describes how to use the United States-International keyboard layout in Windows XP.

    With the United States-International layout, you can type international and special characters by using combinations of keys.

    back to the top
    How to Use the United States-International Keyboard

    Adding the United States-International Keyboard Layout
    To add the United States-International keyboard layout, follow these steps:
    1. Click Start, and then click Control Panel.
    2. Under Pick a category, click Date, Time, Language, and Regional Options.
    3. Under or pick a Control Panel icon, click Regional and Language Options.

    The Regional and Language Options dialog box appears.
    4. On the Languages tab, click Details.

    The Text Services and Input Languages dialog box appears.
    5. Under Installed services, click Add.

    The Add Input language dialog box appears.
    6. In the Input language list, click the language that you want. For example, English (United States).

    NOTE: When you use the United States-International keyboard layout, you should also use an English language setting.
    7. In the Keyboard layout/IME list, click United States-International, and then click OK.
    8. In the Select one of the installed input languages to use when you start your computer list, click Language name - United States-International (where Language name is the language that you selected in step 6), and then click OK.
    9. In the Regional and Language Options dialog box, click OK.

    Notice that the Language bar appears on the taskbar. When you position the mouse pointer over it, a ToolTip appears that describes the active keyboard layout. For example, United States-International.
    10. Click the Language bar, and then click United States-International on the shortcut menu that appears.

    The United States-International keyboard layout is selected.

    back to the top
    Creating Extended Characters
    The United States-International keyboard layout assigns new functions to the right ALT key (the ALT key on the right side of the keyboard). Use the right ALT key in combination with other keys to create extended characters.

    The following table illustrates characters that you can create by using the combination of the right ALT key plus another key, as well as those that you can create by using the right ALT key plus the SHIFT key plus another key:


    Key on United States keyboard Character Made with Right ALT+Key SHIFT+Right ALT+Key
    1i¹
    2²N/A
    3³N/A
    4¤£
    5€N/A
    61/4N/A
    71/2N/A
    83/4N/A
    9'N/A
    0'N/A
    -Â¥N/A
    =×÷
    QäÄ
    WåÅ
    EéÉ
    R(r)N/A
    TþÞ
    YüÜ
    UúÚ
    IíÍ
    OóÓ
    PöÖ
    [<<N/A
    ]>>N/A
    \Not Sign¦
    AáÁ
    Sߧ
    DðÐ
    LøØ
    ;Pilcrow Sign°
    '´¨
    ZæÆ
    C(c)¢
    NñÑ
    MµN/A
    ,çÇ
    /¿N/A
    TABLE This table is a list of extended characters that cannot be displayed.
    back to the top
    Creating International Characters
    When you press the APOSTROPHE (') key, QUOTATION MARK (") key, ACCENT GRAVE (`) key, TILDE (~) key, ACCENT CIRCUMFLEX key, or CARET (^) key, nothing appears on the screen until you press a second key. If you press one of the letters designated as eligible to receive an accent mark, the accented version of the letter appears. If you press the key of a character that is not eligible to receive an accent mark, two separate characters appear.

    In other words, when you use the US-International keyboard layout, Windows automatically accents letters that customarily receive an accent but does not automatically accent letters that do not customarily receive an accent.

    The following table illustrates the accented characters that you can create:


    Press this keyThen press this keyResultant character
    ' (APOSTROPHE)CÇ
    '(APOSTROPHE)e, y, u, i, o, aé, ý, ú, í, ó, á
    "(QUOTATION MARK)e, u, i, o, aë, ü, ï, ö, ä
    `(ACCENT GRAVE)e, u, i, oè, ù, ì, ò
    ~(TILDE)o, nõ, ñ
    ^(CARET)e, u, i, o, aê, û, î, ô, â
    This table contains accented characters that cannot be displayed.
    back to the top
    How to Use StickyKeys
    Key combinations require you to press and hold down two or more keys at once. Single-handed typists or users who use a mouth-stick have difficulty doing this. StickyKeys enables you to press a modifier key (CTRL, ALT, or SHIFT), or the Windows logo key, and have it remain active until another key is pressed.

    To turn on StickyKeys, follow these steps:
    1. Click Start, and then click Control Panel.
    2. Under Pick a category, click Accessibility Options.
    3. Under or pick a Control Panel icon, click Accessibility Options.

    The Accessibility Options dialog box appears.
    4. On the Keyboard tab, click to select the Use StickyKeys check box, and then click OK.
    back to the top


    The information in this article applies to:
    Microsoft Windows XP Professional
    Microsoft Windows XP Home Edition
    Last Reviewed:7/15/2004 (1.2)
    Keywords:kbhowto kbHOWTOmaster KB306560 kbAudITPro


    ----------------------------------------------------------
    http://www.uscricket.com
    "Charles" <Charles@discussions.microsoft.com> wrote in message news:E04599DF-1A3C-49A8-81BB-4F810370A7F5@microsoft.com...
    > The problem I am having is that, instead of simply producing a character in
    > whatever body of text I happen to be writing (be it in a word processor, an
    > e-mail program, or whtever) something completely unrelated happens -- like
    > jumping to the last e-mail I read, or skipping to another mailbox, or jumping
    > to the bottom of the text. I have not catalogued all the precise problems
    > but they happen for most of the ALT codes that worked fine in all previous
    > versions of Windows but do not work in Windows XP. The codes I used to use
    > were both 3 and 4 digit codes, ranging from ALT+0193 which produced a capital
    > A-accent-grave to ALT+159 which produced the old German form of an "s" which
    > looks like an itallic "f"
    >
    > I gather that some of these codes are unicode, but that is not the problem.
    > The problem is that the very same codes that used to work in ALL versions of
    > Windows before XP (and I think I have used or tried them all over the years)
    > do other things in XP. My conclusion is that Windows XP expropriates some of
    > these codes to do all the wonderful things that it does with keyboard
    > short-cuts. All I really want to do is to disable some of the Windows XP
    > defaults and be able to use the character codes that have been standard for
    > years.
    >
    > Thanks for the insights, but I'm still searching for an answer.
    >
    > Charles
    >
    >
    >
    > "David Candy" wrote:
    >
    >> But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192
    >>
    >> --
    >> ----------------------------------------------------------
    >> http://www.uscricket.com
    >> "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    >> > Thank you very much George. I will get the software you recommd (fortunately
    >> > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    >> > answer to my orginial question, though. Some of the Microsoft built0in short
    >> > cuts are useful, of course, and have been present since the first versions of
    >> > Windows. But some of the new ones in XP are, to me at least, useless and
    >> > often just a confusing hindrance.
    >> >
    >> > I hope there is a way to deactivate at least some of the built-in short
    >> > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    >> > arcane ini file or some such thing.
    >> >
    >> > Thanks again,
    >> >
    >> > Charles
    >> >
    >> > "george" wrote:
    >> >
    >> >> It is not exactly what you are looking for but check out
    >> >> http://allchars.zwolnet.com/index.html
    >> >> and look for AllChar.
    >> >> A minor part of the webpage text is in dutch but the tool is great.
    >> >> It emulates *nix Compose key in windows.
    >> >> It's freeware.
    >> >> I have it in my startup routine and it sits right under the (left) Ctrl key
    >> >> waiting for you.
    >> >> The notification area has a little icon to access all it's functions.
    >> >> To type any 'compposite' character just hit Ctrl first and then two
    >> >> consecutive normal keys making up the 'composite.
    >> >> eg.
    >> >> To type
    >> >> Copyright you would hit Ctrl - o - c ©
    >> >> Registered Ctrl - o - r ®
    >> >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    >> >> Check it out, you'll love it, it is dead-easy to get used to.
    >> >> Thank the guy (not me) for producing it.
    >> >>
    >> >> hth
    >> >>
    >> >> george
    >> >>
    >> >>
    >> >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    >> >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    >> >> >I do a lot of writing in French (and a few other foreign languages) and
    >> >> > sometimes mix French words into otherwise English text (and vice versa).
    >> >> > I
    >> >> > all previous versions of Windows prior to XP I have been able to insert
    >> >> > the
    >> >> > accented letters needed to write in French (and other special characters)
    >> >> > by
    >> >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    >> >> > with
    >> >> > an accent grave I would simply hold down ALT and enter the number 133 on
    >> >> > the
    >> >> > key pad. This was a very convenient way to insert the letters needed to
    >> >> > write French words and I used them so much that I could almost (but not
    >> >> > quite) do it while touch typing. When I started using XP (about a year
    >> >> > ago)
    >> >> > I found that most of the ALT codes which I used did other strange things
    >> >> > instead. I have had to resort to using the character map to enter
    >> >> > accented
    >> >> > letters which is very slow.
    >> >> >
    >> >> > I read an article in Maximum PC sometime ago which I believe addressed
    >> >> > this
    >> >> > problem, but I did not act at the time and have since lost the article. I
    >> >> > believe it said that there was a way to disable some (or all) of the
    >> >> > keyboard
    >> >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    >> >> > for
    >> >> > foreign characters to work again.
    >> >> >
    >> >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    >> >> > most, however, do not.
    >> >> >
    >> >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    >> >> > problem.
    >> >> >
    >> >> > Thanks a lot (merci beaucoup)
    >> >> > --
    >> >> > Charles
    >> >>
    >> >>
    >> >>
    >>
  8. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    EUREKA!

    David, you did it!

    Actually, of all the things you suggested, the brief comment that it was
    necessary to press the Num Lock key before typing in the ALT codes is what
    did the trick. I seem to be able to get all of the characters I got in
    earlier versions of Windows with the same ALT codes (which do not match
    exactly the codes as seen in the Character Map tool.)

    I am only guessing, but I suspect that it was not necessary to turn on Num
    Lock in the earlier versions of Windows. I never remember having to do so in
    the past and never remember seeing the Num Lock light light up before.
    Although I am using a new computer (custom built by myself) I am using my old
    keyboard. I ran into virtually no problems at all building the new computer,
    installing Windows XP, and all my applications. I only discovered the ALT
    problem sometime later when I first had occasion to type something in French.

    I suspect that having to turn on the Num Lock key was not required to get
    the foreign characters in the earlier versions of Windows, but I could be
    wrong. I never remember having to do so and never remember seeing the Num
    Lock key on before.

    I now get all the same characters I used to get before (including both upper
    and lower case a accent grave: À à ... a good thing because à is one of the
    most commonly used letters in French, as a stand alone letter à and a are
    both words but mean entirely different things and it is important to get them
    right.

    For your information (or that of any other readers of this message who care)
    here is the complete list: To use, FIRST MAKE SURE NUM LOCK IS ON, then, to
    get the character on the left, hold down ALT while typing the number on the
    right (3 or 4 digits ... if 4 digits the first is always 0)

    Ã? 0193
    á 160
    À 0192
    à 133
    Â 0194
    â 131
    Ä 142
    ä 132
    Ã… 143
    å 134
    Æ 146
    æ 145
    Ç 128
    ç 135
    É 144
    é 130 <- used in lots of English words like "sauté"
    È 0200
    è 138
    Ê 0202
    ê 136
    Ë 0203
    ë 137
    Ã? 0205
    í 161
    Ì 0204
    ì 141
    ÃŽ 0206
    î 140
    Ã? 0207
    ï 139
    Ñ 165
    ñ 164
    Ó 0211
    ó 162
    Ã’ 0210
    ò 149
    Ô 0212
    ô 147
    Ö 153
    ö 148
    Ø 0216
    ø 0248
    Å’ 0140
    Å“ 0156
    Å  0138
    Å¡ 0154
    Ú 0218
    ú 163
    Ù 0217
    ù 151
    Û 0219
    û 150
    Ü 154
    ü 129
    Ÿ 0159
    ÿ 152
    ¿ 168
    ¡ 173
    « 174
    » 175
    € 0128
    ¢ 155
    £ 156
    ¥ 157
    Æ’ 159


    Thank you David ... Thank you ... and Happy Thanksgiving!


    "David Candy" wrote:

    > If you set the keyboard to US International then
    >
    > `A will give you à (except for accent grave but the others work). Acctually there doesn't seem to be accent grave A at all in the international keyboard.
    >
    >
    > Contact Us
    >
    > © 2004 Microsoft Corporation. All rights reserved. Terms of use Privacy Accessibility
    >
    >
    > --
    > How To Use the United States-International Keyboard Layout in Windows XP
    > Applies To
    > This article was previously published under Q306560
    >
    > IN THIS TASK
    > SUMMARY
    > How to Use the United States-International Keyboard
    > Adding the United States-International Keyboard Layout
    > Creating Extended Characters
    > Creating International Characters
    > How to Use StickyKeys
    >
    > SUMMARY
    > This step-by-step guide describes how to use the United States-International keyboard layout in Windows XP.
    >
    > With the United States-International layout, you can type international and special characters by using combinations of keys.
    >
    > back to the top
    > How to Use the United States-International Keyboard
    >
    > Adding the United States-International Keyboard Layout
    > To add the United States-International keyboard layout, follow these steps:
    > 1. Click Start, and then click Control Panel.
    > 2. Under Pick a category, click Date, Time, Language, and Regional Options.
    > 3. Under or pick a Control Panel icon, click Regional and Language Options.
    >
    > The Regional and Language Options dialog box appears.
    > 4. On the Languages tab, click Details.
    >
    > The Text Services and Input Languages dialog box appears.
    > 5. Under Installed services, click Add.
    >
    > The Add Input language dialog box appears.
    > 6. In the Input language list, click the language that you want. For example, English (United States).
    >
    > NOTE: When you use the United States-International keyboard layout, you should also use an English language setting.
    > 7. In the Keyboard layout/IME list, click United States-International, and then click OK.
    > 8. In the Select one of the installed input languages to use when you start your computer list, click Language name - United States-International (where Language name is the language that you selected in step 6), and then click OK.
    > 9. In the Regional and Language Options dialog box, click OK.
    >
    > Notice that the Language bar appears on the taskbar. When you position the mouse pointer over it, a ToolTip appears that describes the active keyboard layout. For example, United States-International.
    > 10. Click the Language bar, and then click United States-International on the shortcut menu that appears.
    >
    > The United States-International keyboard layout is selected.
    >
    > back to the top
    > Creating Extended Characters
    > The United States-International keyboard layout assigns new functions to the right ALT key (the ALT key on the right side of the keyboard). Use the right ALT key in combination with other keys to create extended characters.
    >
    > The following table illustrates characters that you can create by using the combination of the right ALT key plus another key, as well as those that you can create by using the right ALT key plus the SHIFT key plus another key:
    >
    >
    > Key on United States keyboard Character Made with Right ALT+Key SHIFT+Right ALT+Key
    > 1i¹
    > 2²N/A
    > 3³N/A
    > 4¤£
    > 5€N/A
    > 61/4N/A
    > 71/2N/A
    > 83/4N/A
    > 9'N/A
    > 0'N/A
    > -Â¥N/A
    > =×÷
    > QäÄ
    > WåÅ
    > EéÉ
    > R(r)N/A
    > TþÞ
    > YüÜ
    > UúÚ
    > Ií�
    > OóÓ
    > PöÖ
    > [<<N/A
    > ]>>N/A
    > \Not Sign¦
    > Aá�
    > Sߧ
    > Dð�
    > LøØ
    > ;Pilcrow Sign°
    > '´¨
    > ZæÆ
    > C(c)¢
    > NñÑ
    > MµN/A
    > ,çÇ
    > /¿N/A
    > TABLE This table is a list of extended characters that cannot be displayed.
    > back to the top
    > Creating International Characters
    > When you press the APOSTROPHE (') key, QUOTATION MARK (") key, ACCENT GRAVE (`) key, TILDE (~) key, ACCENT CIRCUMFLEX key, or CARET (^) key, nothing appears on the screen until you press a second key. If you press one of the letters designated as eligible to receive an accent mark, the accented version of the letter appears. If you press the key of a character that is not eligible to receive an accent mark, two separate characters appear.
    >
    > In other words, when you use the US-International keyboard layout, Windows automatically accents letters that customarily receive an accent but does not automatically accent letters that do not customarily receive an accent.
    >
    > The following table illustrates the accented characters that you can create:
    >
    >
    > Press this keyThen press this keyResultant character
    > ' (APOSTROPHE)CÇ
    > '(APOSTROPHE)e, y, u, i, o, aé, ý, ú, í, ó, á
    > "(QUOTATION MARK)e, u, i, o, aë, ü, ï, ö, ä
    > `(ACCENT GRAVE)e, u, i, oè, ù, ì, ò
    > ~(TILDE)o, nõ, ñ
    > ^(CARET)e, u, i, o, aê, û, î, ô, â
    > This table contains accented characters that cannot be displayed.
    > back to the top
    > How to Use StickyKeys
    > Key combinations require you to press and hold down two or more keys at once. Single-handed typists or users who use a mouth-stick have difficulty doing this. StickyKeys enables you to press a modifier key (CTRL, ALT, or SHIFT), or the Windows logo key, and have it remain active until another key is pressed.
    >
    > To turn on StickyKeys, follow these steps:
    > 1. Click Start, and then click Control Panel.
    > 2. Under Pick a category, click Accessibility Options.
    > 3. Under or pick a Control Panel icon, click Accessibility Options.
    >
    > The Accessibility Options dialog box appears.
    > 4. On the Keyboard tab, click to select the Use StickyKeys check box, and then click OK.
    > back to the top
    >
    >
    >
    > The information in this article applies to:
    > Microsoft Windows XP Professional
    > Microsoft Windows XP Home Edition
    > Last Reviewed:7/15/2004 (1.2)
    > Keywords:kbhowto kbHOWTOmaster KB306560 kbAudITPro
    >
    >
    > ----------------------------------------------------------
    > http://www.uscricket.com
    > "Charles" <Charles@discussions.microsoft.com> wrote in message news:E04599DF-1A3C-49A8-81BB-4F810370A7F5@microsoft.com...
    > > The problem I am having is that, instead of simply producing a character in
    > > whatever body of text I happen to be writing (be it in a word processor, an
    > > e-mail program, or whtever) something completely unrelated happens -- like
    > > jumping to the last e-mail I read, or skipping to another mailbox, or jumping
    > > to the bottom of the text. I have not catalogued all the precise problems
    > > but they happen for most of the ALT codes that worked fine in all previous
    > > versions of Windows but do not work in Windows XP. The codes I used to use
    > > were both 3 and 4 digit codes, ranging from ALT+0193 which produced a capital
    > > A-accent-grave to ALT+159 which produced the old German form of an "s" which
    > > looks like an itallic "f"
    > >
    > > I gather that some of these codes are unicode, but that is not the problem.
    > > The problem is that the very same codes that used to work in ALL versions of
    > > Windows before XP (and I think I have used or tried them all over the years)
    > > do other things in XP. My conclusion is that Windows XP expropriates some of
    > > these codes to do all the wonderful things that it does with keyboard
    > > short-cuts. All I really want to do is to disable some of the Windows XP
    > > defaults and be able to use the character codes that have been standard for
    > > years.
    > >
    > > Thanks for the insights, but I'm still searching for an answer.
    > >
    > > Charles
    > >
    > >
    > >
    > > "David Candy" wrote:
    > >
    > >> But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192
    > >>
    > >> --
    > >> ----------------------------------------------------------
    > >> http://www.uscricket.com
    > >> "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    > >> > Thank you very much George. I will get the software you recommd (fortunately
    > >> > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    > >> > answer to my orginial question, though. Some of the Microsoft built0in short
    > >> > cuts are useful, of course, and have been present since the first versions of
    > >> > Windows. But some of the new ones in XP are, to me at least, useless and
    > >> > often just a confusing hindrance.
    > >> >
    > >> > I hope there is a way to deactivate at least some of the built-in short
    > >> > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    > >> > arcane ini file or some such thing.
    > >> >
    > >> > Thanks again,
    > >> >
    > >> > Charles
    > >> >
    > >> > "george" wrote:
    > >> >
    > >> >> It is not exactly what you are looking for but check out
    > >> >> http://allchars.zwolnet.com/index.html
    > >> >> and look for AllChar.
    > >> >> A minor part of the webpage text is in dutch but the tool is great.
    > >> >> It emulates *nix Compose key in windows.
    > >> >> It's freeware.
    > >> >> I have it in my startup routine and it sits right under the (left) Ctrl key
    > >> >> waiting for you.
    > >> >> The notification area has a little icon to access all it's functions.
    > >> >> To type any 'compposite' character just hit Ctrl first and then two
    > >> >> consecutive normal keys making up the 'composite.
    > >> >> eg.
    > >> >> To type
    > >> >> Copyright you would hit Ctrl - o - c ©
    > >> >> Registered Ctrl - o - r ®
    > >> >> something accented Ctrl - ` - a (à) or Ctrl - ' - e (é)
    > >> >> Check it out, you'll love it, it is dead-easy to get used to.
    > >> >> Thank the guy (not me) for producing it.
    > >> >>
    > >> >> hth
    > >> >>
    > >> >> george
    > >> >>
    > >> >>
    > >> >> "Charles" <Charles@discussions.microsoft.com> wrote in message
    > >> >> news:B654037A-4CC9-4049-9A6E-02A78B946BD8@microsoft.com...
    > >> >> >I do a lot of writing in French (and a few other foreign languages) and
    > >> >> > sometimes mix French words into otherwise English text (and vice versa).
    > >> >> > I
    > >> >> > all previous versions of Windows prior to XP I have been able to insert
    > >> >> > the
    > >> >> > accented letters needed to write in French (and other special characters)
    > >> >> > by
    > >> >> > using an ALT+(number on numberpad) code. For example, to enter an "a"
    > >> >> > with
    > >> >> > an accent grave I would simply hold down ALT and enter the number 133 on
    > >> >> > the
    > >> >> > key pad. This was a very convenient way to insert the letters needed to
    > >> >> > write French words and I used them so much that I could almost (but not
    > >> >> > quite) do it while touch typing. When I started using XP (about a year
    > >> >> > ago)
    > >> >> > I found that most of the ALT codes which I used did other strange things
    > >> >> > instead. I have had to resort to using the character map to enter
    > >> >> > accented
    > >> >> > letters which is very slow.
    > >> >> >
    > >> >> > I read an article in Maximum PC sometime ago which I believe addressed
    > >> >> > this
    > >> >> > problem, but I did not act at the time and have since lost the article. I
    > >> >> > believe it said that there was a way to disable some (or all) of the
    > >> >> > keyboard
    > >> >> > shortcuts that XP installs automatically, thus allowing the old ALT codes
    > >> >> > for
    > >> >> > foreign characters to work again.
    > >> >> >
    > >> >> > A few codes still work, like "é" wich is ALT + 130(on the number pad) ...
    > >> >> > most, however, do not.
    > >> >> >
    > >> >> > Can anyone help me? I would DEEPLY appreciate being able to fix this
    > >> >> > problem.
    > >> >> >
    > >> >> > Thanks a lot (merci beaucoup)
    > >> >> > --
    > >> >> > Charles
    > >> >>
    > >> >>
    > >> >>
    > >>
    >
  9. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thank you so much Charles for putting the entire list of accents in this
    posting! I write in French all the time and just bought a new computer with
    an English keyboard...what a pain to try to figure out codes when used to a
    French keyboard! Anyway, this helped me a lot!

    "Charles" wrote:

    > EUREKA!
    >
    > David, you did it!
    >
    > Actually, of all the things you suggested, the brief comment that it was
    > necessary to press the Num Lock key before typing in the ALT codes is what
    > did the trick. I seem to be able to get all of the characters I got in
    > earlier versions of Windows with the same ALT codes (which do not match
    > exactly the codes as seen in the Character Map tool.)
    >
    > I am only guessing, but I suspect that it was not necessary to turn on Num
    > Lock in the earlier versions of Windows. I never remember having to do so in
    > the past and never remember seeing the Num Lock light light up before.
    > Although I am using a new computer (custom built by myself) I am using my old
    > keyboard. I ran into virtually no problems at all building the new computer,
    > installing Windows XP, and all my applications. I only discovered the ALT
    > problem sometime later when I first had occasion to type something in French.
    >
    > I suspect that having to turn on the Num Lock key was not required to get
    > the foreign characters in the earlier versions of Windows, but I could be
    > wrong. I never remember having to do so and never remember seeing the Num
    > Lock key on before.
    >
    > I now get all the same characters I used to get before (including both upper
    > and lower case a accent grave: À à ... a good thing because à is one of the
    > most commonly used letters in French, as a stand alone letter à and a are
    > both words but mean entirely different things and it is important to get them
    > right.
    >
    > For your information (or that of any other readers of this message who care)
    > here is the complete list: To use, FIRST MAKE SURE NUM LOCK IS ON, then, to
    > get the character on the left, hold down ALT while typing the number on the
    > right (3 or 4 digits ... if 4 digits the first is always 0)
    >
    > Ã? 0193
    > á 160
    > À 0192
    > à 133
    > Â 0194
    > â 131
    > Ä 142
    > ä 132
    > Ã… 143
    > å 134
    > Æ 146
    > æ 145
    > Ç 128
    > ç 135
    > É 144
    > é 130 <- used in lots of English words like "sauté"
    > È 0200
    > è 138
    > Ê 0202
    > ê 136
    > Ë 0203
    > ë 137
    > Ã? 0205
    > í 161
    > Ì 0204
    > ì 141
    > ÃŽ 0206
    > î 140
    > Ã? 0207
    > ï 139
    > Ñ 165
    > ñ 164
    > Ó 0211
    > ó 162
    > Ã’ 0210
    > ò 149
    > Ô 0212
    > ô 147
    > Ö 153
    > ö 148
    > Ø 0216
    > ø 0248
    > Å’ 0140
    > Å“ 0156
    > Å  0138
    > Å¡ 0154
    > Ú 0218
    > ú 163
    > Ù 0217
    > ù 151
    > Û 0219
    > û 150
    > Ü 154
    > ü 129
    > Ÿ 0159
    > ÿ 152
    > ¿ 168
    > ¡ 173
    > « 174
    > » 175
    > € 0128
    > ¢ 155
    > £ 156
    > ¥ 157
    > Æ’ 159
    >
    >
    > Thank you David ... Thank you ... and Happy Thanksgiving!
    >
    >
    >
    >
    > "David Candy" wrote:
    >
    > > If you set the keyboard to US International then
    > >
    > > `A will give you à (except for accent grave but the others work). Acctually there doesn't seem to be accent grave A at all in the international keyboard.
    > >
    > >
    > > Contact Us
    > >
    > > © 2004 Microsoft Corporation. All rights reserved. Terms of use Privacy Accessibility
    > >
    > >
    > > --
    > > How To Use the United States-International Keyboard Layout in Windows XP
    > > Applies To
    > > This article was previously published under Q306560
    > >
    > > IN THIS TASK
    > > SUMMARY
    > > How to Use the United States-International Keyboard
    > > Adding the United States-International Keyboard Layout
    > > Creating Extended Characters
    > > Creating International Characters
    > > How to Use StickyKeys
    > >
    > > SUMMARY
    > > This step-by-step guide describes how to use the United States-International keyboard layout in Windows XP.
    > >
    > > With the United States-International layout, you can type international and special characters by using combinations of keys.
    > >
    > > back to the top
    > > How to Use the United States-International Keyboard
    > >
    > > Adding the United States-International Keyboard Layout
    > > To add the United States-International keyboard layout, follow these steps:
    > > 1. Click Start, and then click Control Panel.
    > > 2. Under Pick a category, click Date, Time, Language, and Regional Options.
    > > 3. Under or pick a Control Panel icon, click Regional and Language Options.
    > >
    > > The Regional and Language Options dialog box appears.
    > > 4. On the Languages tab, click Details.
    > >
    > > The Text Services and Input Languages dialog box appears.
    > > 5. Under Installed services, click Add.
    > >
    > > The Add Input language dialog box appears.
    > > 6. In the Input language list, click the language that you want. For example, English (United States).
    > >
    > > NOTE: When you use the United States-International keyboard layout, you should also use an English language setting.
    > > 7. In the Keyboard layout/IME list, click United States-International, and then click OK.
    > > 8. In the Select one of the installed input languages to use when you start your computer list, click Language name - United States-International (where Language name is the language that you selected in step 6), and then click OK.
    > > 9. In the Regional and Language Options dialog box, click OK.
    > >
    > > Notice that the Language bar appears on the taskbar. When you position the mouse pointer over it, a ToolTip appears that describes the active keyboard layout. For example, United States-International.
    > > 10. Click the Language bar, and then click United States-International on the shortcut menu that appears.
    > >
    > > The United States-International keyboard layout is selected.
    > >
    > > back to the top
    > > Creating Extended Characters
    > > The United States-International keyboard layout assigns new functions to the right ALT key (the ALT key on the right side of the keyboard). Use the right ALT key in combination with other keys to create extended characters.
    > >
    > > The following table illustrates characters that you can create by using the combination of the right ALT key plus another key, as well as those that you can create by using the right ALT key plus the SHIFT key plus another key:
    > >
    > >
    > > Key on United States keyboard Character Made with Right ALT+Key SHIFT+Right ALT+Key
    > > 1i¹
    > > 2²N/A
    > > 3³N/A
    > > 4¤£
    > > 5€N/A
    > > 61/4N/A
    > > 71/2N/A
    > > 83/4N/A
    > > 9'N/A
    > > 0'N/A
    > > -Â¥N/A
    > > =×÷
    > > QäÄ
    > > WåÅ
    > > EéÉ
    > > R(r)N/A
    > > TþÞ
    > > YüÜ
    > > UúÚ
    > > Ií�
    > > OóÓ
    > > PöÖ
    > > [<<N/A
    > > ]>>N/A
    > > \Not Sign¦
    > > Aá�
    > > Sߧ
    > > Dð�
    > > LøØ
    > > ;Pilcrow Sign°
    > > '´¨
    > > ZæÆ
    > > C(c)¢
    > > NñÑ
    > > MµN/A
    > > ,çÇ
    > > /¿N/A
    > > TABLE This table is a list of extended characters that cannot be displayed.
    > > back to the top
    > > Creating International Characters
    > > When you press the APOSTROPHE (') key, QUOTATION MARK (") key, ACCENT GRAVE (`) key, TILDE (~) key, ACCENT CIRCUMFLEX key, or CARET (^) key, nothing appears on the screen until you press a second key. If you press one of the letters designated as eligible to receive an accent mark, the accented version of the letter appears. If you press the key of a character that is not eligible to receive an accent mark, two separate characters appear.
    > >
    > > In other words, when you use the US-International keyboard layout, Windows automatically accents letters that customarily receive an accent but does not automatically accent letters that do not customarily receive an accent.
    > >
    > > The following table illustrates the accented characters that you can create:
    > >
    > >
    > > Press this keyThen press this keyResultant character
    > > ' (APOSTROPHE)CÇ
    > > '(APOSTROPHE)e, y, u, i, o, aé, ý, ú, í, ó, á
    > > "(QUOTATION MARK)e, u, i, o, aë, ü, ï, ö, ä
    > > `(ACCENT GRAVE)e, u, i, oè, ù, ì, ò
    > > ~(TILDE)o, nõ, ñ
    > > ^(CARET)e, u, i, o, aê, û, î, ô, â
    > > This table contains accented characters that cannot be displayed.
    > > back to the top
    > > How to Use StickyKeys
    > > Key combinations require you to press and hold down two or more keys at once. Single-handed typists or users who use a mouth-stick have difficulty doing this. StickyKeys enables you to press a modifier key (CTRL, ALT, or SHIFT), or the Windows logo key, and have it remain active until another key is pressed.
    > >
    > > To turn on StickyKeys, follow these steps:
    > > 1. Click Start, and then click Control Panel.
    > > 2. Under Pick a category, click Accessibility Options.
    > > 3. Under or pick a Control Panel icon, click Accessibility Options.
    > >
    > > The Accessibility Options dialog box appears.
    > > 4. On the Keyboard tab, click to select the Use StickyKeys check box, and then click OK.
    > > back to the top
    > >
    > >
    > >
    > > The information in this article applies to:
    > > Microsoft Windows XP Professional
    > > Microsoft Windows XP Home Edition
    > > Last Reviewed:7/15/2004 (1.2)
    > > Keywords:kbhowto kbHOWTOmaster KB306560 kbAudITPro
    > >
    > >
    > > ----------------------------------------------------------
    > > http://www.uscricket.com
    > > "Charles" <Charles@discussions.microsoft.com> wrote in message news:E04599DF-1A3C-49A8-81BB-4F810370A7F5@microsoft.com...
    > > > The problem I am having is that, instead of simply producing a character in
    > > > whatever body of text I happen to be writing (be it in a word processor, an
    > > > e-mail program, or whtever) something completely unrelated happens -- like
    > > > jumping to the last e-mail I read, or skipping to another mailbox, or jumping
    > > > to the bottom of the text. I have not catalogued all the precise problems
    > > > but they happen for most of the ALT codes that worked fine in all previous
    > > > versions of Windows but do not work in Windows XP. The codes I used to use
    > > > were both 3 and 4 digit codes, ranging from ALT+0193 which produced a capital
    > > > A-accent-grave to ALT+159 which produced the old German form of an "s" which
    > > > looks like an itallic "f"
    > > >
    > > > I gather that some of these codes are unicode, but that is not the problem.
    > > > The problem is that the very same codes that used to work in ALL versions of
    > > > Windows before XP (and I think I have used or tried them all over the years)
    > > > do other things in XP. My conclusion is that Windows XP expropriates some of
    > > > these codes to do all the wonderful things that it does with keyboard
    > > > short-cuts. All I really want to do is to disable some of the Windows XP
    > > > defaults and be able to use the character codes that have been standard for
    > > > years.
    > > >
    > > > Thanks for the insights, but I'm still searching for an answer.
    > > >
    > > > Charles
    > > >
    > > >
    > > >
    > > > "David Candy" wrote:
    > > >
    > > >> But the numbers I gave are Unicode. If you use ANSI it is Alt + 0192
    > > >>
    > > >> --
    > > >> ----------------------------------------------------------
    > > >> http://www.uscricket.com
    > > >> "Charles" <Charles@discussions.microsoft.com> wrote in message news:EAD95402-BC2D-424F-9A94-C9EE7DCB9574@microsoft.com...
    > > >> > Thank you very much George. I will get the software you recommd (fortunately
    > > >> > I speak a little Dutch ... een klein beetje.) I am still trying to get the
    > > >> > answer to my orginial question, though. Some of the Microsoft built0in short
    > > >> > cuts are useful, of course, and have been present since the first versions of
    > > >> > Windows. But some of the new ones in XP are, to me at least, useless and
    > > >> > often just a confusing hindrance.
    > > >> >
    > > >> > I hope there is a way to deactivate at least some of the built-in short
    > > >> > cuts. I suspect there is but that it is just "cleverly" hidden away in some
    > > >> > arcane ini file or some such thing.
    > > >> >
    > > >> > Thanks again,
    > > >> >
    > > >> > Charles
Ask a new question

Read More

Configuration Windows XP