Sign in with
Sign up | Sign in
Your question
Closed

7950-Black Screen When Gaming

Last response: in Graphics & Displays
Share
February 20, 2012 1:35:23 AM

Hi I recently purchased an Asus 7950. At first everything was working well. I was able to run Heaven Benchmark and play games with no problems. Now when I try to run Heaven or play games my screen goes blank. I have tried just about everything from checking the cables, upping the voltage, etc. I don't know if it could be software/hardware problem but I do know it's not heat since it's less than 40C(even when gaming). Any help would be greatly appreciated. TY.

HAF X
Asus 7950
Intel 2600
Seasonic 860W Platinum
Intel SSD 520 Cherryville(120)
WD 1.5TB
ROG Maximus IV Extreme-Z
Corsair Vengeance 8G

Best solution

a b U Graphics card
February 20, 2012 2:12:01 AM

uninstall your amd drivers and install the latest ones from here.

If that doesn't work, rma.

edit: i suppose you could try a different pcie slot too. And try a different dvi slot.

and by blank, you mean the computer crashes or it just goes black till you close the game? Make sure you have all the auxiliary power cables plugged in too. I suppose you would if it worked before.
Share
February 20, 2012 2:14:55 AM

slicedtoad said:
uninstall your amd drivers and install the latest ones from here.

If that doesn't work, rma.



Yup...did that already. Guess it looks more likely I'm going to RMA it.

I was so pumped too in trying this card out. Now it seems I might switch back to NVidia.
Score
0
Related resources
February 20, 2012 2:44:00 AM

slicedtoad said:
uninstall your amd drivers and install the latest ones from here.

If that doesn't work, rma.

edit: i suppose you could try a different pcie slot too. And try a different dvi slot.

and by blank, you mean the computer crashes or it just goes black till you close the game? Make sure you have all the auxiliary power cables plugged in too. I suppose you would if it worked before.



I will try a different pcie slot in a bit and see if that changes anything. My connection is hdmi. My 27 in Samsung only has the VGA & HDMI available so I went with HDMI since I don't have a converter cable.

The screen goes completely blank and I hear the background music. After a couple of seconds it all goes silence.
Score
0
a b U Graphics card
February 20, 2012 11:32:36 PM

do you have another computer you could test it on? I'm thinking an rma will be necessary.

Don't give up on amd though... both companies have the occasional faulty card.
Score
0
February 21, 2012 12:17:38 AM

slicedtoad said:
do you have another computer you could test it on? I'm thinking an rma will be necessary.

Don't give up on amd though... both companies have the occasional faulty card.



Well good thing I didn't give up. I appreciate with taking the time to reply with advice/help. I switched it to a difference spot, had to reset the computer for the new settings to take place and redownload the drivers for the card. Have not had a problem since. I've been able to play games and run Heaven/3dMark11 with no problem whatsoever. I'm so glad it looks like it was a software and not a hardware problem. Thanks man.
Score
0
a b U Graphics card
February 21, 2012 10:04:15 PM

A different pcie slot fixed it? wow, that was kind of a shot in the dark.
Usually i see problems with pcie slots resulting in no display at all or a buggy display. Can't understand why it'd cause no display only at load.

Anyway, are you sure it's software? More likely it's the mobo if i understood you correctly. A broken pcie slot is not acceptable, you should rma.
Score
0
February 22, 2012 6:09:26 AM

slicedtoad said:
A different pcie slot fixed it? wow, that was kind of a shot in the dark.
Usually i see problems with pcie slots resulting in no display at all or a buggy display. Can't understand why it'd cause no display only at load.

Anyway, are you sure it's software? More likely it's the mobo if i understood you correctly. A broken pcie slot is not acceptable, you should rma.



You must be a good luck charm or something(no homo) lol.

I'm running the sound card of fthe first slot....Asus Xonar ST and it's working good with Corsair speakers. Once again thanks for taking the time in helping me bro. If you're in Houston, I owe you a beer.
Score
0
a b U Graphics card
February 22, 2012 10:04:22 PM

np, just remember to select my answer as "best answer".
Score
0
February 23, 2012 1:23:42 AM

Best answer selected by MrFantaztik.
Score
0
a c 273 U Graphics card
February 23, 2012 1:47:05 AM

This topic has been closed by Mousemonkey
Score
0
!