Crysis 2 Locking Up

Hey all,

Set up a new PC a month or two ago and finally got around to getting Crysis 2 (up until now have not had one problem with the build) but now when I play Crysis I get 5-10 minutes in and it freezes (30 seconds) then a black screen (5 seconds) then a fuzzy gray screen (1/2 second) and then it play again only to freeze 2 minutes later. I've monitored all my temps on a second screen with HWMonitor and with my H100 in place the CPU never gets over 60, and the GPU is always below 70.

I've run stock settings on my CPU and GPU. I've also run Prime95 without fail and Mark3D 11 with a decent score ~ P1600 (from memory)

I screen capped what happens when my system crashed (sorry its in table form, off of AMD system monitor)




I've tried reinstalling Crysis 2, drivers, patches even Windows but haven't seen a change.

One thing I'm not sure about is RAM, I have tried running on XMP - 1600, and on AUTO - 1300.

The only other thing is I'm using a 60GB SSD for Intel Rapid Storage Cache

I'd really appreciate anyone's advice so I can see this game in all it's glory

System Specs:
Intel 2500k @ 3.3Ghz
Gigabyte Factory OC 6970 2GB @ 900Mhz
ASRock Z68 Extreme 7 B3
Corsair H100 Liquid Cooler
Corsair Vengance Blue 16GB (4x4GB)
1000W Coolermaster SilentPro Gold
2TB Seagate 7200RPM w Corsair 60GB SSD Intel RST
7 answers Last reply
More about crysis locking
  1. I also ran memtest86 and for 20 minutes it ran well testing ~ 10GB then crashed
  2. Does any other game show this same freezing problem apart from Crysis 2?

    Also, did you run the test separately on each card?
  3. Nah nothing else even makes the comp sweat, what do you mean each card? Ive only got one GPU?
  4. benstark said:
    Nah nothing else even makes the comp sweat, what do you mean each card? Ive only got one GPU?

    Oh sorry, I meant each stick of RAM.

    But since no other games show the same problem, I think it's a problem with the game.
    So it's patched to the latest v1.9?
    Did you try running the game in compatibility mode? Or as an administrator?
  5. The Vengeance has an XMP profile right? Why not set it in bios and re-run memtest... crashing outside of windows isn't a good sign.
  6. He said he had already tried that
    Quote:
    I have tried running on XMP - 1600, and on AUTO - 1300


    But I don't know if he ran memtest with it.
  7. Yeah I ran memtest on xmp and auto modes, with basically the same result, I was hoping I wouldn't have to pull out each stock of ram, but yeah it's patched to the latest 1.9
    One thing I haven't tried is compatability mode so il try that today
Ask a new question

Read More

Graphics Cards Crysis Graphics