Sign in with
Sign up | Sign in
Your question

HD 5570 wont boot pc

Last response: in Graphics & Displays
Share
February 23, 2012 5:45:02 PM

I have been trying to install a new hd 5570

when i put the new card in, and boot up i can hear all of the machines fans spin at full speed, but nothing else happens. The PC simply will not boot

If i put my hd 4550 back in everything is fine, and the PC runs normally.

I have used driver sweeper, and removed all of the old drivers from the old card.

I reset my bios to factory, and switched it so that pci e was the main graphic display.

i tried a trick about holding the power button for 30 seconds or so with the cord out, and then plugging it in nothing has worked.

my cpu is an amd athalon 64 x2 4200+ 2.2ghz
motherboard is MS-7184 MSI Amethyst-M
I have a 550watt power supply

I am out of options as to what this could be besides simply a bad card. Any help would be greatly apreciated.

Ok after reading i hear this may be due to pci-e2.1 not working on some older motherboards. can anyone confirm if this sounds right. i am really at a lose here. I have never had this kind of problem buying a new card, and it was my understanding that the pci backward compatible this was standard. i guess i was wrong.

More about : 5570 wont boot

February 24, 2012 11:44:52 AM

It's a distinct possibility. Check the MSI web site to see if there has been any BIOS upgrades for your motherboard. If there are, check to see if any of those mention support for PCI-E 2.1. If so, try and upgrade the BIOS. If not, don't bother.

If you happen to have a newer system (or maybe a friend does), try the graphics card in that system to determine if it's functional. If it works in the newer system, then you know it's an incompatibility between your new graphics card and the motherboard.

-Wolf sends
!