Sapphire HD 7950 loses Audio when HDMI input is changed

I've tried everything from rolling back drivers, to reinstalling them, to using older ones and nothing has worked so far.

I use the PS3 3D Display. There have been no issues with it when I was using it with my G73 laptop, which also uses an AMD card. I could switch my display over to my PS3, then switch it back to my PC and have audio.

Now with my custom built PC, this is no longer the case. It completely loses audio when I go to a different input and then back to my PC input.

The only way to get back the audio is to either restart my system or unplug and plug the HDMI back in again.

Sapphire HD 7950 12.4
Sound driver version
i7 2600k
ASUS P8Z68-V/GEN3 LGA 1155

Any other suggestions would be awesome. I am pretty much out of options right now...
5 answers Last reply
More about sapphire 7950 loses audio hdmi input changed
  1. Doesn't work... I kept my display on when I rebooted my PC and the issue still happens when I switch inputs.
  2. Disable other audio output devices on your system (onboard).
  3. Tried that as well... Still get this

    edit: What do you mean by onboard? I went to the playback devices and disabled every audio thing there except my display.
  4. I am on a 6800 series ATI card and also have the same issue. I used to be able to switch between tv and hdmi input and the sound would still work. Now, I have to put my computer to sleep and turn it back on for this recognize the sound again.
Ask a new question

Read More

Homebuilt Audio Systems