Sign in with
Sign up | Sign in
Your question
Solved

Sapphire Radeon HD 6870 & 1920x1080 Resolution Gives Black Screen on HDTV

Last response: in Graphics & Displays
Share
February 26, 2012 6:56:11 PM

Hello,

I just bought the Sapphire Radeon HD 6870 card for my PC and hooked it up to my Samsung 40" HDTV with an HDMI cable (as Extended). My TV's native resolution is 1920x1080. But if I set anything higher than 1280x720 I get a black screen on the TV. I started with 1920x1080 and moved down incrementally until the TV shows, at 1280x720.

I found a closed thread in the Windows 7 titled "Window 7 monitor 1680x1050 and 1920x1080 resolution fix is here" but it was fixed by using an older version of the Nvidia drivers. I am using AMD graphic cards, so I wonder if anyone know of a driver (or fix) that would resolve this issue. Any help is much appreciated!

Victor


Updates: After I uninstalled the graphic drivers and CCC and rebooted, the TV does shows my Windows screen (same as what's on my PC) at it's native resolution, 1920x1080. So it looks like it works with the generic VGA driver in Windows 7. But how do I get it to work with it's own AMD driver? Please help!

Anyone?
February 28, 2012 4:05:01 AM

Got some intererting fact. I uninstalled the CCC v12.1 (F8/Driver Sweeper, the works) and installed v11.12. Once installed, this version gave my HDTV 1280x960. This is 3 levels better than the resolution I got with v12.1 (1280x720.)

So it has to do with the driver. I installed CCC v11.11 and got a black screen (almost) on my PC monitor where I can barely see anything. After some fumbling around I uninstalled it, and installed v11.10. This also gave me a best resolution of 1280x960.

I can keep doing this, uninstalling and reinstalling older versions, going backward. But this is painfully time consuming.

If anyone has any better idea, please let me know.

Thanks.
m
0
l
March 9, 2012 1:35:17 AM

Got an email from the forum saying to choose my best answer, but there is no answer yet.

More info: Currently I am using CCC version 12.2 and it gives me 1440x900 resolution. I used a DVI-HDMI adapter to connect and my TV does shows at 1920x1080. Just no audio, as we know DVI won't. But still no luck on HDMI to HDMI connection. I called AMD support and they advised me to use an HDMI ver 1.4a or better.

The cable I am using is High Speed HDMI 1080P and Support 3D and Audio Return Channel (ARC) so although I am not sure of the version, I think it should works. And it does work with just the generic Windows 7 VGA driver (CCC uninstallled.)

So, anyone?

Thanks.
m
0
l
Related resources
March 9, 2012 3:43:05 AM

Wow, finally got this resolved. In the Catalyst Control Center, the Pixel Format setting in My Digital Flat-Panels should be YCbCr 4:2:2 Pixel Format.

I hope this infomation will help those that have the same problem.

Please close this thread. Thanks.
m
0
l
March 19, 2012 1:06:07 AM

Again, I am being asked to close this thread by "....and select the best one as your "Best Answer" (click on the gold cup above it)...." but I am not seeing any 'Gold Cup.'
m
0
l
March 26, 2012 4:28:09 AM

Hello ,
your thread "Sapphire Radeon HD 6870 & 1920x1080 Resolution Gives Black Screen on HDTV" has received some answers. We invite you to review these, and select the best one as your “Best Answer” (click on the gold cup above it).
Click here to review the answers to your question: http://www.tomshardware.com/forum//forum2.php?config=to...
Selecting a "Best Answer" will help the community to easily spot answers to similar issues or questions.
Thank you for contributing the Tom's Hardware community
The Tom's Hardware community team
m
0
l

Best solution

March 26, 2012 4:56:48 AM

Give me a best answer :) 
Share
March 27, 2012 3:07:37 AM

Hahah...that's what I thought... Thanks.

The system needs to be modified.
m
0
l
March 27, 2012 3:07:49 AM

Best answer selected by voodoo1226.
m
0
l
March 29, 2012 5:10:52 AM

I think the forum is playing a joke on me....just got this again, lol...




4:54 PM (5 hours ago)














to me












Hello ,
we noticed that your thread is not active anymore. Did you get the answer that you were seeking? We invite you to review the answers, and select the best one as your "Best Answer" (click on the gold cup above it).
Click here to review the answers to your question: http://www.tomshardware.com/forum//forum2.php?config=to...
Selecting a "Best Answer" will help the community to easily spot answers to similar issues or questions.
If you did not get the answer you were seeking, we suggest that you add details to your question. By doing so, you will get renewed attention to your issue.
Thank you for contributing the Tom's Hardware community
The Tom's Hardware community team
m
0
l
March 29, 2012 2:31:22 PM

Did you try custom HDTV resolution option in CCC?... or make it your main display instead of extended.

Also, you shouldn't have picked a best answer especially to the troll that asked for it.
m
0
l
March 29, 2012 4:41:13 PM

RussK1 said:
Did you try custom HDTV resolution option in CCC?... or make it your main display instead of extended.

Also, you shouldn't have picked a best answer especially to the troll that asked for it.


I posted the question more than a month ago, with no reply. Then I solved the problem myself. And the forum keeps sending me emails, telling me to pick the best answer by picking the 'gold up' thing. But the gold cup thing is no where to be seen, probably because no one anwered.

This forum should have an option to pick your own answer as the best answer if you solved the problem yourself. The gold cup seems to appear only when someone else post a reply.
m
0
l
March 29, 2012 5:06:59 PM

voodoo1226 said:
I posted the question more than a month ago, with no reply. Then I solved the problem myself. And the forum keeps sending me emails, telling me to pick the best answer by picking the 'gold up' thing. But the gold cup thing is no where to be seen, probably because no one anwered.

This forum should have an option to pick your own answer as the best answer if you solved the problem yourself. The gold cup seems to appear only when someone else post a reply.


True... you could message one of the moderators and voice the concern. It is a problem that should be fixed...

Take care.
m
0
l
February 22, 2013 9:58:45 AM

Dear Friend's,

I had the same Problem when i upgraded my Graphics card to His Radeon Hd 6870.When i First installed the Graphics card, I randomly used to get the Black screen, Suddenly while using some application's and Browser's or while Going through some pictures using Window's photo viewer...my screen suddenly goes black and from a simple problem it became worse and i was so irritated with the problem and thought of even disposing my Graphics card and eventually my system.I tried Several techniques and trick's on my system but was not successful... AND THEN FINALLY ITS BEEN 'SOLVED' :) 

My Specs Are:

Intel Core i7 930 Processor on DX58SO mother board.
8 GB DDR3 RAM
Cooler Master V8 cooler
HIS AMD/ATI Radeon HD 6870 ICEQ X Garphics card
12 Fan's inside the cabinet
1 TB WD HDD
LG DVD RW CD/DVD Drive
700 watts Mron PSU
4 Cathode blue Lights


I Tried all this:

1. I first Uninstalled the CCC and used only MSI Afterburner... But again the Problem still remain's...Black screen.

2.I installed some Previous version's of CCC 12.10... but was unsuccessful..

3.I Disabled AMD Overdrive but was of new use.

4.I Changed my DVI TO HDMI Cable and replaced with a new one and i used HDMI TO HDMI Cable, but again i had the same issue...

5.Installed DIRECT X Latest version..... but was unsuccessful...

6.Updated Monitor Driver's....was unsuccessfull :( 

7.I set my GPU Clock to 950 Mhz... but again the black screen....

8.I tried the graphics card on the other pci-e slot as well.... but was unsuccessful... :( 

9.Updated the BIOS To latest version....was unsuccessful

10.I Reinstalling Window's 7..... was Unsuccessful....


Then Finally.............

I Upgraded my PSU to Cosair TX850 - Just Awesome with a dedicated 12v rail 8 pin connector delivering clean and quality Power unlike other Cheap brand's

Now i am very happy on my new PSU AND GRAPHICS CARD...

I would recommend only Corsair and cooler master PSU's...



Pls do reply to my post and let me know on further discussion's.Hope my Post help most of my friend's facing the same issue..

Thank you,
Regard's
Vishal.

m
0
l
February 22, 2013 9:59:55 AM

Dear Friend's,

I had the same Problem when i upgraded my Graphics card to His Radeon Hd 6870.When i First installed the Graphics card, I randomly used to get the Black screen, Suddenly while using some application's and Browser's or while Going through some pictures using Window's photo viewer...my screen suddenly goes black and from a simple problem it became worse and i was so irritated with the problem and thought of even disposing my Graphics card and eventually my system.I tried Several techniques and trick's on my system but was not successful... AND THEN FINALLY ITS BEEN 'SOLVED' :) 

My Specs Are:

Intel Core i7 930 Processor on DX58SO mother board.
8 GB DDR3 RAM
Cooler Master V8 cooler
HIS AMD/ATI Radeon HD 6870 ICEQ X Garphics card
12 Fan's inside the cabinet
1 TB WD HDD
LG DVD RW CD/DVD Drive
700 watts Mron PSU
4 Cathode blue Lights


I Tried all this:

1. I first Uninstalled the CCC and used only MSI Afterburner... But again the Problem still remain's...Black screen.

2.I installed some Previous version's of CCC 12.10... but was unsuccessful..

3.I Disabled AMD Overdrive but was of new use.

4.I Changed my DVI TO HDMI Cable and replaced with a new one and i used HDMI TO HDMI Cable, but again i had the same issue...

5.Installed DIRECT X Latest version..... but was unsuccessful...

6.Updated Monitor Driver's....was unsuccessfull :( 

7.I set my GPU Clock to 950 Mhz... but again the black screen....

8.I tried the graphics card on the other pci-e slot as well.... but was unsuccessful... :( 

9.Updated the BIOS To latest version....was unsuccessful

10.I Reinstalling Window's 7..... was Unsuccessful....


Then Finally.............

I Upgraded my PSU to Cosair TX850 - Just Awesome with a dedicated 12v rail 8 pin connector delivering clean and quality Power unlike other Cheap brand's

Now i am very happy on my new PSU AND GRAPHICS CARD...

I would recommend only Corsair and cooler master PSU's...



Pls do reply to my post and let me know on further discussion's.Hope my Post help most of my friend's facing the same issue..

Thank you,
Regard's
Vishal.

m
0
l
!