Sign in with
Sign up | Sign in
Your question

AMD Radeon HD 6850 Display issues

Last response: in Graphics & Displays
Share
February 27, 2012 4:27:45 PM

About 4 months ago i bought a brand new AMD Radeon HD 6850 and it worked fine for about a month then randomly while playing wow one half of my screen with switch with the other half. I play wow in windowed mode and ive never had this problem with any other card ive owned. So i sent it back and got it repaired they told me it was a chip that was faulty and fixed and sent it back. I just got it back today,updated the drivers and made sure it was the primary graphics on my comp and im still having the screen switch sides..... any ideas....
a b U Graphics card
February 27, 2012 4:38:30 PM

Try switching output ports and messing with the extended displays options...
a b U Graphics card
February 27, 2012 4:42:26 PM

What do you mean Switching sides? can you give a example?

Can be a monitor problem, also your psu may be not enough for the video card what is giving you random issues, what is your PSU? is your monitor correctly conected what cable are you using?
Related resources
February 27, 2012 4:46:10 PM

Ok my PSU is a Corsair GS800 800 watt, and i have tried it on my 22 in vizio tv and my brand new acer monitor happens on both and only during wow others games it works fine. As an example look at your monitor and divide in half down the middle of the screen so you have basically 2 sides and then switch them and that is whats happening, and when that happens i close wow and my desktop is the same so it forces me to restart my comp
February 27, 2012 4:52:48 PM

Must be config within WOW if it is fine with other games it must be WOW. Hardware should be perfectly fine
February 27, 2012 4:57:53 PM

If It just WoW any ideas on how to fix it?
a b U Graphics card
February 27, 2012 5:01:04 PM

Shrader said:
Ok my PSU is a Corsair GS800 800 watt, and i have tried it on my 22 in vizio tv and my brand new acer monitor happens on both and only during wow others games it works fine. As an example look at your monitor and divide in half down the middle of the screen so you have basically 2 sides and then switch them and that is whats happening, and when that happens i close wow and my desktop is the same so it forces me to restart my comp

hm, this is very strange, does this happens with every video card output (vga/hdmi/dvi)? or is it specific?
well if it is just o WOrld of warcraft, it should be a config problem, try changing some settings in game.
February 27, 2012 5:03:44 PM

Well when it first happened before i sent it in it would happen with hdmi and vga, but today im using it with a vga to dvi adapter but i can go ahead and test all three?
February 27, 2012 5:07:16 PM

I also MSI After Burner if that could be useful
a b U Graphics card
February 27, 2012 5:11:25 PM

Shrader said:
Well when it first happened before i sent it in it would happen with hdmi and vga, but today im using it with a vga to dvi adapter but i can go ahead and test all three?


if it is just in wow try uninstalling (removing all game configs and files from computer) and reinstalling again...
February 27, 2012 5:14:35 PM

Well before i go spending my entire day reinstalling wow lets see if there's other solutions.. could be an other problem???
February 27, 2012 5:17:13 PM

Would having Direct 11 on or off cause this or vertical sync??
a b U Graphics card
February 27, 2012 5:27:54 PM

i really never saw that problem happen, but try setting everething to low and see if the problem keeps there.
February 27, 2012 5:33:19 PM

So far i set everything to low and the problem has not happened, but i know my card i capable or playing WoW on ultra...
a b U Graphics card
February 27, 2012 5:37:12 PM

maybe some setting is scramblin with pixel/vertex shaders, try upgrading your catalyst drivers and go increasing the graphics one by one until you catch the switch effect.
February 27, 2012 5:53:53 PM

ok so i turned up everything but Texture filtering which i left at bilinear and triple buffering which is disabled and so far the problem has not happened
Also left multisampling at 1x and kept vertical sync on and reduced lag input off
a b U Graphics card
February 27, 2012 5:59:24 PM

This is really strange, if you could show that to blizzard staff they would like to see an error like this one, maybe it is an incompatibility with your specific video card. or some bugged update/driver.
February 27, 2012 6:01:11 PM

ima go ahead and put texture filtering to 8x anisotropic and see if that affects anything i have limited it down to multi sampling reduced lag input an triple buffering it has to be one of those
February 27, 2012 6:07:51 PM

the problem has seemed to stop which puzzles me..
February 27, 2012 8:58:51 PM

and now it continues again...
a b U Graphics card
February 27, 2012 11:55:08 PM

Did you noticed anythin wrong with any other game? or is it just with wow? do you remember last thing you did before this problem started to occur? maybe updated driver? try rolling back to the oldest drivers see if that fix your issue.

can you give us a screenshot of the problem?
February 28, 2012 4:41:49 PM

well i ran DxDaig and there was some problem accessing my system files and when i fixed that the problem hasent happened since. if it does happen again i will get a picture post it, thanks for your help though very much appreciated.
April 7, 2012 3:47:50 AM

Shrader,
I am having this exact issue (halfs switching sides) with my new sapphire hd 6850. I read your part about running dxdiag and it also popped up a message about a problem accessing my system files. I ran it again and it analyzed fine.

Did you do anything else to fix this issue with the flipped halves?

April 22, 2012 5:38:06 PM

I am having the exact issue as with with a brand new computer from newegg with the AMD Radeon HD 6850. Drivers all have been updated. This is not an issue just to wow. It has occurred in BF3 and Diablo3 beta for me. Same for me that it sometimes occurs within minutes and then sometimes hours. Im currently in contact with cyberpowerpc tech support, so if i get a solution i will link it back here.
May 7, 2012 2:53:08 AM

I ended up RMA'ing the card back to Newegg, they sent another one, it works fine.

July 26, 2012 11:56:19 AM

I only signed up here because, I have the exact same problem and the card has overheating issues, I opened mine up to see the Heat sink paste has dried out, Cleaned off then replaced it worked fine.
Anonymous
a b U Graphics card
a b Ý World of Warcraft
January 19, 2013 9:49:39 PM

I had the same problem with my AMD 6850hd graphics card,when i used windowed fullscreen mode (wow).Although this issue came up when i upgraded Catalyst driver.I did restore or something from the hardware menu and everything is fine.Until now...
Anonymous
a b U Graphics card
a b Ý World of Warcraft
January 20, 2013 9:11:53 AM

Just happened again in Diablo III...
July 9, 2013 3:30:52 PM

I also ran across this issue with the same graphics card. I re-installed my graphics card and updated all drivers. Instead of using the device manager to install the updates, I did it directly from AMD's website. I am currently on Driver Version: 12.104.0.0 which was released on 03/28/2013. I would suggest upgrading your card to this version. A link to the drivers page of AMD's website is provided below:

http://support.amd.com/us/gpudownload/Pages/index.aspx

This solved the problem for me, I hope it will work for you too!
!