Sign in with
Sign up | Sign in
Your question
Solved

Asus P8Z77-V: Red CPU LED

Last response: in Systems
Share
May 5, 2012 3:17:27 AM

I just swapped out my old mobo with a brand new P8Z77-V. My cpu is Intel i5-2500k.

Everything is connected, etc... when I power-on the the system, there is no signal sent to the display, the tiny CPU LED on the mobo turns red immediately, and the system shuts off after 10 seconds. I've tried reseating the cpu, messed around with the RAM, etc... nothing is working.

Any ideas?

Random thought... I bought my cpu last year, very soon after the unlocked i5s were released. Now, I notice that the P8Z77-V supports "Intel® Socket 1155 for 3rd/2nd Generation Processors ". Do have a 1st gen cpu?

Thanks for any help.....

More about : asus p8z77 red cpu led

a b B Homebuilt system
a b à CPUs
May 5, 2012 3:30:34 AM

the i5-2500k is 2nd gen
m
0
l
May 5, 2012 3:34:11 AM

Thanks... that's what I thought. Just a guess on my part. Maybe when my old mobo dies, it took the cpu with it?
m
0
l
Related resources

Best solution

a b B Homebuilt system
a b à CPUs
May 5, 2012 3:36:15 AM

unless your cpu was hit by a power surge when your mobo died out, it shouldnt happen. imo the best thing to do is to look for a friend or someone who has a socket 1155 motherboard computer and test your cpu on their board to see if it works.
Share
a b B Homebuilt system
a c 188 à CPUs
May 5, 2012 3:59:59 AM

check for bent pins. there may be one on the cpu or the mb. also did you plug in the extra 4/8 pin power that the mb needs without this it wont post. have you tried posting the mb outside the cae to rule out that there a dead short.
m
0
l
May 5, 2012 5:58:24 AM

No bent pins. All power connections attached. Not sure what you mean by posting the mb outside the case.. ?
m
0
l
May 5, 2012 7:17:40 AM

Thanks. I've tried many of these steps, and still no go. I'll keep trying...
m
0
l
Anonymous
a b B Homebuilt system
a b à CPUs
May 5, 2012 7:22:50 AM

i will suggest you consider an RMA process. :( 
m
0
l
May 11, 2012 5:34:04 PM

Follow up: A red cpu LED means exactly what you'd think: Dead cpu. This was confirmed by my local pc shop. Good news is that it's under warranty (3yrs), and a new one is on the way. Intel support was actually quite good, and efficient.
m
0
l
May 18, 2012 1:59:56 AM

Best answer selected by porch73.
m
0
l
!