Sign in with
Sign up | Sign in
Your question
Closed

I need help with Skyrim on my GTX570:(

Last response: in Graphics & Displays
Share
February 29, 2012 9:27:29 AM

Ok so I have the Gigabyte SOC GTX570 with an i7 2600k @4.5ghz. All packed in an Antec 1200 V3. Running Skyrim with high res Texture pack I always get 60fps + everywhere in Skyrim. Outside and in towns. but lately I have noticed a problem. The game will run great for about 40 minutes or so and then BAM I take a massive hit in the FPS department. It drops to about 20fps and starts lagging out. I'm using 285.62 drivers. I am guessing the problem is with the card but have no clue. Playing other games I have 0 problems. And this is a pretty powerful card I cannot see it not being able to handle Skyrim on Ultra. BF3 runs great on Ultra. Plus I find it odd that it runs great for 40 minutes and then starts this crap.

I can fix it by simply exiting to desktop and then restarting the game. However this is quite irritating. And just recently when I exited the game and clicked on my browser my screen looked like it was "wavy" is the best way I can describe it. THe xt and everything on screen had a slight fluid motion to it. It stopped after a minute or so. This is a brand new system as well. Maybe driver related I don't know hoping someone can help me.

Just to add there is no overheating going on. My processor reaches a max of 55c and my video card 50c while gaming. So heat is not the issue. Thanks guys:) 

More about : skyrim gtx570

February 29, 2012 12:57:36 PM

I had similar issues with Skyrim running a pair of HD 5850's in crossfire (along with a whole host of other issues due to poor amd drivers for the first few months). I ended up getting rid of the video cards but haven't gone back to play through with the new 560 ti's yet. Bottom line is the problem is most likely with Skryim- one of the best games I've played in the last couple of years but such a shame there are/were so many technical problems.
Score
0
Related resources

Best solution

a b Î Nvidia
February 29, 2012 1:17:54 PM

Update the driver, i know it not something you want to do, but i can say i got a huge performance increase comparing older drivers vs the new 295.73 WHQRL. They say a guaranteed 20-40% increase
Share
February 29, 2012 5:16:41 PM

Rockdpm said:
Update the driver, i know it not something you want to do, but i can say i got a huge performance increase comparing older drivers vs the new 295.73 WHQRL. They say a guaranteed 20-40% increase



Ok I will do that later and get back to you. Thank you. Ya I thought the driver only updated support for SLI/CF. Which I am not using. But mayb it helps other issues as well. As you said you got an increase in performance.
Score
0
February 29, 2012 5:22:02 PM

neon neophyte said:
http://forums.guru3d.com/showthread.php?t=353822

its a weird problem though. it sounds like overheating but then its not. cant really picture what else it would be outside of something faulty


Wow ok that thread you sent that guy has the exact problems as me. Only he is uding SLI 570 and still getting massive drops. If updating the drivers does not work I may just have to try 8X AA instead of 16. I cant see taking that big of a visual hit. All though I'd rather take none at all Lol. But ya I monitor my temps closely and my card never reaches above 55c. I see people with reference cards idle that high.
Score
0
a c 456 Î Nvidia
February 29, 2012 5:28:33 PM

That has happened to me a couple times and was fixed by exiting and restarting the game. There are still some bugs in the game that need to be fixed.

Definitely upgrade your drivers to the latest 295.73 WHQL drivers, which are really Skyrim specific. Also, be sure to take a look at your Nvidia Control Panel settings, there are really a lot of things in there that you can play around with. Most importantly, though, is to set VSync to "Force Off".

Check out this tweak guide:
http://www.geforce.com/Optimize/Guides/the-elder-scroll...
Score
0
February 29, 2012 11:42:36 PM

17seconds said:
That has happened to me a couple times and was fixed by exiting and restarting the game. There are still some bugs in the game that need to be fixed.

Definitely upgrade your drivers to the latest 295.73 WHQL drivers, which are really Skyrim specific. Also, be sure to take a look at your Nvidia Control Panel settings, there are really a lot of things in there that you can play around with. Most importantly, though, is to set VSync to "Force Off".

Check out this tweak guide:
http://www.geforce.com/Optimize/Guides/the-elder-scroll...



Ok I was wondering though I did go in the control panel and set a few things straight. But I have only a 60hz 1680X1050 monitor right now. And I use Vsync. Would it matter if I turned it off? Thanks:) 
Score
0
February 29, 2012 11:56:20 PM

I am running a similar set up and used to have frame rate drops after playing Skyrim for extended periods of time until i started using the Large Adress Aware Mod that allows you to use more RAM for Skyrim. I do want to note that the most recent patchs, the driver update listed above, and the high resolution texture pack have fixed this issue so i no longer use this mod to keep Skyrim from dropping FPS and crashing. If you are interested in trying this as a potential fix, this can be downloaded from the Skyrim Nexus skyrim.nexusmods.com.

Good Luck with your problem!
Score
0
a c 456 Î Nvidia
March 1, 2012 1:12:30 AM

Always turn the VSync off unless you have a specific problem with screen tearing that you need to fix. With a GTX 570 on a 1050 resolution, you should definitely turn Vsync off to get that frame rate as high as possible.
Score
0
March 1, 2012 8:47:19 AM

Best answer selected by bigj1985.
Score
0
March 1, 2012 8:54:39 AM

Ok thank you to everyone here you guys were all quick to help. I can say I love the community here! One of the very few places of light in the dark corners of the net Lol. Anyways my issues were completely FIXED by UPDATING MY DRIVERS

After updating played for the last 3 hours no issues:)  The good part is that Skyrim was the only game I had any need to OC my sandy bridge for. It scaled well.....or so I thought. Just poor optimization. After updating I was able to revert back to stock turbo settings and the game never drops below 60fps. Well ok I get 59 sometimes Lol. So now my chip runs much cooler. Sure I like the bragging rights of saying I have a 4.5ghz chip bla bla bla bla. But when it really comes down to it for what I do there is no need for such insane clock speed on this beast. I'm all about extending life of the chip.

THANK YOU!!
Score
0
March 1, 2012 8:57:47 AM

17seconds said:
Always turn the VSync off unless you have a specific problem with screen tearing that you need to fix. With a GTX 570 on a 1050 resolution, you should definitely turn Vsync off to get that frame rate as high as possible.


Just to let you know when I forced Vsync off after updating the drivers I was getting 150+FPS. I had real bad screen tearing everywhere:(  i had to apply Vsync. In the menu screen it was showing 1500fps Lol. I guess if I had a reference 570 I would be right around the area to turn it off. But I guess if I hadn't updated my drivers I would have gotten descent results forcing it off IDK. Thanks mate:) 
Score
0
a c 456 Î Nvidia
March 1, 2012 3:45:09 PM

bigj1985 said:
Just to let you know when I forced Vsync off after updating the drivers I was getting 150+FPS. I had real bad screen tearing everywhere:(  i had to apply Vsync. In the menu screen it was showing 1500fps Lol. I guess if I had a reference 570 I would be right around the area to turn it off. But I guess if I hadn't updated my drivers I would have gotten descent results forcing it off IDK. Thanks mate:) 

If you got screen tearing.... that's actually a good thing.... because now you get to turn up the detail settings even more to bring the frame rate down and eliminate tearing.

Here are my recommendations to amp up your visuals and reduce/eliminate that screen tearing, much of which I got from the tweak guide I listed before and from experimenting myself:

Game Settings:
- Ultra everything
- FXAA On
- Object Detail Fade Off
- Antialiasing 8x
- Anisotropic Filtering Off (you'll max out AF in the Nvidia Control Panel instead)

Nvidia Control Panel, go to Program Settings > Drop down menu for Elder Scrolls 5: Skyrim
- Ambient Occlusion Quality
- Anisotropic Filtering 16x
- Anitaliasing gamma correction On
- Antialiasing Mode Application-controlled (I see the new drivers took away the option to override)
- Antialiasing Transparency - 2x (supersample) - DO NOT use Multisample for this one. You can turn this up all the way to 8x if you want. I can use 8x, 4x, and 2x, but with the extra .ini settings I have enabled, 2x works best. This is the one setting that will have the biggest impact on performance.
- Mixed display/mixed-GPU acceleration - Single display performance mode (this defaults to multi-display)
- Texture Filtering Quality - set to High Quality
- Vertical sync - Force off
Score
0
March 1, 2012 5:01:07 PM

17seconds said:
If you got screen tearing.... that's actually a good thing.... because now you get to turn up the detail settings even more to bring the frame rate down and eliminate tearing.

Here are my recommendations to amp up your visuals and reduce/eliminate that screen tearing, much of which I got from the tweak guide I listed before and from experimenting myself:

Game Settings:
- Ultra everything
- FXAA On
- Object Detail Fade Off
- Antialiasing 8x
- Anisotropic Filtering Off (you'll max out AF in the Nvidia Control Panel instead)

Nvidia Control Panel, go to Program Settings > Drop down menu for Elder Scrolls 5: Skyrim
- Ambient Occlusion Quality
- Anisotropic Filtering 16x
- Anitaliasing gamma correction On
- Antialiasing Mode Application-controlled (I see the new drivers took away the option to override)
- Antialiasing Transparency - 2x (supersample) - DO NOT use Multisample for this one. You can turn this up all the way to 8x if you want. I can use 8x, 4x, and 2x, but with the extra .ini settings I have enabled, 2x works best. This is the one setting that will have the biggest impact on performance.
- Mixed display/mixed-GPU acceleration - Single display performance mode (this defaults to multi-display)
- Texture Filtering Quality - set to High Quality
- Vertical sync - Force off


Well then you learn something new everyday. I didn't know it could get any better than the ultra settings in the launcher and the texture mods. Sweet man will try thank you:)  I would have never thought of this
Score
0
a c 172 Î Nvidia
March 1, 2012 7:15:37 PM

[:thegreatgrapeape:7]
Score
0
!