Sign in with
Sign up | Sign in
Your question

Possible PSU problem

Last response: in Components
Share
August 20, 2012 9:04:36 PM

Hi all, I have a problem with my system and was wondering if you guys could help. I recently purchased some upgrades for my system from ebuyer as it was time but since installing them, sometimes when gaming the computer shuts down, there's still fan noise but the screen goes black, my system is as Follows

Zotac GTX 560 Ti 448 Core Limited Edition 1280MB (new)
CIT 750W Power supply GOLD (new)
Gigabyte GA-970A-DS3 Socket AM3+ 7.1 Channel Audio ATX Motherboard (new)
EXTRA VALUE 4GB (2x2GB) DDR3 1333MHz Memory Kit 1.5V CL9
AMD Athlon II X2 260 3.2 GHz Socket AM3 2MB Cache
Hitachi 500GB Deskstar 3.5" SATA-II Hard Drive 7k1000.C - 7200rpm 16MB Cache - OEM

So I'm thinking I may have made a bad decision with the PSU even though on paper it seems like it should run the rest of the system, that's what you get for trying to pinch pennies! I also noticed the graphics card ran hot under load, around 85 degrees but a little research suggests this is normal, I have mostly stock cooling except for a couple of case fans, just budget ones that came with my case.

So do you think it is my PSU or am I looking at something completely different?

Many thanks!

More about : psu problem

a c 165 ) Power supply
August 20, 2012 9:13:49 PM

85c is fine for the GPU, what about the CPU temps (just to make sure)?

besides that, the PSU is junk. considering its 750w and costs half as much as a good budget 600w unit? i would return it ASAP and getting something solid

http://www.ebuyer.com/264511-ocz-zs-series-650w-80-bron...


August 20, 2012 9:38:57 PM

Hi ct1615

Thanks, I was afraid I may have made a bad decision there and thanks for the recommendation, I'll be on the phone to ebuyer tomorrow to try to get it refunded! As for my CPU temp it seems to run around 48-54 degrees while gaming
Related resources
August 20, 2012 9:47:51 PM

Strangely, when I replace the zotac with my old hd 4670 gfx card I get no shutdowns, not sure if this means the GPU is dead or if it's just because the old gfx card draws less power
a c 165 ) Power supply
August 20, 2012 11:15:40 PM

mikey2505 said:
Hi ct1615

Thanks, I was afraid I may have made a bad decision there and thanks for the recommendation, I'll be on the phone to ebuyer tomorrow to try to get it refunded! As for my CPU temp it seems to run around 48-54 degrees while gaming


good temps for the CPU so obviously that was not an issue
a c 165 ) Power supply
August 20, 2012 11:20:46 PM

mikey2505 said:
Strangely, when I replace the zotac with my old hd 4670 gfx card I get no shutdowns, not sure if this means the GPU is dead or if it's just because the old gfx card draws less power


the Nvidia GTX 560ti 448 can draw over 200w at peak power while the ATI 4670 will stay under 50w

when looking for a new PSU get one with solid reviews (like the OCZ unit linked above) rather then one with the most power at a budget price. remember, companies can simply toss a 750w on a 400w PSU since they don't have to have their units independently tested for stated power.


August 20, 2012 11:23:02 PM

OK thanks again for all your help, I'll try a different PSU tomorrow
!