Sign in with
Sign up | Sign in
Your question
Solved

Fan speed not increasing on HD5970

Last response: in Graphics & Displays
Share
Anonymous
March 2, 2012 4:43:02 AM

I've recently upgraded to a HD5970, Fan speed doesn't seem to be increasing by itself and having issues with temperature hitting 80degrees+ (Crashing to black screen in win7, In winXP crashes to VPU Recover)

Playing Crysis on win7 64bit the temp will go up to 80+ degrees (from about 45 degrees) and the fan still stays at 29%, In winxp x86 the fan stays at 30%.

Also running Furmark (Not for a full test) The fan speed will stay at 29% to temps of 80 degrees and more.

I can manually adjust the fan speed within catalyst and assign a fan speed profile in MSI afterburner. I have a few questions though..

Is the fan speed meant to be going up at temps up to 80 degrees?

I'd like to assign a permanent fan profile without MSI afterburner running in the background (Like the card should normally do).. any way i can do this?

Thanks for any help.

Best solution

March 2, 2012 7:02:15 AM

As a someone who has owned 2 of these
Great cards, but terrible fan profiles in the bios, that pretty much do not work
It's either manual fan speed/profile, or flash a modified bios onto the card
I used to just set manual fan speed to 65% and left it, I didn't mind the noise
Share
Anonymous
March 2, 2012 7:46:43 AM

Thanks kitsunestarwind, really appreciate the replies. Just turned my card to 65% fan but its really close to my gamin area and quite loud...

Think i'll settle with MSI Afterburner fan profiles, I'm not 100% confident on flashing a card i just spent half a grand on... Did you end up flashing yours? Mine is a sapphire hd5970, clocks are stock at 725 & 1000.

Glad to have some feedback from someone who has owned the same cards. Have selected you as best answer for both threads. Cheers
m
0
l
Related resources
Anonymous
March 2, 2012 7:46:55 AM

Best answer selected by client54.
m
0
l
March 2, 2012 8:08:30 AM

I had flashed one of mine as an experiment, you have to be careful due to it having Master and Slave bios's.
I flashed it cause, I up'd the voltage a touch on a min power mode due to suffering the low power mode crash/BSOD some of the earlier cards had trouble with.

Now that mine are no longer in my primary desktop i've been tempted to reflash them with a much better fan profile.

Oh if you can get one, even second hand as they are very rare now the Arctic Cooling Accelero Extreme cooler for the 5970 works wonders. But like i said very rare
m
0
l
July 13, 2012 12:12:31 PM

Anonymous said:
I've recently upgraded to a HD5970, Fan speed doesn't seem to be increasing by itself and having issues with temperature hitting 80degrees+ (Crashing to black screen in win7, In winXP crashes to VPU Recover)

Playing Crysis on win7 64bit the temp will go up to 80+ degrees (from about 45 degrees) and the fan still stays at 29%, In winxp x86 the fan stays at 30%.

Also running Furmark (Not for a full test) The fan speed will stay at 29% to temps of 80 degrees and more.

I can manually adjust the fan speed within catalyst and assign a fan speed profile in MSI afterburner. I have a few questions though..

Is the fan speed meant to be going up at temps up to 80 degrees?

I'd like to assign a permanent fan profile without MSI afterburner running in the background (Like the card should normally do).. any way i can do this?

Thanks for any help.


i have the same card and the same issue...have had to resort to setting the fan speeds manually when i go in and start a game...i have noticed temps getting to 80C as well without the fan trying to adjust the speed...always at 29 or 30 percent.

nice to see others are having this issue and i guess its unfortunate there is no quick fix
m
0
l
!