Sign-in / Sign-up
Your question
Solved

CoolerMaster HAF 912 LED problems

Tags:
  • Cooler Master
  • LED Monitor
  • Components
Last response: in Components
August 21, 2012 10:17:14 PM

The front LED on my HAF 912 doesnt seem to turn on.... anyone got any possible explanations? Everything else works, including the power LED and the front fan does work

More about : coolermaster haf 912 led problems

August 21, 2012 10:27:18 PM

What specific LED are you referring to?

All front panel LEDS will be powered by plugging them directly into the motherboard - and seeing as you have the Power LED working you know how fiddly this is.

Make sure you have all the little headers in the correct order (+/-).
m
0
l
August 21, 2012 10:38:34 PM

Usually a led is associated with some function like a fan or an on off button , what is this led supposed to be for? Where is it located ? Up near the usb plugs and the on/off bottons? When you say the front fan does work are you saying that the led is for the front fan? If the front fan has led then it could have a seperate plug that needs to be connected and you might want to check the wires that came with the case and are routed towards the front and see if there is a seperate plug for a led for the fan.
m
0
l
Related resources
August 21, 2012 10:55:56 PM

inzone said:
Usually a led is associated with some function like a fan or an on off button , what is this led supposed to be for? Where is it located ? Up near the usb plugs and the on/off bottons? When you say the front fan does work are you saying that the led is for the front fan? If the front fan has led then it could have a seperate plug that needs to be connected and you might want to check the wires that came with the case and are routed towards the front and see if there is a seperate plug for a led for the fan.

yup the LEDs are where the fans are, ive checked several times with the small connectors ive hooked up as well as to see if i didnt connect anything... everything seems fine O.o
m
0
l

Best solution

August 21, 2012 11:41:08 PM

Then you may either have to take out the front fan and see what is going on with connections or give Cooler Master a call to say that the les are not working.
Share
August 21, 2012 11:46:55 PM

Best answer selected by ty0620.
m
0
l
August 21, 2012 11:48:12 PM

inzone said:
Then you may either have to take out the front fan and see what is going on with connections or give Cooler Master a call to say that the les are not working.

Your computer build is ridiculous.... may i ask why u would need 24 gb of ram O.o?
m
0
l
August 21, 2012 11:57:35 PM

Well I bought it before I bothered checking if I needed it or not and being a little lazy and ram prices being so cheap I just decided to get the max and if I needed it then I have it , if not then I have it anyway. Looking back I should have gotten some higher frequncy instead of a large amount. The ram on the X-58 chipset is triple channel and you need the sets to be in three stick sets and the ram water block I wanted covered six sticks so that's another reason.
m
0
l