Sign in with
Sign up | Sign in
Your question

Need help with Soundblaster X-Fi XtremeGamer edition audio

Last response: in Components
Share
August 22, 2012 9:52:22 AM

Hello,

I have problem with the Soundblaster X-Fi XtremeGamer edition.

The problem might be fairly simple, but i dont know how to setup settings correctly.

The problem is that the sound goes between default output device and spdif out.

For example. if i open more than one sound source eg. game, teamspeak, music one of the sound sources will go to spdif, which i dont want.

I tried to disable spdif, but the sound still finds the way inside the spdif, even if it's disabled. ( you don't hear the sound, but if you enable spdif you will see the sound meters which are moving inside the spdif )

How im able to direct sound sources only for one (default x-fi XtremeGamer) output device and not for spdif at all.

Im running latest sblaster drivers and tried to reinstall those multiple times.

I would appreciate if someone could help me with this, because i have tried like eveything so far.
August 22, 2012 11:54:49 AM

Try the Daniel_K or PAX driver sets. Ditch the official driver.
August 22, 2012 2:18:38 PM

Are you using the S/PDIF connection on the sound card or the motherboard's S/PDIF?
Is the on-board sound turned off, in the bios?
August 22, 2012 10:46:58 PM

On-board sound device is disabled from bios. I will try those drivers as suggested in the first reply.
!