Sign in with
Sign up | Sign in
Your question

[Solved] DirectX 9.03c issues - can't run games

Last response: in Graphics & Displays
Share
March 2, 2012 9:20:45 PM

Games (Deus Ex: Human Revolution, GTA IV) are reporting that my graphics card (An Asus EAH6950 DCII/2DI4S/1GD5) does not support DirectX9.0c 3D Acceleration. I was previously able to play these games and others without issue on this same machine.

The error reads: "This game requires a DirectX9.0c capable graphics card. Your card or driver does not support DirectX9.0c 3D Acceleration."


Attempted fixes:

- Run the DirectX Diagnostic Tool. It shows my DirectX version as DirectX 11, although under "DirectX Features" on the Display 1 tab it shows DirectDraw, Direct3D and AGP Texture Acceleration as 'Not Available'.

- Installed the DirectX June 2010 SDK update (directx_Jun2010_redist)

- Installed the DirectX Runtime Components (dxwebsetup)

- Uninstalled my graphics card drivers, run Driver Sweeper to remove the remnants, then installed the Catalyst 12.2 Pre-Certified Driver.

- Upgraded my SSD firmware to the latest version (0309)

- Run "SFC /SCANNOW" to see if there were any corrupted system files (there weren't)

- Run MSE and Spybot scans (both negative)


What's weird is that installing new drivers works initially, but on the next reboot, the problem reoccurs. I shouldn't have to reinstall drivers every time I want to play a game!



Recent changes:
Other than Windows Updates and installing Filezilla client, no software changes. No hardware changes at all.

Operating system:
Windows 7 Home Premium 64-bit. Version 6.1 Build 7601: Service Pack 1.

System specs:
Intel Core i5 2500, Gigabyte Z68XP-UD4 MB, G.Skill 8GB (2x4GB) DDR3 RAM, Crucial m4 256GB SSD, Asus Radeon HD6950 (EAH6950DCII2DI4S1GD5)
a b U Graphics card
March 2, 2012 9:44:43 PM

Do you have Cat. Contrl. Center. working? If it is what are the settings under the 3d tab?
m
0
l
March 2, 2012 10:03:50 PM

Dogsnake said:
Do you have Cat. Contrl. Center. working? If it is what are the settings under the 3d tab?


Unfortunately not. I can open it, but it's not displaying properly. I can click randomly down buttons on the left side but am not sure where the 3D tab would be.

http://i.imgur.com/k5tET.png
m
0
l
Related resources
a b U Graphics card
March 2, 2012 10:47:49 PM

Install (http://www.microsoft.com/download/en/details.aspx?id=17...) .netframe4. It is required for ccc to work properly. This is a first suggestion. Let's see what happens next. I think the fact that cc is either corrupted or disabled is the source of your problem. When you reboot it starts automatically hence the problem on restart. You can disable it by going into msconfig. and UN-checking it's box. After you run .net 4 select either install or repair then you will have to re-install ccc.
m
0
l
March 3, 2012 12:53:53 AM

Dogsnake said:
Install (http://www.microsoft.com/download/en/details.aspx?id=17...) .netframe4. It is required for ccc to work properly. This is a first suggestion. Let's see what happens next. I think the fact that cc is either corrupted or disabled is the source of your problem. When you reboot it starts automatically hence the problem on restart. You can disable it by going into msconfig. and UN-checking it's box. After you run .net 4 select either install or repair then you will have to re-install ccc.


I installed .net 4 and then re-installed CCC, but it's still not displaying properly. Perhaps I should install an earlier version?

EDIT: I restored to an earlier system restore point, uninstalled/reinstalled and have CCC open now. Under Gaming: 3d Application Setings it looks as if I have them on the default values.

EDIT 2: After a reboot CCC stopped working again.
m
0
l
a b U Graphics card
March 3, 2012 2:14:06 AM

Ok, for a test, you can un-install ccc by running the driver install program and selecting un-install. Select only ccc to remove. Re-boot and see if it works.
m
0
l
March 3, 2012 2:23:54 AM

Dogsnake said:
Ok, for a test, you can un-install ccc by running the driver install program and selecting un-install. Select only ccc to remove. Re-boot and see if it works.


Done, still no joy.

EDIT: Heading out for the night. Will try out any new ideas tomorrow. Thanks for your help so far, Dogsnake.
m
0
l
March 3, 2012 8:40:40 PM

Hey, finally solved this issue. I ran CCleaner, uninstalled my graphics card drivers and then reinstalled version 12.1 (rather than 12.2). I've restarted three times, and ever time Deus Ex: HR and GTA IV loaded up fine - that error message didnt' appear.

Of course, now Deux Ex crashes where before it ran smoothly, but that's probably a settings issue or something.

Dogsnake, thanks so much for your help here.
m
0
l
a b U Graphics card
March 3, 2012 9:22:57 PM

YW glad things worked out.
m
0
l
!