Sign in with
Sign up | Sign in
Your question

Dell XPS8300 - memory upgrade odd behavior

Tags:
  • Prebuilt
  • Memory
  • Dell
  • Memory Upgrade
  • Systems
Last response: in Systems
Share
May 7, 2012 3:04:09 AM

Hi ... I upgraded the memory in my new Dell XPS8300: i7-2600, Windows 7 home premium, Microsoft office 2010, AMD6450 graphics
FROM: 4x2GB Kingston dual channel DDR3 1333 PC3-10600U-9-10-A0 #K1N7HK-ELC 9995402-051.A00G (apparently dell only)
TO: 4x4GB Corsair dual channel DDR3 1333 DDR3-1333 (PC3-10666) 9-9-9-24 latency #CMX8GX3M2A1333C9

For the most part the system has worked fine BUT on a couple of intermittent occasions when the system goes into hibernate (either by itself automatically after an hour idle or when I briefly tap the on-off button), when it comes out of hibernation I have gotten a few error messages:
1. a "blue screen" with the message "Your system's firmware did not preserve the system memory map across the hibernation transition. If you proceed with resume, your system could behave in an unpredictable manner after resume completes" with a choice of "normal" "or "safe mode" - have just let it resume ("normal" I assume)
2. Windows message box - "Windows Application Error The instruction at 0x77b3324e referenced memory at 0cffffffff. The memory could not be read. Click OK to terminate the program" Microsoft Outlook 2010 was the only "visible" application that had been running

So ... three questions: did I install "incorrect" memory and/or do I need to do something to resize the hibernate file or do something else?

The system seems to recognize the new memory when I do "my computer" - properties: Installed Memory (RAM): 16GB
However when I attempted to run Dell diagnostics, it "failed" several of the memory tests and crashed during one of the memory tests ... unfortunately it happened quickly and I did not get to write them down and have not rerun the tests. It has not acted odd recently, however I have not left any applications open during hibernation either.

Any suggestions? Thanks

More about : dell xps8300 memory upgrade odd behavior

a b } Memory
May 7, 2012 3:25:59 AM

It is my guess that one of the 4GB Corsair sticks is probably flawed.

If that is the case, you could use the computer all day long until such a point in time as the computer tried to use the bad area on the bad stick. Stability problems would likely occur if your computer did tried to use the bad area on the bad stick.

Anyway, my suggestion to you would be to download a program called Memtest86+ (that + is important) and take out all the sticks except 1 in slot 1 and then start the computer up with the MemTest CD in the drive and let it do the RAM tests on the 1 remaining stick.

Once that is done (probably 4 hours) then switch to the next stick and repeat the process until you get through all of them.

If each stick came up clean with no errors, then its possible there is a bad slot on the motherboard. If they all come back with errors then its possible slot 1 is a bad slot.

Anyway, trial and error with the program mentioned is probably your best bet at this point.

It would be best to stick to 1 stick at a time to help control variables.

As for having "correct" RAM or not, it looks fine, but Corsair has the highest failure rates of any of the major RAM makers so it really depends on where you draw the line. Assuming all the sticks don't fail out of the box, there shouldn't be anything necessarily incorrect about it. That could quite easily be a faulty assumption, though, if my theory is correct.

There is nothing you would need to do in regards to the hibernate file, I wouldn't change any settings in regards to that.
m
0
l
May 9, 2012 12:30:14 AM

Also, run a tool like cpuz (from cpuid, google it) to check what frequency and latencies got set. There are multiple JEDECs specified on that memory (I think), you can see them. Go into BIOS and ensure you are running at 1.5V. Then set some of the looser timings and see if everything stabilizes.

Good idea running Memtest86+.

Memory is really tough to test. The memory test programs walk through memory trying to create all the opportunities for fail, but they can only really prove you have a problem. If they run cleanly they cannot prove you don't have a problem. http://digitalelectronics.blogspot.com/2009/01/memories...
m
0
l
Related resources
May 9, 2012 1:14:59 PM

an update ... I removed the Cosair memory (4x4GB) for the time being and reinstalled the original Dell/Kingston memory (4x2GB) and re-ran the Dell system diagnostics tests (includes about 10 memory tests) - all passed (in contrast to most failing when run with the Corsair memory), no problems now, system now seems to be stable. So for the moment, I am sort of left to conclude that there is something wrong with 1 or more of the Corsair menory sticks or there are setting mis-marches - I just don't know which.

I down loaded memtest86+ as suggested with the intent of runnig it on the Corsair sticks as suggested, however I have not been able to sucessfully burn a bootable memtest86+ CD/DVD with my nero9 software (seems that it just hangs up when I select the bootable choices and put in a blank CD or DVD - its odd because if I goto the burn a regular data CD/DVD it works just fine other than the CD/DVD is not bootable)

Thanks for all of your help and suggestions ... hopefully I will figure out a way to get a bootable memtest86+ CD/dvd ... I am going to try burning it on another computer and if that works, then run the memtest86+ tests on the Corsair memory one stick at a time as suggested.
m
0
l
May 16, 2012 4:14:06 PM

Another update ...
I was able to download ImgBurn and was able to burn the Memtest86+ iso CD with no problem. After rearranging the boot sequence (figured that one out after the PC still booted from the HD), I was able to run Memtest86+ ... here are the results:
1. Using the Dell/Kingston 4x2GB memory sticks - Memtest86+ ran with no errors after 6 passes ... I did this to sort of benchmark the Dell/Kingston memory AND to verify the system board did not have any issues (assuming the memory checked out OK).
2. Removed all to the Dell/Kingston memory and tested the Corsair memory 1 stick (1x4GB) at a time (as suggested) in slot#1 (slots are numbered #1 to #4). For the first 3 Corsair sticks, Memtest86+ ran with no errors after about 7 passes each. However using the 4th Corsair stick, the PC would not even boot, so my conclusion is that there is something definitely wrong with this stick.
3. Just to verify that Corsair sticks (2x4GB) 1 and 2 (they ship in co-numbered pairs) worked OK together, I reran Memtest86+ using both of them in slots #1 and #2. Memtest86+ ran with no errors after about 4 passes.
4. Just for grins, I removed Corsair sticks (2x4GB) 1 and 2, replacing them with Corsair sticks (2x4GB) 3 and 4 (4 being the "bad" one) in slots #1 and #2 respectively (I wanted to see if the PC would boot so I put the "good" one in slot #1). Errors started scrolling by immediately after booting ... over 38,000 in just a few seconds. So definitely something wrong with #4 and since they come in co-numbered pairs, this pair definitely needs to be exchanged.
5. So I reinstalled Corsair sticks (2x4GB) 1 and 2 (the "good" sticks) in slots #1 and #2 and then ran the Dell Diagnostics test (powered by PC-Doctor). The Corsair memory (sticks 1 and 2) passed 11 of the 12 memory tests but failed the "advanced pattern test" with 3 errors on one run of the test and 6 errors on a 2nd run of the test. While each error showed different addresses locations, the error message was generally like this: “Memory read-write error at physical address 00000000363871C0H. Wrote pattern 20202020H, read back pattern 20202420H” (note the "20" write and the "24" read). So now I am puzzled if there is in fact something wrong with Corsair sticks 1 and 2 (the supposed "good" ones from the Memtest86+ test) or if this might be a "timing" issue (I have never dealt with memory timing before).

I really appreciate all of your help and look forward to any other thoughts/suggestions you may have.

Thanks, Ken
m
0
l
May 17, 2012 12:19:19 AM

Use a tool like CPUZ from CPUID (google it, download from reputable site) to see memory timings you are using they are on the memory tab. Compare them to the rated timings of the memory. There are several rated timings, they show on the SPD tab. Then verify in BIOS that mem voltage is set at 1.5v. Having two failing sticks out of four is unexpected.
m
0
l
a b } Memory
May 17, 2012 5:01:19 PM

There are 10 passes that each do different tests. If you stop at pass 7 there is no way to know if pass 8 would have revealed flaws or not.

In any event, the "matching" of the pairs is meaningless.

I would take #3 out and take one of either #1 or 2 and see if you get no errors. If you get errors then switch to the other of 1 or 2.

If you can get to a point where you never get any errors with any other program using 2 sticks, then seal up the other 2 and send them back to Corsair for new ones. They won't know the difference.

Two out of four being flawed is unusual, but this is Corsair we are talking about. They are the major manufacturer with the worst quality so statistically it is likely to happen to somebody eventually.
m
0
l
!