Sign in with
Sign up | Sign in
Your question

MiniDP to DVI Active Adapter | Issues | DisplayLink Failure

Last response: in Graphics & Displays
Share
March 3, 2012 1:54:44 AM

I'm attempting to connect (3) 30'' monitors (at 2550x1600 max resolution) to an XFX HD5950 Black Edition Limited video card.

I have 3 Accell Active MiniDP to DVI converters. While it worked for the first 5 minutes at max resolution on all 3 monitors... when I attempt to essentially tax the video card as a test (play an HD film clip), the system collapses, reporting a "DisplayLink Failure" error message OR blacked out screens, with one screen coming back online at lower resolution, or not at all. I reproduced similar behavior with only 2 monitors connected, but it actually managed to play a few HD clips without blacking out or flickering - suggesting the 3rd monitor is taxing the card too much?

At one point I also got a "DisplayPort Low Power Error" message as well. Searches around the web have demonstrated that this is an established issue... though I haven't seen any actual solutions. Not only that, but I'm very perplexed (not to mention frustrated and worried) that I am even using AMD-stamped Accell adaptors which are designed for this very purpose...

I have attempted:

1. Restarting the machine (this allows me to get the monitor(s) to come back on with the error message, but doesn't 'fix' the problem.

2. Moving the USB power cables for the Accell adaptors to different USB ports (MoBo is EVGA X58 SLi 3x) believing it was a power-related issue with low/high power USB ports - I then used wall power USB connectors to power 2/3 adapters, and the issues did not seem to resolve completely...

3. Connecting the MiniDP adaptors to different ports on the video card, which has 6 total for so-called Eyefinity.

4. Ensured the graphics card is in the x16 PCI slot.

5. Temperatures are all far below even normal idle, and the CPU/SB is liquid cooled and not overclocked (yet).

6. I have noticed that 1 of my 3 adapters has different firmware than the other 2... though this hasn't allowed me to do any testing since the problems seem to revolve around using MULTIPLE monitors, whereas using 1 monitor doesn't seem to reproduce the issues - does this suggest a video card problem... with the card simply unable to drive (3) 30'' displays at dual-link DVI via MiniDP?
----


I have realized that Accell posted a firmware upgrade on their website, but according to many in the forums this firmware has NOT resolved this issue. ATI claims that "with our approved active adapters, there should be no limitation to Eyefinity configurations (even if you use DVI-monitors)." The card furthermore... is designed to run in principle, (6!) 30'' monitors at full resolution.


I'm not sure what else I should be looking at... I hope my almost $5000 worth of gpu and monitors... are not useless...

If anyone has any suggestions... they'd be much appreciated.
March 4, 2012 2:02:33 PM

I had this issue as well trying to connect two 30'' monitors - I'm pretty sure the problem were the adapters.

I don't have the same ridiculously overpriced (but yes limited edition...) gfx card, but I do have the Eyefinity 6 one, which has miniDP.

I never tried Accell firmware since I was getting two more 30'' monitors anyway, and I got them with miniDP inputs - when I connected them mDP to mDP there were, predictably, no issues, which is why I blame the adapters, and maybe, but not likely, the dual link DVI cables.

You ARE using DUAL LINK DVI cables right? (they have a thicker caliber than single... and also say 'dual link' stamped on the cable).

I don't think it's a power issue - esp if you used wall power (though it might be important to check the amperage of those wall-power slots, since not all usb wall power is created equal...) But since I've heard people using them right on the mobo usb, I doubt that's the issue.

It's possible that your connectors aren't well seated. Check the contacts between the miniDP adapter and the gfx card. if the adapter isn't properly in contact with the card, then you could be getting DP port fail errors, or flickering.

Personally, allowing for the firmware thing from Accell... I feel like this could be driver related, the fact that you have such a rare video card makes it difficult to know though whether others are having the same issues... unless your card is just an OC of the reference eyefinity 6 card, I don't know.
March 4, 2012 2:13:00 PM

Thanks for replying - I've been on forums on several sites and haven't found any good solution to this - there are those saying that even after the firmware upgrade (which I believe one of my adapters actually has already since I purchased it a few months ago, and it has a FW sticker on it more recent from the other two...

I am using all DUAL LINK DVI cables, and I did check the USB power - they're iPhone chargers, which I think are 1A, which is more than enough for USB powered devices.

1. I don't think there's anything wrong with the contacts - the adapters pull on the wires a little bit, so I put them on a box to see if that was the problem, but it didn't fix anything.

2. Just to add some information - I tried using only 2 monitors, and while it's definitely more stable, when I play the same HD film clip there's a lot of flickering and the like - though I did NOT receive the DisplayPort Link Failure error message so far when testing with only 2 monitors, so clearly, having the 3rd one just makes it worse...

3. I have the latest Catalyst Control Center (AMD drivers), and I don't think it should matter that my card is different... as far as I know as you said, it's just a fancier version of the Eyefinity 6 card and uses the same drivers as well I believe?

4. I'll get the firmware on Monday (hopefully Accell will give it to me) but I have this suspicion that it's not going to make it work...
!