Sign in with
Sign up | Sign in
Your question

Just got a ASUS Xonar DG

Last response: in Components
Share
Anonymous
August 23, 2012 2:50:16 PM

And so far I have had no luck with it.

I can hear a faint static noise but other than that there's no sound, I tried testing the microphone and had no luck there either. The software has detected the card is there and so has the operating system, and whenever I change the analog out setting I can hear a click coming from the card which is kind of reassuring.

I have disabled the onboard sound and I am sure I'm using the right jacks for this headset also. I even went to ASUS and found the latest drivers from them.

If anyone has any idea on how to fix this, then feel free to say.

More about : asus xonar

August 23, 2012 3:06:20 PM

If you disabled the onboard sound without uninstalling the drivers the Windows Audio stack may still think that it's installed. Go to the Windows Audio panel -> playback devices and scroll down until you see Speakers. The speakers should say something along the lines of "Asus Xonar". Right click on the Speakers device and select "Set as Default device" and "set as default communications device"

You may also want to configure the speakers to set them up properly for your sound setup.
Anonymous
August 23, 2012 3:20:33 PM

Pinhedd said:
If you disabled the onboard sound without uninstalling the drivers the Windows Audio stack may still think that it's installed. Go to the Windows Audio panel -> playback devices and scroll down until you see Speakers. The speakers should say something along the lines of "Asus Xonar". Right click on the Speakers device and select "Set as Default device" and "set as default communications device"

You may also want to configure the speakers to set them up properly for your sound setup.


Thanks for the reply man!

I have disabled the drivers so it saves the hassle of having to install them again if this sound card fails.

When I looked at the devices screen it turns out the Xonar card was set to default for both the speakers and the headphones. And trying the configure option didn't work either, when it tested for sound nothing through.
Related resources
August 23, 2012 3:26:15 PM

Quote:
Thanks for the reply man!

I have disabled the drivers so it saves the hassle of having to install them again if this sound card fails.

When I looked at the devices screen it turns out the Xonar card was set to default for both the speakers and the headphones. And trying the configure option didn't work either, when it tested for sound nothing through.


Strange. I would recommend completely removing the drivers rather than disabling them. There's a lot that can go wrong there

If you want to test another way try using an Ubuntu Linux LiveCD. The Generic HD audio drivers in the upstream kernel should work

Also make sure that the volume on your headphones isn't turned all the way down, I've made that mistake a few times
August 23, 2012 3:56:57 PM

Defective card? The clicking indicates that the relays on the card are switching on, which is what the card is supposed to do. But theres no reason you should be getting static out...

You using the headphone port, or the stereo output port?
August 23, 2012 4:48:52 PM

gamerk316 said:
Defective card? The clicking indicates that the relays on the card are switching on, which is what the card is supposed to do. But theres no reason you should be getting static out...

You using the headphone port, or the stereo output port?


If there's a short in there somewhere the static could be line noise that's getting amplified.
August 23, 2012 6:21:49 PM

This happened to me, i'm using a xonar d2x. I was freaking out as I thought it was a duff card.

Turns out it was simply that i was using the wrong settings fotr the audio.

for headphones try these settings

Audio channels : 8 Channels
Sample rate: PCM 96 KHz
Analog Out : Headphone
SPDIF : unchecked
Dolby headphone : your preference.
PCM
August 23, 2012 7:02:11 PM

Doh, yeah, check the Sample Rate. Some devices can't handle 192KHz audio (some old one can't even handle 96KHz). That could be the issue.
Anonymous
August 23, 2012 7:49:35 PM

Just booting into Ubuntu now to see if it'll work. Tried the settings you mentioned littlebloke and they didn't work :( 

Having a feeling that the card I was sent is defective though.
!