Slow browsing, high download speeds?

My computer is browsing the web EXTREMELY slow (takes minutes just for Google to load). At first I thought my download speeds were slow, but I have a download speed of 12.41 Mbps. I know it can't be my network speed because 12 Mbps is pretty fast, and it takes a long time just for local web pages to load! This happens on all web browsers and it's only on my computer (everyone's computers are browsing fast, except mine).


P.S. I don't have any torrent application seeding.
7 answers Last reply
More about slow browsing high download speeds
  1. How old is your computer? What's your specs?
  2. ehcanadian said:
    How old is your computer? What's your specs?

    A few months old.

    i5-2500K stock speeds
    Radeon HD 6870
    8GB RAM
    Asus P8Z68-LX mobo.
  3. Oooh then it can't be the hardware. I'm assuming this didn't happen at first? Probably has to do with some new software. Installed something new?

    Did a proper virus scan and everything?

    By network and download speed, do you mean that's the speed your provider is supposed to give you... or that's how much you're actually downloading at?

    I usually get fed up and reformat everything, but that would be the absolute last thing.
  4. ehcanadian said:
    Oooh then it can't be the hardware. I'm assuming this didn't happen at first? Probably has to do with some new software. Installed something new?

    Did a proper virus scan and everything?

    By network and download speed, do you mean that's the speed your provider is supposed to give you... or that's how much you're actually downloading at?

    I usually get fed up and reformat everything, but that would be the absolute last thing.

    12 Mbps is what I'm actually downloading at (tested at speedtest.net). I just ran Avast and it didn't come up with anything. I don't remember installing anything new.
  5. Try tweaking TCP settings.


    http://www.speedguide.net/downloads.php


    Find your speed at speedtest.net
  6. I fixed it, guys. Well, it kind of fixed itself. I restarted my computer and my browsing speed's back to normal... Weird.
  7. xspectrum said:
    I fixed it, guys. Well, it kind of fixed itself. I restarted my computer and my browsing speed's back to normal... Weird.



    Yeah, a restart usually fixes most problems. You can still try optimizing your TCP settings and see if your browsing speed feels any faster.
Ask a new question

Read More

New Build Download Computer Systems