Urgent HELP NEEDED: CPU Throttling During Gaming/BenchMarking

Please take your time to read all of this thread.

Hello, I have just purchased and built my very first gaming rig, but I have recently been having a problem. When I play games or I decide to benchmark my PC my PC down throttles itself down from 4.3Ghz to 1.6 ghz therefore I get much lower and very inconsistent FPS, this makes benchmarking and gaming a nightmare.

My PC rigs specs are as follows:

GPU: Gigabyte GeForce GTX 670 WindForce x3

MotherBoard: ASRock Z77 Extreme4

Case: Zalman Z11 Plus

CPU: Intel i5 3570k @ 4.3ghz

CPU Cooler: Cooler Master Hyper 212 Evo

Optical Drive: Sony AD-7280S

RAM: Corsair 8gb DDR3 @ 1600mhz

HDD: Western Digital Caviar Black 1TB

SSD: Samsung 830 series 128gb

PSU: Corsair CMPSU-750TXV2UK Enthusiast (750 W)

OS: Windows 7 64bit

Resolution: 1980x1080

Basically my my problem is that when I set multipliers to 43 with all cores enabled in the bios, I cannot turn off intel turbo boost (which after some research has suggested to me that is causing the down throttling to occur). The option simply just skips past, meaning I cannot disable to option. I have attempted to disable to option beforehand but it defaults back as soon as I set the cpu ratio from auto to all cores.

I have ran prime 95 tests for 1 hour and the max temperature I was getting was 68 degrees Celsius.

I would gladly appreciate help in turning off turbo boost while allowing me to change multipliers or to fix the down throttling.

I ran heaven benchmark at max settings and only recorded a 40 fps on 1080p, I was expecting much more with my GPU (I was expecting high 70's) after some research I determined that the CPU was down throttling itself to 1600 Mhz during testing which bottlenecked the GPU.

Thanks.
10 answers Last reply
More about urgent needed throttling gaming benchmarking
  1. SpeedStep, but just use the High Performance power plan in Windows to lock in max speed while you're gaming and benching.

    Control Panel -> Power Options and select High Performance. When you're done, just set it back to Balanced to let it idle correctly.
  2. So you are suggesting I should disable speedstep?
  3. HyperBlue said:
    So you are suggesting I should disable speedstep?


    No. Leave it enabled.

    Just do what I said above. It effectively disables SpeedStep in and of itself, with the added bonus of not having to go back into the BIOS to re-enable it when you're done gaming.

    SpeedStep is a good thing...
  4. Well I got it to constantly run at 4.3ghz even on idle but I am still getting only 40 fps on heaven, there seems to be a serious problem here.
  5. HyperBlue said:
    Well I got it to constantly run at 4.3ghz even on idle but I am still getting only 40 fps on heaven, there seems to be a serious problem here.


    Yeah, to be honest, I didn't really think SpeedStep (or lower speeds) had anything to do with it. That was just to be sure.

    I'd say there may be a driver/software issue (although I'll admit that I have no idea what a good Heaven bench is for that GPU at that res, so I honestly don't know if there even is a problem).
  6. I may have a go at over clocking my GPU seeing as I get a cool 40 degrees 100% load in heaven on my GPU, thanks for the help
  7. You're welcome. :)
  8. hello guys! Do u think this program "ThrottleStop"will help me with my cpu and gpu...in one word,will help my laptop to not have anymore that fps drops?? I have an Acer Aspire E1-531G,Intel dual-core B960 at 2,2 Ghz,8 Gb of ram and NVidia GeForce 710M with 2 gb VRAM,Windows 7 Ultimate 64 bits! So what do u think,it will help me,or not!I can play with this laptop a few good games,but in some of them i have this damn fps drops,specially in Assassin's Creed 4 Black Flag!!???
Ask a new question

Read More

CPUs Gaming