Sabertooth z77 and Saphire 7970 OC problem

hi, this is my first time using these forums and i'm not sure if this is the right spot for this. I have the above components in a new build (my first build) and on boot the BOOT led lights up and nothing is displayed by the 7970. I know its not the mobo's fault as it works with other cards. Is my 7970 DOA?

EDIT: I thought i'd post the rest of my build if that could help.

PSU: Fatal1ty 750w
Graphics Card: Saphire 7970 OC Edition
CPU: i7-2600k @ stock speed
Ram: 4gb DDR3 Ram (bought 12 gb but 8 of it isn't compatible :( )
mobo: Asus Sabertooth z77
HDD: 2 (1 1000gb and 1 750gb)

I have also tried everything on the sticky about troubleshooting.
7 answers Last reply
More about sabertooth saphire 7970 problem
  1. you might have to switch to a difference bios for the mobo

    did you do everything right?
    like getting the latest updates for everything
    installing the pins to the right slot?
    read the manual for the mobo?
  2. FinneousPJ said:

    Check my edit (had already read it before I posted it) :D
  3. boulbox said:
    you might have to switch to a difference bios for the mobo

    did you do everything right?
    like getting the latest updates for everything
    installing the pins to the right slot?
    read the manual for the mobo?

    How would I change the bios on the mobo? And I dont have windows installed yet.
  4. camdat said:

    Ram: 4gb DDR3 Ram (bought 12 gb but 8 of it isn't compatible :( )


    Wait, how did you get 12GB of RAM? I thought 12GB is only to be used with triple-channel platform (X58)?

    Assuming that you fit a triple channel RAM into your board, that may explain why it isn't booting.
  5. eddieroolz said:
    Wait, how did you get 12GB of RAM? I thought 12GB is only to be used with triple-channel platform (X58)?

    Assuming that you fit a triple channel RAM into your board, that may explain why it isn't booting.

    I've tried with only one stick of ram and it was 4 sticks of ram (totaling 12gb) only 2 of the sticks worked (different brands).
  6. camdat said:
    I've tried with only one stick of ram and it was 4 sticks of ram (totaling 12gb) only 2 of the sticks worked (different brands).


    Oh okay, makes sense, thanks.
Ask a new question

Read More

New Build Systems