Sign in with
Sign up | Sign in
Your question

Corsair Vengeance 1500 Headphones Drivers won't install...

Last response: in Windows 8
Share
March 22, 2012 8:04:42 AM

Ok, so I just got home with the vengeance 1500 headphones and when I try to install the 1.1 drivers it opens the install window and runs a bunch of commands and then disappears. If I try running in XP SP3 compatability mode it actually gets past that and starts an install bar but freezes 3/4 through. There is nothing in the app tray when I search for the program windows come up with nothing. I'm not sure of a way to check and see if they installed and the app with the equalizer functions is nowhere to be found. Could it be a problem with windows 8? I REALLY don't wanna roll back to 7! Any ideas?? The headset works fine but I read over and over that the difference in sound quality is huge... help!
Thx in advance
March 22, 2012 8:23:47 AM

Using an operating system in beta is hit and miss. It is as simple as that. If various compatibility modes does not help. You are probably stuck waiting for them to release a version prepared for windows 8.
m
0
l
March 22, 2012 9:33:53 AM

Hoping someone who sees this has had different luck... think it might be possible because windows7 and vista compatibility mode appear to have the same result as windows 8.
m
0
l
Related resources
March 31, 2012 7:02:45 AM

ok so i had the same issue and tried running it in windows 7 compatability mode, but it wouldnt install. I just used the windows 8 trouble shooter and got lucky.
m
0
l
March 31, 2012 11:47:14 AM

try to run the installer as an adminstrator and use windows vista SP2 compability mode worked for me. :) 
m
0
l
December 4, 2012 4:54:22 AM

robo26 said:
unzip the install file using some thing like 7zip, then run the setup file in win7 compatibility mode and it should work, it did for me. got this idea from http://forum.corsair.com/v3/showthread.php?p=607868

Yep, just googled this problem tonight and tried that solution and it worked :D  Thanks to you and the guy on the corsair forums :D 
m
0
l
January 26, 2013 3:14:49 PM

robo26 said:
unzip the install file using some thing like 7zip, then run the setup file in win7 compatibility mode and it should work, it did for me. got this idea from http://forum.corsair.com/v3/showthread.php?p=607868


Thank you for mentioning this. Btw, I had to go into the USB112-110929-8.2150(W7-ER)WHQL folder and install in compatibility mode from there, but it did work. It was getting to me that Corsair wasn't bothering to update their driver.
m
0
l
!