Sign in with
Sign up | Sign in
Your question
Solved

Which version

Last response: in Graphics & Displays
Share
March 10, 2012 11:19:06 AM

This is my first post here so please forgive any mistakes.I have a msi radeon hd 6950 2gb twin froz11 GC and my question is this. I was using the 12.1 drivers in skyrim and was getting quite a lot of CTD, my computer was being hissy and I ended up with driver version 8.850.0.0 which is running skyrim a lot better. but which version is this is it 11.10,11.12 or before those 2, I know its a year old.thanks in advance

More about : version

Best solution

March 10, 2012 11:36:08 AM

Hi,

Welcome to the forums. Driver version 8.850.0.0 is Catalyst 11.5


Mactronix :) 
Share
March 10, 2012 11:55:58 AM

Thanks for your reply I'm surprised the older version is working better than the new ones, in skyrim it auto-detected my card and put it up to ultra when in the newer version it was on high.
m
0
l
Related resources
March 10, 2012 12:00:18 PM

You get this sometimes with AMD drivers. I am running 11.8 at the moment with no issues in skyrim. Generally I wont update the drivers unless there is a really good reason to do so.
Don't know if you have this link or not, you may find it useful. http://support.amd.com/us/gpudownload/windows/previous/...


Mactronix :) 
m
0
l
March 10, 2012 12:10:03 PM

I had a lot of trouble going back to a previous driver, my screen went black and the words were in green I could hardly see them.In the end I managed to get into device manager/6900series/properties/driver and click on one of the drivers there, bit lucky I think. Do not have the catalyst software installed now, as its running smoothly would not like to mess it up.
m
0
l
March 10, 2012 12:20:52 PM

Nothing wrong with that. I have on occasion just used the driver on its own. If you do decide to try an update any time then I have always used the Uninstall package that will be included with any Catalyst driver download.

For now though I fully agree if it is not broken don't try and fix it ;) 

Mactronix :) 
m
0
l
March 10, 2012 1:30:24 PM

That link you gave me to the drivers it says its for windows vista, I'm using windows 7 32 bit are they the same.thanks
m
0
l
March 10, 2012 1:51:53 PM

Ah sorry my bad, no they wont be compatible as they are also 64 bit versions. I tried to find the version for you but teh server is down at the moment.
Again apologies for my mistake. And well spotted.

Mactronix :) 

m
0
l
March 10, 2012 2:09:50 PM

no worries thanks for trying :) 
m
0
l
March 17, 2012 7:23:48 AM

Best answer selected by larryddd.
m
0
l
!