Sign in with
Sign up | Sign in
Your question

Guild Wars 2 shocking performance from high spec machine

Last response: in Components
Share
August 30, 2012 8:01:25 PM

Hi Guys

Recently I bought Guild Wars 2 and was shocked to find that I could not reach a framerate above 30fps on the lowest settings possible. I don't know why this is happening since my specs are apparently far above what is required to max this game out and in the past I could obtain a healthy 60fps with games much more intensive such as BF3 and Skyrim.

MY SPECS

CPU i52500K (stock clocks)
GPU gigabyte wind force gtx 670 OC edition
mobo ASUS P8Z77-V LX
RAM 8Gb DDR3

current nividia driver 304.79 (as recommended by game)

Any idea whats going on and what I should do.

Thanks in advance for any help
August 30, 2012 8:05:14 PM

Might be a weird driver problem? Games do tend to have a few such bugs at release.
August 30, 2012 11:05:23 PM

Thanks have updated mobo bios which seems to have improved things a little must be optimization problems.
Related resources
August 31, 2012 12:44:16 AM

What resolution are you playing at? I've also heard that the 304 drivers are junk, try the new betas.
August 31, 2012 9:50:48 AM

1920*1090 which beta drivers are you using?
August 31, 2012 2:44:45 PM

euansharp said:
1920*1090 which beta drivers are you using?


I'm using AMD GPUs but I have a couple of guildmates who have NVidia 500 and 600 series GPUs who said that the performance was less than desirable on the 304 drivers, try 306
September 3, 2012 9:51:22 PM

Hmm have tried 306 and now get around 30 to 40 fps on the lowest possible settings which is pathetic for a gtx 670 but what is really interesting is my gpu usage which stubbornly sits at around 10 to 20 percent according to afterburner. Why on earth is my gpu being so damn lazy with this game. Any ideas how I could make the card recognize the load of GW2?
September 3, 2012 9:52:39 PM

I think it might be a problem with GW2.
September 3, 2012 9:57:34 PM

amuffin said:
I think it might be a problem with GW2.


I completely agree with that. A lot of people seem to be having various issues with GW2, from what I've seen the past few days.
September 3, 2012 10:21:14 PM

Hope so is this pretty common at the moment?
September 3, 2012 10:34:57 PM

euansharp said:
Hope so is this pretty common at the moment?


Not sure how common it is overall, but I've seen issues with GW2 around here, at least, for the past few days.
September 3, 2012 11:00:11 PM

euansharp said:
Hope so is this pretty common at the moment?


It's an online game, they always have framerate issues. Trust me on this
September 4, 2012 3:28:10 PM

Just checked toms hardware on what the card should be putting out, it claims I should receive around 50-70 fps that seems pretty off to me. Have Anet even acknowledged this crap or is it nividia's problem.
September 4, 2012 4:41:12 PM

euansharp said:
Just checked toms hardware on what the card should be putting out, it claims I should receive around 50-70 fps that seems pretty off to me. Have Anet even acknowledged this crap or is it nividia's problem.


Tom's benchmark is rather idealistic and was taken before the game went gold which means it was during a beta or prerelease. With more people everything will be laggier. Even my 7970s get slow
!