Problem, GPU or PSU dying?

So I'm having a problem with my system...
A few days ago my system started showing unstable behavior under heavy graphical load. I could start a game, play it for maybe a minute and then my system would just reboot. I could reproduce the reboot every time in one game, all it required was a bit of strain from the GPU.

This said initially I pretty much suspected the GPU. However to narrow it down (and since games use a lot of memory) I checked my memory modules, took them all out and tested them one by one. No help, the problem still manifested itself. Next I reset my BIOS since I had set some manual memory settings, just to be sure. Didn't help. I checked my CPU and GPU temperatures, they were both steady at around 45C when the reboots happened. The next thing I did was underclocking my GPU. After tuning it down enough the rebooting started happening later, when there was much going on in the game and heavier graphical load. Finally I swapped the GPU to an older one and the problem disappeared completely.

Rebooting seems a strange way to crash if the problem lies in the GPU though. There's nothing in the Windows event logs either - it's like a complete power loss when it happens and the computer just reboots. This makes me wonder if it's the power supply that's giving up. After all after switching to an older GPU with less power consumption the problem disappears. I'd also expect seeing something in the event logs if it was the GPU failing. Both the GPU and the PSU are barely 7 months old, feels odd that they'd give up so fast but it happens I guess.

My system specs are:
Q6600 @2.4GHz (overclocked to 3.0GHz)
ASUS P5QL Pro
6GB RAM (Kingston)
Gigabyte GV-N570OC-13I 570 GTX (new) / XFX GTX 260 (old)
Nexus NX-6000 R3 630W PSU

What do you think, is is the GPU or the PSU? Is there any sure way to test them? Or could it still be something else?
2 answers Last reply
More about problem dying
  1. PSU.

    They can lose power over time. What may have been a perfectly serviceable supply at the start may be falling behind your gaming needs now.
  2. Confirmed, it indeed was the PSU. Got myself a brand new PSU and the problem disappeared.
Ask a new question

Read More

Homebuilt GPUs Systems