Sign in with
Sign up | Sign in
Your question

Debugging Strange Behaviour

Last response: in Systems
Share
May 15, 2012 8:14:30 PM

Last night I upgraded my home desktop machine with some new components and noticed some oddness and before I really dig into it I wanted to see if these are perhaps known or expected issues.

The complete system is (new components in bold):
Biostar TPower X79
Intel i7-3820 3.6ghz
nVidia GeForce GTX 670 2gb
2x4gb G.SKILL Jaws
3xWestern Digital SATA HDD
1xPlextor SATA SSD
Corsair 750TX PSU
CoolerMaster HAF 932 Case

I think that's everything relevant anyway. I was a bit of an idiot and didn't realize that the motherboard doesn't have an IDE connector and so I would not be able to connect my ancient DVD drive and thus could not install Windows 7 last night. But I do have a LinuxLive (Mint, for the record) USB stick and did some tinkering before bed. I did install the Mint Linux on the SSD but that did not boot. Or, rather, the system kept loading GRUB from the HDD which was my primary boot device in my previous machine, and the SSD was not listed in the BIOS boot options and I'm not enough of a GRUB pro to figure out how to add a new boot option on the fly. More on that below. I'll remedy the DVD drive issue with a stop at Fry's on the way home tonight.

So, the issues I noticed were:

First that the image on the screen was clamped into what I guess is the "safe zone" for TVs. The resolution was set to the monitor's native 1920x1080, but there was a thick black area around the actual display which was centered and clearly being scaled down (text was blurry, etc.). I searched around in my monitor's OSD for some related option but could not find one. I reset the monitor settings to factory default and that changed nothing. I have the monitor plugged into the video card's DVI-1 port. It never did this before.

Second, on initial startup I saw the full-screen BIOS boot no problem, however if I restart the machine the link goes dead until the OS starts up and meanwhile the monitor cycles through inputs. I would not see the full-screen logo, or if I went into setup and turned that off nor would I see the init text screen. If I hammered delete (not knowing exactly what was going on) then eventually after cycling through inputs for a couple minutes, the setup screen would appear. The monitor has never behaved this way before. It's a 24" Samsung SyncMaster, but I wonder if it might be the video card not outputting a signal for some reason. If I power down the machine then power back on, the screen will come up right away. It's just if I restart it either by pressing the reset button or via the OS then it takes a while. With my previous video card (GTX 480) the screen was always shown instantly on startup or reboot, no delay whatsoever.

Third, and I don't know why I didn't check in the LinuxLive what drives were shown, but in OS setup I noticed that it only recognized 2 of the 4 disks I had connected to the SATA ports. It recognized the SSD which I had on SATA2-L, and a HDD that I had on SATA3-L, but the HDDs on SATA2-U and SATA3-U were not listed in the BIOS setup screen / hardware information. Even though the SSD was listed in hardware info, it was not an option in the BIOS's "boot from" menu options. I think I recall seeing more than 2 drives listed in the Mint install partitioner, but I didn't pay much attention to those as at the time I hadn't yet noticed the issue in the BIOS setup. I was only interested in the SSD that I was going to install it on.

I know what things I can do to debug more such as swapping back in the GTX 480, plugging the drives in 1 at a time to different ports, etc. At this point I'm just looking for responses on whether these issues are known and if there might be common solutions I can try first.

Thanks for any help. I'll be able to debug this more thoroughly tonight. I'm hoping it won't take long, Diablo 3 isn't going to play itself.

ETA: I noticed this motherboard has 2 8-pin power connectors. The manual says they should both be plugged in if overclocking. I don't plan to overclock (just yet) and my PSU only has 1 of those plugs. But I do wonder if it will be enough with 3 HDDs + SSD + GTX 670 + i7-3820 + fans?
a b B Homebuilt system
May 15, 2012 9:42:28 PM

in the bios you can set the boot order of your drives. if your primary boot device is physically connected to the Intel controller on SATA0 then it will automatically boot first unless you change it. Devices connected to the 3rd party controller it may not show up in the bios but will be detected after POST.
m
0
l
May 15, 2012 9:45:02 PM

nhasian said:
in the bios you can set the boot order of your drives. if your primary boot device is physically connected to the Intel controller on SATA0 then it will automatically boot first unless you change it. Devices connected to the 3rd party controller it may not show up in the bios but will be detected after POST.


I've been looking at the motherboard manual and diagrams and I think I may have got the order of the SATA connectors backwards. I'll try hooking them up so that the important drives are on the Intel ports. I just wanted to make sure that the SATA is on a 6gb/s port, but I also want to boot off it so hopefully I can do both.
m
0
l
Related resources
a b B Homebuilt system
May 16, 2012 12:30:55 AM

Any chance the linux distribution you used was not upgraded for the new MB/Chipset/CPU/Video combination you are using? All of those parts are bleeding edge, and the "LinuxLive (Mint, for the record) USB stick " could well be older.
m
0
l
May 16, 2012 2:38:27 AM

Probably.

But I have a much worse problem now. I can't install Windows 7. The first phase of install completes fine (copying files, etc) but after reboot there is an error (0xc000000d) that Windows cannot start. I have no idea what to do. Every thread I have read about this says to install raid drivers but a) I am not using raid and b) I don't have an OS.

Any idea whatI can do? Pretty close to punting the machine out of my window at this point.

I disconnected all non-essential drives so only plugged in is dvd drive and the SSD. I also unplugged one of the RAM chips and tested them both individually with a memtest: no errors.

Help. :/ 
m
0
l
May 16, 2012 2:49:13 AM

ok the very next time I tried it and it works. Installing drivers and such now. Hopefully it all still works when I plug the drives back in.
m
0
l
a b B Homebuilt system
May 17, 2012 12:23:56 AM

lol, that never happens to me. much. good luck.

p.s. win7 will not have current drivers for your MB or Video. Grab them from manufacturer -- recommend against letting windows update install them, so install before you enable network.
m
0
l
May 17, 2012 12:54:04 AM

Yep, it's all good now. Before the boot that worked I set both SATA mode options to IDE mode and disabled booting from anything but the cd drive and the SSD that I wanted to boot from, which I plugged into SATA1. I also gave disk drive boot higher priority than UEFI. I'll try the UEFI boot in the future sometime.

I didn't have much choice about downloading since the network device did not have drivers, so I did a full drivers install from the CD that came with the mobo on the first boot. After that everything went perfectly. Incidentally, it still takes forever to install Windows updates even on an SSD.

The screen scaling issue went away once I installed nVidia drivers.

The monitor still cycles inputs on reboot but it's a minor issue that I'm not going to worry about.
m
0
l
!