Sign-in / Sign-up
Your question
Solved

Link Failure for Tiger Direct, Anyone?

Tags:
  • Site Bug Reports
  • Tiger
  • Components
  • Tom's Hardware
Last response: in Forum Feedback
June 10, 2012 2:27:04 AM

This may not be about CPU & components but I get this problem whenever I click the tigerdirect links referred by posters:

http://www.tigerdirect.com/errors/default404us.htm?ev=1...

I receive this all the time & in all PC I use. At the start, I just pass it on but during some deep discussion, a link like this could break the discussion and I do not wish to burden the posters for asking new links or exact specs so that I can google myself. So it does start to bother me.

I am currently in Indonesia so it may be that the link does not work from here. Strangely, I do not have problem with any other site. Is there any way to fix? or a proxy that can bypass whatever restriction there might be?

More about : link failure tiger direct

June 10, 2012 2:47:01 AM

use a different browser?
m
0
l

Best solution

June 10, 2012 4:17:07 AM

I got his from tigerdirect:

We're sorry, but the page requested was not found on TigerDirect.com.

If you've arrived to this page after clicking anywhere on our website, we would
appreciate if you report the issue by adding comments and clicking this button:

BTW, this should be in the forum feedback section.
Share
Related resources
June 10, 2012 4:20:34 AM

This topic has been moved from the section CPU & Components to section Forum Feedback by Pyree
m
0
l
June 10, 2012 4:25:34 AM

amuffin said:
use a different browser?

I already did. Sorry for not telling right away.

I got Chrome & IE in this PC and Firefox & IE in my laptop. Does not work anywhere.
m
0
l
June 10, 2012 4:27:45 AM

Pyree said:
This topic has been moved from the section CPU & Components to section Forum Feedback by Pyree

Okay, thanks. I took note of in case of other feedback in the future.
m
0
l
June 20, 2012 12:15:05 AM

Best answer selected by randomkid.
m
0
l