Sign in with
Sign up | Sign in
Your question

AMD ATI Radeon HD7950 issues

Last response: in Graphics & Displays
Share
March 15, 2012 7:03:00 AM

Hi, Im having issues with this card its a Gigabyte AMD ATI Radeon HD7950 3GB.

Im always getting the "AMD driver has stopped responding" issue.

Here's the interesting part, when i have 16GB (4x4GB sticks) or less in, it seems to be all good. But once I increase it to say 20 or 24GB, I get those driver issues again (just browsing on the desktop through windows and bang! it freezes and goes black for a second then recovers)

My Specs:
CPU: Intel i7 3820 3.60Ghz
MB: Asus p9x79 Pro (Quad channel memory)
VC: Gigabyte AMD Radeon HD 7950 3GB
RAM: 2 x G.Skill Ripjaws Z 16GB (4x4GB)
SSD: Corsair Force Series 3 120gb
HDD: Seagate Barracuda 2TB 7200rpm
CPU Cooler: Cooler Master Hyper 212 EVO
PSU: Antec TruePower TP-750 750W

Please help, I'v been spending days trying to fix this!!
March 19, 2012 7:30:18 PM

Try installing the latest drivers. I always had this problem until I installed the latest drivers.
March 27, 2012 5:16:01 AM

Already tried that.

I solved it! lol...so weird

I overclocked the cpu using the asus suit II to fast then i overclocked to extreme. Then I installed the other 16GB's of RAM. I then discovered that it was running at a lower clock speed around 1300MHz rather than the stock 1600MHz. Its now running smoothly with all 32gb of RAM. So now i put it back to stock cpu clock and RAM clock and all seems to be fine now :) 

I guess its one of those random things were you just need to play around with stuff.
!